WIP [Trinket] [Rebug] [Others] SWITCHBOOT_UF2 / FUSEE_UF2 modchip software

Discussion in 'Switch - Backup Loaders & Modchips' started by mattytrog, Dec 18, 2018.

  1. Gismor

    Gismor GBAtemp Regular

    Member
    4
    Nov 12, 2018
    Germany
    okay have try the same
    and this is my result ReiNX anime girl coming Atmospehre logo is coming and back to switchboot V1.20 screen oO
    but is not a problem for me i dont use ReiNX was only a try ^^ my cfw works perfect
     
    Last edited by Gismor, Apr 3, 2019
  2. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    dupe
     
    Last edited by mattytrog, Apr 3, 2019
  3. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    Hmmm...

    Very strange. You do have the sleep libraries there don't you? You must have these with sept

    @peteruk

    20190403_200314[1].jpg 20190403_200333[1].jpg

    Not my cup of tea but the job went pretty well.

    The joycon housing mouldings aren`t the best. Poorly fitting rails. No way do they click together without a bulge!

    However, with some adjustment and a strip of adhesive, the job is done.
     
    Last edited by mattytrog, Apr 3, 2019
    metaljay, Gismor and peteruk like this.
  4. peteruk

    peteruk GBAtemp Addict

    Member
    13
    Jun 26, 2015

    it looks bloody lovely mate !!! DM incoming sir - thank you !!!
     
  5. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    Joycon sides.

    The moulding on the far edges is messy and not very accurate... But apart from that, the mouldings are a reasonable quality.

    Never going to be as good as Nintendo ones, but then again, thats why Ninty ones are £50. 20190403_205400[1].jpg
     
    Gismor and peteruk like this.
  6. peteruk

    peteruk GBAtemp Addict

    Member
    13
    Jun 26, 2015

    They look pretty gorgeous to me mate, another fantastic modification by your goodself... will maybe make a small video when I get it back and showcase the console with dpad mod and the modchip features

    Thanks for the great work as always :)
     
  7. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    No worries. That is actually how the mouldings are moulded. It isn`t possible to get them fitted any better than that. The plastic is a few microns thicker than standard. I actually adjusted the tabs on the black rail. I didn`t want anything hot or sharp touching the white. I wasn`t sure if they had a painted finish on them or not.
     
    peteruk likes this.
  8. Gismor

    Gismor GBAtemp Regular

    Member
    4
    Nov 12, 2018
    Germany
    okay have never use the sleep libaries will try it tomorrow again thanks for the info ;)

    wow so nice modding.
    i like this style ;)
     
    peteruk likes this.
  9. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    Not my taste. But thats nothing against these mods... I am just an old school "keep it original" old fart.

    I still have a OLED Vita... Only been out the box once to Henkaku it. Still got all plastic / wrapping on it. Just old and boring, thats me.
     
    Last edited by mattytrog, Apr 3, 2019
    peteruk likes this.
  10. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    Tidying up OP... How the hell do you make a video with text showing how the VOL+ options work? I`m shit at stuff like this... :(
     
    peteruk likes this.
  11. smasha

    smasha Member

    Newcomer
    2
    Aug 16, 2018
    Australia
    Updated switchboot part 1 & 2 to 1.20 (old version was working fine), now switch wont boot. Stuck at blank screen, can't get trinket to connect to pc for reflashing now either.
    Pressing vol+ on the blank screen does make the LED turn on (i have all straps fitted).

    Pc wont even recognise that the switch is in RCM mode so i cannot send payload manually through pc either.

    Any ideas on how to recover from this?

    EDIT: managed to fix it, after many reboots of the switch my pc finally recognised it as APX device, sent payload with tegrasmash and reflashed my trinket with barebones hekate. Switchboot part 2 - 1.20 is broken for me.
     
    Last edited by smasha, Apr 4, 2019
  12. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    How are you downloading? Check size of download. It isn't broken I promise!
     
  13. smasha

    smasha Member

    Newcomer
    2
    Aug 16, 2018
    Australia
    I cloned your github, opened the source code in arduino ide, commented all chips except for trinket_rebug and uploaded the sketch.
     
  14. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    What is your payload size? What GCC version are you using? I think you may be using an old version and making the stack overflow.

    Try a prebuilt UF2.

    Forget that... You are using armoured dildo
     
    Last edited by mattytrog, Apr 4, 2019
  15. smasha

    smasha Member

    Newcomer
    2
    Aug 16, 2018
    Australia
    Arduino IDE did tell me I have some board/tools updates which I didn't do, so you might be right, maybe ill try those and try again, or maybe ill try upload via visual studio.

    Also just want to clarify, is this the correct boot process or is something messed up here?

    Hekate bootlogo -> Sept logo - > Hekate bootlogo -> normal switch boot

    I get the Hekate logo before and after Sept showing up. Vol- gets me to hekate boot options screen the first time the logo shows up before Sept, but not the 2nd time after Sept.
     
  16. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    Yes. That is correct. I've just tested again all my code. It checks out 100%.

    So I think you have a lib problem or something in arduino
     
  17. smasha

    smasha Member

    Newcomer
    2
    Aug 16, 2018
    Australia
    Cheers mate, ill give it another shot tomorrow and report back
     
    mattytrog likes this.
  18. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    Just remember... The are three sections to change.

    Comment out all chips apart from your desired one...

    Change board type to match...

    Change com port accordingly.

    You probably already know this, just chucking it out there.

    If all you want to do is change modes, you can hex edit the UF2
     
    smasha likes this.
  19. smasha

    smasha Member

    Newcomer
    2
    Aug 16, 2018
    Australia

    Yep all good, i only want hekate so i normally disable mode change anyways.

    Was no errors during sketch compile/upload so ill try updating the arduino tools+libs and see if that fixes it.

    I just tried loading in the precompiled uf2 and it works 100%, definitely something to do with my setup.

    Thanks again :)
     
    mattytrog likes this.
  20. josete2k

    josete2k GBAtemp Fan

    Member
    5
    Apr 24, 2009
    Spain
    Spain
    Nice feature for SXOS users...

    Now, sorry again if this is an stupid question, but if we have SXOS payload renamed as payload.bin, how can we access to your hekate mod (internal flash) for license.dat restoring?
     
  21. Gismor

    Gismor GBAtemp Regular

    Member
    4
    Nov 12, 2018
    Germany
    its totaly easy :D
    when your switch is power off hold volume + and press power you enter hektate and under tools you find the option restore sx license ;)
     
    josete2k likes this.
  22. josete2k

    josete2k GBAtemp Fan

    Member
    5
    Apr 24, 2009
    Spain
    Spain
    OK, and pressing vol+ after SX logo will show the SXOS menu...

    Thanks....
     
Quick Reply
Draft saved Draft deleted
Loading...