Time on frontpage articles is wrong

Discussion in 'Site Discussions & Suggestions' started by ProtoKun7, Feb 3, 2011.

  1. ProtoKun7
    OP

    ProtoKun7 GBAtemp Time Lord Regenerations: 3

    Global Moderator
    7,513
    1,555
    Jan 3, 2009
    Gallifrey
    I made the i/Evo 2.1 news topic and afterwards I noticed that the time on the portal article was an hour ahead when compared to the actual time, and what appears on the thread itself.

    I'll provide pictures as the way I'm saying it may not make much sense.

    My thread, which was posted at 17:50 (5:50pm) shows that it was posted at 6:50pm on the portal.
    [​IMG] ? [​IMG]
    [/p]

    Another World's article was posted at 6:53am, though the portal says 7:53am.
    [​IMG] ?
    [​IMG][/p]
    (I was going to post this earlier but I had to go)

    It's also a similar situation to the shoutbox, where the timestamps are (still) an hour out of sync, at least in my time zone (among other problems, which I want to mention again, like special character glitches and parsing errors). Maybe the two are related.
     
  2. neotank19

    neotank19 GBAtemp Regular

    Member
    231
    3
    Apr 1, 2010
    United States
    Could it be the "is daylight saving time in effect?" tab is checked in your options and you are not using daylight savings time in your country?
     
  3. Evo.lve

    Evo.lve All that you could be.

    Member
    1,786
    21
    Oct 11, 2010
    Away from you.
    Because that makes so much sense.
     
  4. ProtoKun7
    OP

    ProtoKun7 GBAtemp Time Lord Regenerations: 3

    Global Moderator
    7,513
    1,555
    Jan 3, 2009
    Gallifrey
    My time settings are perfectly fine.
    It's not a fault of mine, it's an error on the site.
     
  5. Lily

    Lily One Scary Lady

    Former Staff
    5,727
    393
    Jun 18, 2004
    Canada
    British Columbia
    ProtoKun7 is correct, this is a bug.

    For me, the CycloDS 2.1 Firmware update says posted at 10:50am, but when I click on the thread it is 9:50am.

    My first guess would be the front page isn't paying attention to your board DST setting.
     
  6. ProtoKun7
    OP

    ProtoKun7 GBAtemp Time Lord Regenerations: 3

    Global Moderator
    7,513
    1,555
    Jan 3, 2009
    Gallifrey
    Seems like that; that makes sense if the server is based in France, which is GMT+1. Unless it happens to be somewhere else or whatever, if it's in a +1 area. I'd imagine that's the same problem as the shoutbox.
     
  7. Lily

    Lily One Scary Lady

    Former Staff
    5,727
    393
    Jun 18, 2004
    Canada
    British Columbia
    I forwarded this on to Costy for you.
     
  8. Minox

    Minox Spytech Employee

    Supervisor
    6,023
    2,602
    Aug 27, 2007
    Since I'm in CET (GMT+1) you could assume that issue would not exist for me in that case, except it does [​IMG]
     
  9. Costello

    Costello Headmaster

    Administrator
    12,393
    5,640
    Oct 24, 2002
    fixed now (I think?), let me know if you see any more problems regarding the date
     
  10. GH0ST

    GH0ST Your Hero is a Ghost

    Member
    924
    1
    Dec 17, 2006
    France
    I was here... before...
    It looks good for me at least same time (now both are 3rd February 2011 - 6:50pm for me )

    Sometimes weird is the popularity like Wood Firmware v1.22 up over 1.23 [​IMG]
     
  11. ProtoKun7
    OP

    ProtoKun7 GBAtemp Time Lord Regenerations: 3

    Global Moderator
    7,513
    1,555
    Jan 3, 2009
    Gallifrey
    Yeah, the article time matches up now (though shoutbox time is still an hour ahead). Thanks for that. [​IMG]