Question SXOS Pro to Atmosphere

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by steve1316, Aug 13, 2019.

  1. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Hello all!

    I have used SXOS Pro this whole time but I want to have Atmosphere too for its sysmodules like sys-clk since SXOS doesn't support sysmodules currently. I use the SXOS Pro Dongle to get to my EMUNAND.

    Switch information:
    Micro SD card formatted to exFAT. My SYSNAND is on 6.1.0 and my EMUNAND is on 8.1.0. Switch is on Auto-RCM.

    The Problem:
    I downloaded Atmosphere 0.9.3 from their GitHub and placed the files into my root along with fusee-primary.bin. I use the SXOS Pro Dongle to then inject the fusee-primary payload but I get a black screen.

    I then downloaded Hekate 5.0.1 and put it into my root and then moved my fusee-primary into the payloads folder inside the bootloader folder. I then used the SXOS Pro Dongle to then inject the hekate_ctcaer_5.0.1.bin. I then went into Payloads and then launched fusee-primary.bin. Atsmosphere screen pops up for a few seconds but then goes to the same black screen.

    I have not tried TetraRCM because I don't have a USB-C cable to connect my switch to my PC or my Samsung phone.
    I have looked online for solutions like trying another CFW like ReiNX. Going from SXOS Pro Dongle to ReiNX results in black screen and going from SXOS Pro Dongle to Hekate to ReiNX shows the ReiNX splash screen and then shortly afterwards, the black screen.

    I would appreciate it if someone can help me.
     
  2. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    did you set up the emummc.ini so it knows where ur emunand is?
     
  3. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Oh, I had no idea that was a thing. Tried searching my micro sd card and I only have emummc.kipm inside my bootloader\sys. Where do I create the emummc.ini?
     
  4. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    Create > emummc folder on the root of the SD

    Create > emummc.ini file inside of emummc folder

    Copy and paste this to emummc.ini

    [emummc]
    enabled = 1
    sector = 0x2
    nintendo_path = Emutendo
     
    Last edited by Mthodmn101, Aug 13, 2019
  5. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Hmm unfortunately, I still encounter the same black screen with both ReiNX and Atmosphere. emummc is like EMUNAND right? Is it noteworthy to know that I created my EMUNAND from the menu in the SXOS Pro Dongle?
     
  6. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    that emummc sector corresponds to where sxos makes the emunand. Not sure why you are getting black screen, must be something else im missing
     
  7. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Hmm, well I created the EMUNAND as a file on my micro sd card and not as a hidden partition. Could that have been it?
     
  8. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    Last edited by Mthodmn101, Aug 13, 2019
  9. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
  10. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    currently, for atmosphere, i believe so, but they are working on optimizing it.
     
    steve1316 likes this.
  11. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Hmm, so I created the EMUNAND hidden partition using SXOS. I added in the emummc.ini from above and I double checked in Hekate and it says under the emuMMC option:

    Enabled!
    Type: SD Raw Partition
    Sector: 0x00000002
    Nintendo folder: Emutendo

    Still getting black screens booting up ReiNX and Atmosphere but SXOS is fine. Below are some pictures of my file structure after installing Atmosphere and ReiNX again.

    Capture.PNG

    Capture2.PNG

    Capture3.PNG

    Capture4.PNG

    Is this all because I'm booting from SXOS Pro Dongle -> Hekate -> ReiNX/Atmosphere?
    Is the boot.dat from SXOS Pro set up in such a way that I can only have 1 CFW or the other on one sd card?
     
  12. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    what happens if you load fusee primary from sx os menu ?
     
  13. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Black screen, same thing for ReiNX
     
  14. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    and this is atmos 0.9.3 ? my sept folder file sizes are slightly different



    only thing i needed to get my sxos emunand partition to boot to atmosphere was copy 0.9.3 extracted over to my sd card, and add the emummc folder with the ini
     
    Last edited by Mthodmn101, Aug 13, 2019
  15. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Yeah, I downloaded their latest release and their file name is "atmosphere-0.9.3-master-25218795+hbl-2.2+hbmenu-3.1.0.zip"
     
  16. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    Yeah looks like SXOS blocked booting directly into fusee-primary, so going into hekate to boot atmos shouldve worked. Reinx also shouldve worked but it doesnt support emunand.
     
  17. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    Ah that really sucks. Thanks for your help so far x.x
     
  18. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States

    Try booting up with this boot.dat and let me know if it works with the SX Dongle. Its the Atmos payload converted to boot.dat
     

    Attached Files:

  19. steve1316
    OP

    steve1316 Member

    Newcomer
    1
    Dec 24, 2013
    United States
    OH IT WORKED! I did the button combination to boot up using my SX Dongle and the screen showed Atmosphere, and then ReiNX. Got past the black screen and I was able to get to the home screen. Seems that I'm on 6.1.0 ReiNX(0.0) even though my EMUNAND was updated to 8.1.0.

    Couple of questions now: Is there a different button combination now to access SXOS now or is it just going to boot straight to ReiNX now? Also, I can't tell if I'm on SYSNAND or EMUNAND.
     
  20. Mthodmn101

    Mthodmn101 GBAtemp Fan

    Member
    6
    Jan 31, 2008
    United States
    there is no emunand for reinx, so you are in cfw on your sysnand. So if you plan to stay clean on sysnand, get out :)


    that boot.dat shouldve booted atmosphere, not reinx though. This boot.dat just allows the booting of atmosphere, so cant go back to sxos using it. Perhaps that SX Reboot to Payload will let you though


    get rid of the reinx stuff on your sd card, and just keep atmosphere files, and it should boot into atmosphere emunand

    when u copied reinx, you prob overwrote some of the atmos files, so just stick with atmos stuff for now
     
    Last edited by Mthodmn101, Aug 13, 2019
Loading...