SWITCH NOOB PARADISE - Ask questions here

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by epickid37, Nov 1, 2017.

  1. P4wn4g3

    P4wn4g3 Advanced Member

    Newcomer
    3
    Nov 1, 2011
    United States
    Over Here
    The reason I ask is I realized I have been making some assumptions which may not be correct. For example when I asked about the exFat patch earlier you said If I want to be safe I should never go online in the first place. I haven't used the 3DS mods, just the Wii. With the mod I did to the Wii it was safe to go online eventually, and also eventually safe to do updates. The CFW also allowed us to play games without updating and to use Eshop without updating. That's really all I want to do, apart from using emulators to basically put my entire game collection on the Switch and maybe some custom video channels if they exist in the future. So my goal for installing Atmosphere in the first place would just be to access Eshop and stuff and still have a 4.1.0 system. I assume my Wii had a ban risk too, but it never happened to me so eh.
     
  2. jimbo504

    jimbo504 Member

    Newcomer
    1
    May 6, 2018
    United States
    If I'm on 1.0.0 do I need the japanese Puyo to install the browser still or will that not be an issue once Atmosphere comes?
     
  3. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
    Neither SX OS nor Atmosphere are released. Using Hekate, we have access to a very early build of Atmosphere that allows us to use homebrew. Using CFW will always present a ban risk as it is a modification of your device without Nintendo's permission. Of course, very rarely are people banned for using just a CFW. They usually do something else stupid that warrants a ban. Since neither of them are out yet, we don't know what will guarantee a ban

    Unfortunately, this is all still speculation as Atmosphere has not been finished yet. Obviously, the goal is to make it as safe and undetectable as possible but it can never truly be 100% ban-free. The exFAT update for example should not be on a Switch without connecting to Nintendo but we cannot say if Nintendo can detect this and subsequently start banning users. For you, it would be best to use EmuNAND to run games that require higher firmware as we can control its firmware much easier than SysNAND's. Not sure if Atmosphere can and will implement spoofing when we have EmuNAND, but we shall see.

    You can follow a tutorial here: https://gbatemp.net/threads/how-to-transplant-savedata-system-and-user-from-other-switches.506840/
    However it appears to not be entirely user-friendly, but there is now a way to install Fake News without Puyo-Puyo.
     
    P4wn4g3 likes this.
  4. Matchitza

    Matchitza Advanced Member

    Newcomer
    2
    May 27, 2017
    Indonesia
    Will atmosphere give me the ability to play "backups"? Was asking so that I can dump my cartridge games and install them in the SD Card once CFW comes out so I don't have to waste time on switching cartridges when I'm done playing a game.


    EDIT: Also in the future will there be an option to access homebrew on 5.x+ without having to play around with a paperclip?
    ik its risk free compared to other hardmods but the process is kinda tedious imo

    if you saw through my first question good job but i'm still asking seriously
     
    Last edited by Matchitza, Jun 13, 2018
  5. Calevala

    Calevala Member

    Newcomer
    2
    Jun 13, 2018
    Russia
    I bought Switch and it on 1.0.0.
    Any benefits of staying on that firmware, or I can buy a game with <3.0.0 on cart?
     
  6. horokeusama

    horokeusama GBAtemp Regular

    Member
    4
    Jan 5, 2011
    Brazil
    Rio de Janeiro
    Is Atmosphere still scheduled for june 15th? I don't remember where i saw this exact date but it kinda stuck into my mind.
    Also, when it gets released, will it be easier to get a warmboot (without a jig) for those on 4.1.0?
     
  7. P4wn4g3

    P4wn4g3 Advanced Member

    Newcomer
    3
    Nov 1, 2011
    United States
    Over Here
    Is the EmuNAND you are mentioning part of Atmosphere or is that just available already? I know there are some Homebrew solutions available, but I'd like something at least a little permanent. I don't mind doing a special boot off an SD card.
     
  8. epickid37
    OP

    epickid37 ( ͡° ͜ʖ ͡°)

    Member
    7
    Jan 4, 2017
    United States
    mushroom kingdom
    Eventually there will be a backup loader for atmosphere, but we don't know when someone will create one. There might be a way to boot RCM without shorting pin 10, but that's unlikely
    1.0.0 doesn't require you to short pin 10 to access RCM. Essentially you don't have to hardmod.
    No one really knows. I doubt it'll be released on the 15th. There's an unreleased warmboot exploit for 4.1.0 iirc, but it won't release for a long time.
    Emunand isn't available yet
     
    P4wn4g3 likes this.
  9. Calevala

    Calevala Member

    Newcomer
    2
    Jun 13, 2018
    Russia
    So only 1.0.0 have this feature?

    Well, I hope emunand will be available soon. I cant even use my SD card.
     
  10. mrtzera

    mrtzera Member

    Newcomer
    1
    May 25, 2018
    Brazil
    I can install any homebrew on fw 2.3.0 or i need up to 3.0.0? if i can, is it through RCM mode?
     
  11. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
    Not in the foreseeable future, but its not impossible. For example, there is an exploit that has been tested to work up to 4.1 but has not been released yet due to the fact that it hasn't been tested on 5.X yet. So once they get a chance to test it on those firmwares, we'll know what options 5.X has available outside of RCM.

    Basically what epickid said. Soon (TM)

    You can install Fake News via buying Puyo-Puyo Tetris. If you want to install it without Fake News, you would follow this guide: https://gbatemp.net/threads/how-to-transplant-savedata-system-and-user-from-other-switches.506840/

    Yes, just follow this guide using RCM: https://gbatemp.net/threads/guide-1-x-5-x-how-to-run-homebrew-on-your-nintendo-switch.506529/
     
    P4wn4g3 and mrtzera like this.
  12. epickid37
    OP

    epickid37 ( ͡° ͜ʖ ͡°)

    Member
    7
    Jan 4, 2017
    United States
    mushroom kingdom
    i'm a complete noob when it comes to switch linux, and the battery desync issue, so heres a question of my own. i opened up my switch, disconnected the battery, held the power button for a couple minutes, then spammed it a bunch. After that, i reconnected everything and closed up the switch. after all that i found that the switch wont turn on at all without the charger plugged in, and it will display the nintendo logo, then shut off when the charger is plugged in. What did i do wrong?
    Edit: Fixed! I didn't connect the battery correctly
     
    Last edited by epickid37, Jun 14, 2018
  13. Nerdtendo

    Nerdtendo Your friendly neighborhood idiot

    Member
    6
    Sep 29, 2016
    United States
    I know this question has been asked a bazillion times but opinions are split and I request someone who knows 100% what they're talking about to answer.

    Is setting up Auto RCM and the Linux port (I'm confused about the entire Linux thing but whatever) safe or risky? Is it better to use that, for things like Lakka or should I stick with heckate?

    Is retroarch still being updated for heckate or has all manpower gone to Lakka?

    Is there a dedicated thread to get the most recent retroarch?
     
  14. qaz015393

    qaz015393 GBAtemp Advanced Fan

    Member
    4
    Jan 28, 2009
    United States
    Has anyone been able to get Pegaswitch on a 2.20 Switch? I want to know if the tutorial works before I try it just incase it ends up making me update it.
     
  15. Nevarc

    Nevarc Newbie

    Newcomer
    1
    Jun 14, 2018
    Australia
    Hey I've got a noob jig question. I was planning to make an RCM jig by soldering a spare part out of a right joycon. Just wondering before I do it, I've seen some guides refer to pins 1, 2 and 7 as the ones to ground to 10, but I've also seen some guides advise soldering 9 & 10. Is pins 9 & 10 an actually viable option? I just ask cause it's a much easier job than getting 1, 2 or 7 bridged.
     
  16. Irastris

    Irastris GBAtemp Maniac

    Member
    6
    May 3, 2015
    United States
    Wait for someone else to answer before proceeding as I may be talking out of my ass, but I recall reading a post that pin 9 isn't always ground and that's why it's not recommended to use it.
     
  17. Nerdtendo

    Nerdtendo Your friendly neighborhood idiot

    Member
    6
    Sep 29, 2016
    United States
    I never heard of 2 being an option. Only 1, 7, and 9 are viable. I always use 9 but there's been some controversy as to if 9 may cause problems. I'd say your best bet is 1.
     
  18. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
    Both Lakka and Linux will cause the battery to become de-synced with the Switch. If you want to use either, I would advise that you have the Switch at 100% before you turn it on and charge it to 100% before you exit Lakka/Linux. If the percentage is off even a little bit, you may see the effects of the battery problem. This seems to be the place for all progress and updates to Retroarch: https://gbatemp.net/threads/development-thread-retroarch-libnx.505672/

    If you have the proper DNS blocked, you should be able to use PegaSwitch without downloading an update. Although PegaSwitch has slowly been falling out of favor due to the power of RCM.

    Here is a list of the pins and their functions: https://reswitched.tech/hardware/joycon
    Also, pin 9 is not a reliable ground because it only counts as grounded with the Joy-Con connected to the Switch. Thus, pins 1 and 7 are the most reliable.
     
  19. Viri

    Viri GBAtemp Addict

    Member
    10
    Sep 13, 2009
    United States
    Did they ever figure out a way to block the "Super update" that stopped 3.0.0 and below users from using web browser hack? I want to use the homebrew launcher, without going into RCM. I'm on 3.0.0 :)
     
  20. P4wn4g3

    P4wn4g3 Advanced Member

    Newcomer
    3
    Nov 1, 2011
    United States
    Over Here
    So waiting for Atmosphere to release will not provide emuNAND and isn't what I'm looking for?

    So I have another question then. Seeing as the Homebrew scene seems to be moving rapidly now and 5.1.0 is essentially supported, would there be any harm in updating at this point and using my switch to its fullest extent? There are several summer releases I plan on buying. I was hoping to blockquote the updates but if it's a choice between using homebrew or using the system I'm obviously just going to update, I just want to know how that limits me first.
     
Loading...