1. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    Now repeat this command:

    pacman -Sy


    If everything it's update, proceed with this command:

    pacman -Sl dkp-libs

    And install all the libs under 3DS voices.....Once finished place your folder (sm64-port) included your backup game .z64 into: C:\Users\"your User name Compurter"/sm64-port

    I hope you open the right MSys with the name mingw64 or 32, with the command cd sm64-port you will be into the folder that you placed above and write the command make .

    And you should be fine.

    Ok, for my little studying around it seems the newest RENDER96 versions 1.4/2.0 or above will not be compatible because they are implemented for the DirectX where the Wii U use the OpenGL and now for me it makes sense why the new textures are incompatible between the two emulations between PC version and Wii U version.

    But as per my understanding in theory the RENDER96 package 1.3 version should be compatible, yesterday I tried again to replace the files and after other few manual fix I got the .rpx, so everything it's works till the initial Menu but once I press to start the game I got the white screen. I believe as noob under this point, I mistake something, because should be the DevKit to extract the new texture and replace them automatically without my manual action. I begging the author of this post to explain how to do it because I saw also his video in Youtube and I found the github experimental for Wii U to implement such new texture on it. But I need the help of some one here, please @AboodXD can you help here ......

    Below, are the Youtube video and Github repository:

    Youtube:

    GitHub: https://github.com/aboood40091/sm64ex/tree/nightly

    cheers

    PS: just then I noticed that the video and the source GitHub addresses are the same as the first page on this topic

    @elk1007 let me know please if you solved this issue, if not we can try to your old GBAtemp post and continue there this topic, also because now I try with a new repository to build up some test and I got this annoying error Audio CPP problem
     
    Last edited by CrisMod, Dec 16, 2020
    danielglzt88 likes this.
  2. AboodXD

    OP AboodXD I hack NSMB games, and other shiz.
    Member

    Joined:
    Oct 11, 2014
    Messages:
    2,859
    Country:
    United Arab Emirates
    There haven't been any major updates on performance yet. There is just so much to do and so little time.
    My free time is only short, disconnected periods, which I don't feel comfortable in to work on big projects I don't know long working on them will take. Hopefully this will change by the winter holiday.
    Any texture mod made for sm64ex will work in the Wii U port, but there are things to note:
    1. The Wii U only has 1 GB RAM, so, extremely high-res texture packs that go above this size will not work due to hardware constraints. (since sm64ex tries to load the entire thing into RAM at once, instead of reading whichever file when needed)
    2. You should be careful around any model replacements that use shader combinations not used in the original game; those don't have a corresponding shader in the Wii U port and will render invisible.

    Render64 suffers from the second issue, and therefore I added an ubershader when testing it (which can be found on a separate branch), which is really slow. (but not the only reason why Render64 is currently really laggy)
     
    GABO1423 likes this.
  3. elk1007

    elk1007 GBAtemp Regular
    Member

    Joined:
    Jun 23, 2017
    Messages:
    121
    Country:
    United States

    Ok, I did that. I am still not able to install the dkp-libs repositories.

    Code:
    $ pacman -Sl dkp-libs
    dkp-libs 3ds-bulletphysics 2.87-4
    dkp-libs 3ds-bzip2 1.0.6-3 [installed]
    dkp-libs 3ds-curl 7.69.1-1
    dkp-libs 3ds-examples 20200716-2 [installed]
    dkp-libs 3ds-flac 1.3.2-1
    dkp-libs 3ds-flite 2.1-2
    dkp-libs 3ds-freetype 2.9-2 [installed]
    dkp-libs 3ds-jansson 2.13-1
    dkp-libs 3ds-libarchive 3.1.2-3
    dkp-libs 3ds-libconfig 1.7.2-3
    dkp-libs 3ds-libid3tag 0.15.1b-2
    dkp-libs 3ds-libjpeg-turbo 1.5.3-2 [installed]
    dkp-libs 3ds-libjson-c 0.13.1-2
    dkp-libs 3ds-liblzma 5.2.3-1
    dkp-libs 3ds-libmad 0.15.1b-1 [installed]
    dkp-libs 3ds-libogg 1.3.3-2 [installed]
    dkp-libs 3ds-libopus 1.3-1
    dkp-libs 3ds-libpng 1.6.37-1 [installed]
    dkp-libs 3ds-libsidplay 1.36.60-1
    dkp-libs 3ds-libtheora 1.2.0alpha1-1
    dkp-libs 3ds-libvorbisidec 1.2.1-3 [installed]
    dkp-libs 3ds-libxmp 4.4.1-2
    dkp-libs 3ds-mbedtls 2.16.6-1
    dkp-libs 3ds-mikmod 3.3.11.1-1 [installed]
    dkp-libs 3ds-mpg123 1.25.13-1
    dkp-libs 3ds-opusfile 0.11-1
    dkp-libs 3ds-physfs 3.0.2-2
    dkp-libs 3ds-pkg-config 0.28-5 [installed]
    dkp-libs 3ds-sdl 1.2.15-15 [installed: 1.2.15-14]
    dkp-libs 3ds-sdl_gfx 2.0.25-2 [installed]
    dkp-libs 3ds-sdl_image 1.2.12-3 [installed]
    dkp-libs 3ds-sdl_mixer 1.2.12-9 [installed]
    dkp-libs 3ds-sdl_ttf 2.0.11-2 [installed]
    dkp-libs 3ds-tinyxml2 6.0.0-2
    dkp-libs 3ds-wildmidi 0.4.3-2
    dkp-libs 3ds-zlib 1.2.11-2 [installed]
    dkp-libs armv4t-bzip2 1.0.8-1
    dkp-libs armv4t-zlib 1.2.11-1
    dkp-libs citro2d 1.4.0-1 [installed]
    dkp-libs citro3d 1.6.1-1 [installed]
    dkp-libs default-arm7 0.7.4-7 [installed]
    dkp-libs deko3d 0.2.0-1 [installed]
    dkp-libs devkita64-rules 1.0.1-2 [installed]
    dkp-libs devkitarm-crtls 1.1.0-1 [installed]
    dkp-libs devkitarm-rules 1.2.1-2 [installed]
    dkp-libs devkitppc-rules 1.1.0-1 [installed]
    dkp-libs devkitpro-pkgbuild-helpers 2.2.0-1
    dkp-libs dswifi 0.4.2-1 [installed]
    dkp-libs gamecube-examples 20200609-1 [installed]
    dkp-libs gamecube-pkg-config 0.28-5 [installed]
    dkp-libs gamecube-sdl 1.2.15-3
    dkp-libs gamecube-sdl_gfx 2.0.25-2
    dkp-libs gamecube-sdl_image 1.2.12-3
    dkp-libs gamecube-sdl_mixer 1.2.12-1
    dkp-libs gamecube-sdl_ttf 2.0.11-2
    dkp-libs gba-examples 20190122-1 [installed]
    dkp-libs gp2x-core 1.2.0-1
    dkp-libs gp2x-examples 1.2.0-1
    dkp-libs gp2x-pkg-config 0.29-1
    dkp-libs gp32-examples 20051021-2 [installed]
    dkp-libs libctru 2.0.0-2 [installed]
    dkp-libs libfat-gba 1.1.5-1 [installed]
    dkp-libs libfat-gp2x 1.2.0-1
    dkp-libs libfat-nds 1.1.5-1 [installed]
    dkp-libs libfat-ogc 1.1.5-2 [installed]
    dkp-libs libfilesystem 0.9.14-2 [installed]
    dkp-libs libgba 0.5.2-2 [installed]
    dkp-libs libmirko 0.9.8-1 [installed]
    dkp-libs libnds 1.8.1-2 [installed]
    dkp-libs libnx 3.3.0-2 [installed]
    dkp-libs libogc 2.1.0-1 [installed]
    dkp-libs libtonc 1.4.3-3 [installed]
    dkp-libs maxmod-gba 1.0.14-1 [installed]
    dkp-libs maxmod-nds 1.0.14-1 [installed]
    dkp-libs nds-bzip2 1.0.6-3
    dkp-libs nds-examples 20200727-1 [installed]
    dkp-libs nds-freetype 2.9-1
    dkp-libs nds-libexpat 2.2.5-1
    dkp-libs nds-libpng 1.6.37-1
    dkp-libs nds-pkg-config 0.28-4 [installed]
    dkp-libs nds-zlib 1.2.11-1
    dkp-libs orcus 1.2.0-1
    dkp-libs ppc-bzip2 1.0.6-2 [installed]
    dkp-libs ppc-freetype 2.9.1-2 [installed]
    dkp-libs ppc-glm 0.9.9.2-2 [installed]
    dkp-libs ppc-jansson 2.12-1 [installed]
    dkp-libs ppc-libgd 2.2.5-2 [installed]
    dkp-libs ppc-libjpeg-turbo 1.5.3-4 [installed]
    dkp-libs ppc-libmad 0.15.1b-2 [installed]
    dkp-libs ppc-libmodplug 0.8.8.5-1 [installed]
    dkp-libs ppc-libogg 1.3.3-3 [installed]
    dkp-libs ppc-libpng 1.6.37-1 [installed]
    dkp-libs ppc-libvorbis 1.3.6-1 [installed]
    dkp-libs ppc-libvorbisidec 1.2.1-2 [installed]
    dkp-libs ppc-mpg123 1.25.10-3 [installed]
    dkp-libs ppc-mxml 2.11-2 [installed]
    dkp-libs ppc-ode 0.16.1-1 [installed]
    dkp-libs ppc-pkg-config 0.28-5 [installed]
    dkp-libs ppc-zlib 1.2.11-2 [installed]
    dkp-libs switch-bulletphysics 2.88-2
    dkp-libs switch-bzip2 1.0.6-3
    dkp-libs switch-curl 7.69.1-3
    dkp-libs switch-examples 20200528-2 [installed]
    dkp-libs switch-ffmpeg 4.2.2-1
    dkp-libs switch-flac 1.3.2-4
    dkp-libs switch-freetype 2.10.1-1
    dkp-libs switch-giflib 5.1.4-1
    dkp-libs switch-glad 0.1.27-1
    dkp-libs switch-glfw 3.3.2-1
    dkp-libs switch-glm 0.9.9.7-1
    dkp-libs switch-jansson 2.11-1
    dkp-libs switch-libass 0.14.0-1
    dkp-libs switch-libconfig 1.7.2-3
    dkp-libs switch-libdrm_nouveau 1.0.1-1
    dkp-libs switch-libexpat 2.2.5-1
    dkp-libs switch-libfribidi 1.0.4-1
    dkp-libs switch-libgd 2.2.5-2
    dkp-libs switch-libjpeg-turbo 1.5.3-2
    dkp-libs switch-libjson-c 0.13.1-2
    dkp-libs switch-liblzma 5.2.4-1
    dkp-libs switch-liblzo2 2.10-1
    dkp-libs switch-libmad 0.15.1b-1
    dkp-libs switch-libmikmod 3.3.11.1-2
    dkp-libs switch-libmodplug 0.8.8.5-1
    dkp-libs switch-libmpv 0.30.0-2
    dkp-libs switch-libogg 1.3.4-1
    dkp-libs switch-libopus 1.3-2
    dkp-libs switch-libpcre2 10.33-1
    dkp-libs switch-libpng 1.6.37-1
    dkp-libs switch-libsamplerate 0.1.9-1
    dkp-libs switch-libsodium 1.0.18-1
    dkp-libs switch-libssh2 1.9.0-1
    dkp-libs switch-libtheora 1.1.1-2
    dkp-libs switch-libtimidity 0.2.6-1
    dkp-libs switch-libvorbis 1.3.5-2
    dkp-libs switch-libvorbisidec 1.2.1-2
    dkp-libs switch-libvpx 1.8.0-1
    dkp-libs switch-libwebp 1.0.2-1
    dkp-libs switch-libxml2 2.9.8-3
    dkp-libs switch-libzstd 1.4.4-1
    dkp-libs switch-mbedtls 2.16.6-3
    dkp-libs switch-mesa 20.1.0-1
    dkp-libs switch-miniupnpc 2.1.20190824-1
    dkp-libs switch-mpg123 1.25.10-3
    dkp-libs switch-ode 0.16.1-1
    dkp-libs switch-oniguruma 6.9.2-1
    dkp-libs switch-opusfile 0.10-3
    dkp-libs switch-physfs 3.0.2-1
    dkp-libs switch-pkg-config 0.28-4 [installed]
    dkp-libs switch-sdl2 2.0.12-3
    dkp-libs switch-sdl2_gfx 1.0.4-2
    dkp-libs switch-sdl2_image 2.0.4-1
    dkp-libs switch-sdl2_mixer 2.0.4-2
    dkp-libs switch-sdl2_net 2.0.1-3
    dkp-libs switch-sdl2_ttf 2.0.15-1
    dkp-libs switch-smpeg2 2.0.0-1
    dkp-libs switch-tinyxml2 6.0.0-2
    dkp-libs switch-wslay 1.1.0-1
    dkp-libs switch-zlib 1.2.11-2
    dkp-libs switch-zziplib 0.13.69-3
    dkp-libs wii-examples 20200609-1 [installed]
    dkp-libs wii-pkg-config 0.28-5 [installed]
    dkp-libs wii-sdl 1.2.15-7
    dkp-libs wii-sdl_gfx 2.0.25-3
    dkp-libs wii-sdl_image 1.2.12-2
    dkp-libs wii-sdl_mixer 1.2.12-9
    dkp-libs wii-sdl_ttf 2.0.11-3
    dkp-libs wiiu-pkg-config 0.28-4 [installed]
    dkp-libs wiiu-sdl2 2.0.9-3 [installed]
    dkp-libs wiiu-sdl2_gfx 1.0.4-1
    dkp-libs wiiu-sdl2_image 2.0.4-2
    dkp-libs wiiu-sdl2_mixer 2.0.4-5
    dkp-libs wiiu-sdl2_ttf 2.0.15-2
    dkp-libs wut 1.0.0_beta11-1 [installed]
    
    
    
    $ pacman -S dkp-libs 3ds-bulletphysics
    error: target not found: dkp-libs
    
    I don't understand how dkp-libs is found with Packman -Sl but not with -S

    Additionally, if I try to upgrade an existing package (which says [installed] ) I get a similar message:


    Code:
    $ pacman -U dkp-libs 3ds-bzip2
    loading packages...
    error: 'dkp-libs': could not find or read package
    error: '3ds-bzip2': could not find or read package
    
     
    Last edited by elk1007, Dec 16, 2020
  4. mive

    mive GBAtemp Regular
    Member

    Joined:
    Jul 19, 2018
    Messages:
    117
    Country:
    Germany
    dkp-libs is the name of the repository, not a package or group name. thats why you get the error messages.

    Code:
    usage:  pacman {-S --sync} [options] [package(s)]
    options:
      -b, --dbpath <path>  set an alternate database location
      -c, --clean          remove old packages from cache directory (-cc for all)
      -d, --nodeps         skip dependency version checks (-dd to skip all checks)
      -g, --groups         view all members of a package group
                           (-gg to view all groups and members)
      -i, --info           view package information (-ii for extended information)
      -l, --list <repo>    view a list of packages in a repo
      -p, --print          print the targets instead of performing the operation
      -q, --quiet          show less information for query and search
      -r, --root <path>    set an alternate installation root
    ...
    
    btw, why do want to install 3ds stuff?
     
  5. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    Hi @elk1007, I understand why will not install them, it's my fault sorry, because I mistake to wrote you; to install each of them you have to write as following example in the command:

    pacman -S 3ds-bulletphysics

    So without the 'dkp-libs' and version '2.87-4' now you will see that will be able to install it
     
    Last edited by CrisMod, Dec 16, 2020
  6. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    Thank you so so much to reply @AboodXD , I can imagine that will take you so long to implement such things that by the way congrats for the great job that you are doing;).

    @AboodXD , I have last question that it's driving me crazy this story, last time with the DevKitPro I got the error as @elk1007 (as below),
    So, now, I start to mess up with the libs because I'm tryng to help @elk1007, and then for funny thing I enter in this vortex of this error. Which means, I try to make it more clear as much as i can, because I believe that I'm not the unique one:

    1) Latest DevKitPro 3.0.3.exe
    2) Open the MSys2 mingw64 (because I have Win 7 64bit) in C:\devkitPro\msys2\mingw64
    3) pacman -Syu and pacman -Su (to ugrade the packages)
    3) Installed the following command: pacman -S wiiu-dev (for Wii U as following x this site https://devkitpro.org/wiki/Getting_Started )
    3) Next command: pacman -S git make python3 wiiu-sdl2 (as x your repository instraction https://github.com/aboood40091/sm64-port )
    4) Next command: git clone https://github.com/aboood40091/sm64-port.git (to download your repository into (C:\Users\"My User Account'\sm64-port)
    5) Place my backup baserom.us.z64 in the sm64-port directory
    6) Open again the MSys2 by mingw64 and write the command: cd sm64-port
    7) Next command: make (or make -j4 as x preferences)
    8) Get an error of gcc not such directory and so on
    9) Command: gcc -v and in fact it miss the gcc
    10) Install the gcc with the command: pacman -S gcc
    11) Command: make (or make -j4 as x preferences) and in building get the error of audiofile.cpp: In function ‘status _afOpenFile(int, File*, const char*, _AFfilehandle**, AFfilesetup)’: ..... as above.

    So, from this moment the build it's stuck. Last time to unlock this situation and in the end was working fine I made and installed few libs by checking with this command pacman -Sl dkp-libs and try to install the MSys2 separately; I took from this site https://www.msys2.org/ , and tried with the sm64pcbuilder2 from here https://sm64pc.info/sm64pcbuilder2/ to test if the problem was my Pc or something else.
    So the sm64pcbuilder2, install all the libs in the separated MSys2 in C:\msys64\mingw64 (so not the one MSys2 that it's installed into the DevkitPro) and everything that the build needs to build for the PC environment by it self, and in the end can do for you the sm64 porting for pc in easy way....
    So, last time when I go back in the MSys2 mingw64 from C:\devkitPro\msys2\mingw64
    I tried the command make and magically the audio.cpp error dessapear and working everything with succesfully made the .rpx.
    Now, I have the same situation and I cannot let it to work again. For my understand it's not the audio.cpp command that it's compiled bad, but should be the gcc that has some problem or some lib that create this kind of bug in MSys2 in C:\devkitPro\msys2\mingw64. Because if I use the MSys2 mingw64 located C:\devkitPro\msys2\mingw64 with the software autobuild sm64pcbuilder2 I will get the same error of audio.cpp and plus the software cannot install some few repository related to Windows that calls SDL or SDL2 (and everytime you use this MSys2 in this DevKitPro location, you open the software and will get this error that cannot be installed these libs, but if you continue to build up by the sm64pcbuilder2 it will stuck on the audio.cpp problem. For this reason I believe that the problem it's some lib missing related...

    Do you have any idea what can I test here? Or if you notice that I'm missing some lib or somenthig else can you please tell me? Last thing, when i install the DevKitPro I see some repository error because cannot reach some few sourch site address to download some few repository, could be this the problem?
     
    Last edited by CrisMod, Dec 16, 2020
  7. AboodXD

    OP AboodXD I hack NSMB games, and other shiz.
    Member

    Joined:
    Oct 11, 2014
    Messages:
    2,859
    Country:
    United Arab Emirates
    You need "mingw-w64-x86_64-gcc". You cannot use plain gcc.
    Uninstall the first gcc you installed, install this one, run "make clean" to revert any changes the first gcc could have made and then follow the instructions normally.
     
    Last edited by AboodXD, Dec 16, 2020
    GABO1423 likes this.
  8. mive

    mive GBAtemp Regular
    Member

    Joined:
    Jul 19, 2018
    Messages:
    117
    Country:
    Germany
    strdup is a function declared in strings.h, not sure why you get this error on windows (and why it did disappear)

    edit:
    see above
     
  9. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    This it's the problem, I get the error with this command: pacman -S mingw-w64-x86_64-gcc
    As below:

    $ pacman -S mingw-w64-x86_64-gcc
    error: target not found: mingw-w64-x86_64-gcc

    I did tried to looking for, in this site, to install the entire libs: https://www.devdungeon.com/content/install-gcc-compiler-windows-msys2-cc

    Whre with this command you can install by pacman -S mingw-w64-x86_64-toolchain

    And If try to install the toolchain will tell me all of them errors that cannot be installed , but if I try to install the toolchain in or from MSys2 in C:\msys64\mingw64 (so located in different position from the DevKitPro) it will install them.

    Any Idea? I really would like to solve it to give this to whom will have the same problem

     
    Last edited by CrisMod, Dec 16, 2020
  10. mive

    mive GBAtemp Regular
    Member

    Joined:
    Jul 19, 2018
    Messages:
    117
    Country:
    Germany
    check available packages with pacman -Ss mingw
     
  11. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    It gives me this:
     
  12. mive

    mive GBAtemp Regular
    Member

    Joined:
    Jul 19, 2018
    Messages:
    117
    Country:
    Germany
    first deinstall gcc like @AboodXD said (pacman -Rcns package_name).
    check afterwards if mingw stuff is still installed
    try to compile
     
  13. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    And I go back to this gcc error as before install the pacman -S gcc.

    This below:

    $ make
    make: gcc: No such file or directory
    make: *** [Makefile:66: n64graphics] Error 127
    Traceback (most recent call last):
    File "./extract_assets.py", line 292, in <module>
    main()
    File "./extract_assets.py", line 162, in main
    subprocess.check_call(
    File "/usr/lib/python3.8/subprocess.py", line 364, in check_call
    raise CalledProcessError(retcode, cmd)
    subprocess.CalledProcessError: Command '['make', '-s', '-C', 'tools/', 'n64graphics', 'skyconv', 'mio0', 'aifc_decode']' returned non-zero exit status 2.
    Makefile:209: *** Failed to extract assets. Stop.


     
  14. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    I made as @AboodXD told me, and I installed even all the mingw stuff available as below:

    $ pacman -Ss mingw
    msys/ccache 3.7.11-1 [installed]
    A compiler cache (mingw-w64)
    msys/libelf 0.8.13-2 [installed]
    ELF object file access library (mingw-w64)
    msys/mingw-w64-cross-binutils 2.35.1-1 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    A set of programs to assemble and manipulate binary and object files
    msys/mingw-w64-cross-crt-git 9.0.0.6029.ecb4ff54-2 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    MinGW-w64 CRT for cross-compiler
    msys/mingw-w64-cross-gcc 10.2.0-1 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    Cross GCC for the MinGW-w64
    msys/mingw-w64-cross-headers-git 9.0.0.6029.ecb4ff54-2 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    MinGW-w64 headers for cross-compiler
    msys/mingw-w64-cross-tools-git 9.0.0.6029.ecb4ff54-2 (mingw-w64-cross-toolchain mingw-w64-cross)
    MinGW-w64 headers for cross-compiler
    msys/mingw-w64-cross-windows-default-manifest 6.4-2 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    Default Windows application manifest
    msys/mingw-w64-cross-winpthreads-git 9.0.0.6029.ecb4ff54-2 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    MinGW-w64 winpthreads library for cross-compiler
    msys/mingw-w64-cross-winstorecompat-git 9.0.0.6029.ecb4ff54-2 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    MinGW-w64 winRT compat library
    msys/mingw-w64-cross-zlib 1.2.11-1 (mingw-w64-cross-toolchain mingw-w64-cross) [installed]
    Compression library implementing the deflate compression method found in
    gzip and PKZIP
    dkp-libs/3ds-freetype 2.9-2 (3ds-portlibs) [installed]
    TrueType font rendering library (mingw-w64)


    When I press make :

    make: gcc: No such file or directory
    make: *** [Makefile:66: n64graphics] Error 127
    Traceback (most recent call last):
    File "./extract_assets.py", line 292, in <module>
    main()
    File "./extract_assets.py", line 162, in main
    subprocess.check_call(
    File "/usr/lib/python3.8/subprocess.py", line 364, in check_call
    raise CalledProcessError(retcode, cmd)
    subprocess.CalledProcessError: Command '['make', '-s', '-C', 'tools/', 'n64graphics', 'skyconv', 'mio0', 'aifc_decode']' returned non-zero exit status 2.
    Makefile:209: *** Failed to extract assets. Stop.


    Should be a reason of this crazy problem, what can else I can try or provide you to find where this problem could be located?

    Really thank you guys ;)


     
    Last edited by CrisMod, Dec 16, 2020
  15. AboodXD

    OP AboodXD I hack NSMB games, and other shiz.
    Member

    Joined:
    Oct 11, 2014
    Messages:
    2,859
    Country:
    United Arab Emirates
    I suppose this is happening because you are using the msys2 included with devKitPro and not the standard msys2.
    Uninstall devKitPro and use the standard msys2 (the one you said is in C:\msys64\mingw64).
    When you are using the standard msys2, first, you need to install devKitPro inside it and then follow the same steps you did previously in the devKitPro msys2. I have explained how it's done in the discord message link linked in the first post (you need to join the SM64 PC port discord server first, which is linked in the readme). If you can check it out, please do.
     
    GABO1423 likes this.
  16. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    Thank you so much @AboodXD and @mive for your support and patience to bear this with me guys, but here I'm tryng to do this also for the people that give up, because they will face the same problems and cannot enjoy such amazing projects as @AboodXD made.
    So, when I will complete this story I'm willing to write a simple guide with step by step how to install these enviroments; because, I discover that here we have some few problems that it's related between DevKitPro enviroment - MSys2 - and libs outdated and cannot be follow the fragmented infos that we can finds around (and trust me I read tons of infos and sites to solve these things because are half correct or outdated solutions).

    So, I tried anything and I tried to understand in many ways (install the DevKitPro - unistall DevkitPro and MSys2 and reinstall them fresh- libs and so on) where the problems are, and are as following:

    The "problem" of the @AboodXD project it's that it needs the libs mingw-w64-x86_64-toolchain installed in the MSys2 enviroment, the mingw-w64-x86_64-toolchain is a group of different libraries like gcc or g++ and so on that it needs for build the file as also the @AboodXD it suggestions in his Troubleshooting GitHub section (here: https://github.com/aboood40091/sm64-port).

    Here come the problems, when you install the latest devkitPro Updater v3.0.3.exe, the DevKitPro will ask you where to install it, and you will install by default in C:\devkitpro; so because it's one automated nice tool that will help you in easy way to settle the Wii U Enviroment (or others Nintendo console) for a newbie person like me ;); and helps you to install almost everything. The automated tool, will install also one Customized MSys2 that before starts the installation the devkitPro Updater v3.0.3 it will download (temporary or permanent it depends of your installation choice) in your Desktop in 7z format. So, this Customized MSys2 it's an old version of MSys2 it's the ver. 2.10.0.1 and during the installation you can notice some libs error that cannot be downloaded and installed as some outdated repository sourching that it doesn't work in our days. So, when you will open the MSys2 from C:\devkitPro\msys2\mingw64 then will try to install all the libs extra packages also the one that @AboodXD suggests (like: pacman -S git make python3 wiiu-sdl2 or the pacman -S wiiu-dev) you can install them but you will still miss the gcc packages (you can check with this command gcc -v as also @AboodXD suggests in his GitHub sections) that it's vital for building the port.
    So, the command pacman -S mingw-w64-x86_64-gcc as also @AboodXD suggestions will not work with this Customized MSys2, because probably the outdated ver. cannot check the new repository and name that are on the new versions MSys2/libs, and you are willing to install only one part of this libs that are alredy included in the downloaded repository libs that are as my above posts and can be installed with this command: pacman -S mingw-w64-cross-gcc .
    I tell you this, because when yesterday I tried to reinstall them I made one step forward from make: gcc: No such file or directory to make: g++: No such file or directory. And, NO it's not related because before I installed the normal gcc libs because I tried to unistall, restart the PC, and make the fresh installations few times...
    Last time, I belive I was really lucky to let it worked, because I mess-up with many libs and on the top of the normal gcc libs that I installed, I reinstalled also the mingw-w64-cross-gcc libs and maybe the libs crossed to eachother or I don't know wich weired story happened behind, that anyway it allows me to build up the .rpx for the Wii U and everything was working.

    So,the best way in our days (till the DevKitPro team will not release a new version of it), will be to install the latest Msys2 from the official site, here: https://www.msys2.org/ .
    But here, for the newbie people like me will face other problems, and Ok to install the new separate MSys2 in C:\msys64 after start the devkitPro Updater v3.0.3.exe and for my understanding from this site https://devkitpro.org/wiki/devkitPro_pacman I have to place the devkitpro folder into the C:\msys64\opt\devkitPro so the automated exe file will install all the necessaries tree folders included the Customized MSys2 and so on. But all the libs and settlement will be installed for the Customized MSys2 and not for the normal new MSys2 in C:\msys64 that i will be going to use for building; so wich means I have to install everithing that the devkitpro will do by it self including the repository and keys.
    So, what i did it's to place the sm64-port folder in the C:\msys64\home\"My User Account"\sm64-port, yes, because for this new MSys2 will sourching the folder into it's enviroment subordinated folders and not in C:\Users\"My User Account"\sm64-port and then try to follow the https://devkitpro.org/wiki/devkitPro_pacman in the step where I need to add the repository sourching as below:

    [dkp-libs]
    Server = https://downloads.devkitpro.org/packages


    [dkp-windows]
    Server = https://downloads.devkitpro.org/packages/windows


    these two lines have to be added in the file located C:\msys64\etc\pacman.conf (as per my pic added below) to download all the repository related to Nintendo consoles dev. But, again, the suggestion that the site gives to you are outdated and when you go back to the new MSys2 and digit these two upgrades (to download the new repositories libs):

    pacman -Syu
    pacman -Su

    The new repositories cannot be installed or downloaded because the keys are outdated where this error i can see even when the DevKitPro exe install them automatically, but then use other type of keys to go around of this problem and it download all of them in the end. But, it's really fast when it makes this automated movement that I cannot undertstand how the exe installer it makes, I saw that use one command called bash.exe into the subfolders located in C:\msys64\opt\devkitPro\msys2\usr\bin, to make all this movements.

    So, for sure here and in our days I need someone more expert than me to help me to settle well this Enviroment, all caused of these outdates repositories or softwares problems that maybe months before was working.
    So, @AboodXD @mive please I begging you guys to support me to install everything step by step correctly to let also others to join these amazing projects.....

    Cheers


     

    Attached Files:

    Last edited by CrisMod, Dec 17, 2020
  17. mive

    mive GBAtemp Regular
    Member

    Joined:
    Jul 19, 2018
    Messages:
    117
    Country:
    Germany
    did you import the key ?


    Code:
    pacman-key --recv BC26F752D25B92CE272E0F44F7FD5492264BB9D0 --keyserver keyserver.ubuntu.com
    pacman-key --lsign BC26F752D25B92CE272E0F44F7FD5492264BB9D0
    
    pacman -U https://downloads.devkitpro.org/devkitpro-keyring.pkg.tar.xz
    
    (but note; First import the key which is used to validate the packages. There seem to be issues with keyservers so we specify one here but you may need to look for a working one.
    https://devkitpro.org/wiki/devkitPro_pacman#Customising_Existing_Pacman_Install)

    I can only help you with pacman issues, not with windows ones, as I dont use windows for compiling stuff
     
    CrisMod likes this.
  18. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    I tried these on the keyserver.ubuntu.com but are outdated in our days.....

    Anyway, after tons of hours spend on it with thest-sourching and studying I have got FINALLYYYYYYY fixed everything and I will write soon a guide below for everyone, because today if you want make it on Windows, the people will face these problems.....

    Thank you anyway for your support @AboodXD and @mive.
    @elk1007 soon you will have your working enviroment for 3DS as well man.
     
    Last edited by CrisMod, Dec 18, 2020
    Lostbhoy and mive like this.
  19. CrisMod

    CrisMod GBAtemp Regular
    Member

    Joined:
    May 4, 2020
    Messages:
    193
    Country:
    Italy
    Perfect guys, as promised you, I'm here to try to explain you what it's going and how to solve all the problems/errors related to the audio cpp - gcc - g++ and so on.... when you try to build your own SM64 Port. And, what it's goin on in between DevkitPro-MSys2-Mingw64-Pacman and libs.

    I made many tests and spend many hours to understand clearly all of these stuff (for me new), and I saw that for such problems can be in difficulty even who is more expert than me, that are using daily these enviroments stuff for intense codes compiling programming.

    Anyway, let's go to understand,when you will download the Latest DevKitPro 3.0.3.exe what happens, the DevkitPro it's a perfect automated Windows software that will download MSys2 + Mingw64 + Mingw32 these are 3 types of Command Shell software for your Console build Enviroment. The DevkitPro, has the principal Command Shell that it's a Customized MSys2 where all the packaging will be downloaded and concentrate to be installed and to be use for all the Nintendo Console basics extensions, that are calls libs. These libs, are vital for the functionality of the building projects (one example, the great one that @AboodXD makes for all of us), if you miss one of these libs extensions the building will not work and continually will gives you the errors and than you are confused because you cannot understand where are the problems. So, these libs in the end of the day will download only for MSys2 Command Shell the other two Command Shell are important as it's important the MSys2, because if someone (like @AboodXD project) it's build for Mingw64 Enviroment Command Shell you have to use this Mingw64 (as @AboodXD suggest to his GitHub section), otherwise if you use the MSys2 or Mingw32 the project will continually gives you the errors. But here will come the funny thing, because DevKitPro as I told you, will concentrate all the package libs installation for MSys2 that these libs will be installed into the directories tree of MSys2,where can be shared for Mingw64 or 32 as well; so the specific or related Mingw64 will not be installed into the Directory tree of Ming64 as normal should be but into the MSys2 directories, because Msys2 it's like the "middle Man" for all of 3 Command Shells.

    In fact, when you will try to install the packages lib calls mingw-w64-x86_64-gcc (that also @AboodXD suggests) you cannot install them because in the Repository that should be by default as choices to install, these are not existing.

    For this reason you have to install the libs that are called mingw-w64-cross-gcc that if you are lucky (you need to switch few times between Msys2 and Mingw64) rare time they could work and make the job in place of mingw-w64-x86_64-gcc. Othervise, if it starting to don't work, you will enter in a vortex of Errors on Errors on the Top of Errors, and makes you crazy.

    So, it's doesn't matter where from you install the libs if from Msys2, Mingw64 or 32, because the existing libs to be installed in anyway will be redirected into the Msys2 directory. Where, instead of, if you will install a normal MSys2 + Mingw64 + Mingw32 from the official site and will be installed in C:\msys64, you will have the specific packages separately in related folder installation directory of each 3 Command shells, and working for the purpose of what they are functional.


    Ok, I hope to gives you at least a general picture of what are the problems, now without that I explain more stuff, I will give you all the procces to make the DevKitPro complete and can be used even with the software sm64pcbuilder2 , at least you will avoid to install the second official MSys2 in your computer, for just different machines.


    Please follow as below:


    1. Download and install the latest DevKitPro from here: https://github.com/devkitPro/installer/releases/tag/v3.0.3
    2. Let the software to download and install everything by it self, once finished don't open it and download my file below (pacman Extra Rep) extract the file, and place this new pacman.conf file into C:\devkitPro\msys2\etc and replace the existing one. This, allows us to install more extensions/ libs specific for the Mingw64 + Mingw32 Command shells.
    3. Open Msys2 from start Menu or C:\devkitPro\msys2\msys2.exe, and write:
    Code:
    pacman -Syu
    (let to update all the repository extensions, if you see some error no worries it's normal). On the question
    Code:
    Replace pkg-config with msys/pkgconf? [Y/n] n
    (choose no for now)

    4. Once finished, next write:

    Code:
    pacman -Su
    (let to apply the update for all the repository extensions, if you see some error no worries it's normal and you can delete some broken lib if requested by the software). On the question
    Code:
    Replace pkg-config with msys/pkgconf? [Y/n] Y
    (choose yes).


    5. Close the MSys2, and open the Mingw64 from C:\devkitPro\msys2\mingw64.exe

    6. Install the necessary libs for SM64 Port Wiiu/PC:

    Code:
    pacman -S wiiu-dev
    and press Enter on the keyboard to install all of them

    7. Then install the following libs:

    pacman -S zip

    pacman -S unzip

    pacman -S unrar

    To install more fast copy this:
    Code:
    pacman -S zip unzip unrar


    8. Then install the following libs:

    pacman -S mingw-w64-cross-binutils

    pacman -S mingw-w64-cross-crt-git

    pacman -S mingw-w64-cross-gcc

    pacman -S mingw-w64-cross-headers-git

    pacman -S mingw-w64-cross-tools-git

    pacman -S mingw-w64-cross-windows-default-manifest

    pacman -S mingw-w64-cross-winpthreads-git

    pacman -S mingw-w64-cross-winstorecompat-git

    pacman -S mingw-w64-cross-zlib

    To install more fast copy this:
    Code:
    pacman -S mingw-w64-cross-binutils mingw-w64-cross-crt-git mingw-w64-cross-gcc mingw-w64-cross-headers-git mingw-w64-cross-tools-git mingw-w64-cross-windows-default-manifest mingw-w64-cross-winpthreads-git mingw-w64-cross-winstorecompat-git mingw-w64-cross-zlib


    9. Then install the specific following libs it needs for Mingw64:

    pacman -S mingw-w64-x86_64-SDL

    pacman -S mingw-w64-x86_64-SDL2


    pacman -S mingw-w64-x86_64-binutils

    pacman -S mingw-w64-x86_64-crt-git

    pacman -S mingw-w64-x86_64-gcc

    pacman -S mingw-w64-x86_64-gcc-libs

    pacman -S mingw-w64-x86_64-glbinding

    pacman -S mingw-w64-x86_64-glew

    pacman -S mingw-w64-x86_64-gmp

    pacman -S mingw-w64-x86_64-headers-git

    pacman -S mingw-w64-x86_64-isl

    pacman -S mingw-w64-x86_64-libiconv

    pacman -S mingw-w64-x86_64-libwinpthread-git

    pacman -S mingw-w64-x86_64-mpc

    pacman -S mingw-w64-x86_64-mpfr

    pacman -S mingw-w64-x86_64-vulkan-headers

    pacman -S mingw-w64-x86_64-vulkan-loader

    pacman -S mingw-w64-x86_64-windows-default-manifest

    pacman -S mingw-w64-x86_64-winpthreads-git

    pacman -S mingw-w64-x86_64-zlib

    pacman -S mingw-w64-x86_64-zstd

    To install more fast copy this:
    Code:
    pacman -S mingw-w64-x86_64-SDL mingw-w64-x86_64-SDL2 mingw-w64-x86_64-binutils mingw-w64-x86_64-crt-git mingw-w64-x86_64-gcc mingw-w64-x86_64-gcc-libs mingw-w64-x86_64-glbinding mingw-w64-x86_64-glew mingw-w64-x86_64-gmp mingw-w64-x86_64-headers-git mingw-w64-x86_64-isl mingw-w64-x86_64-libiconv mingw-w64-x86_64-libwinpthread-git mingw-w64-x86_64-mpc mingw-w64-x86_64-mpfr mingw-w64-x86_64-vulkan-headers mingw-w64-x86_64-vulkan-loader mingw-w64-x86_64-windows-default-manifest mingw-w64-x86_64-winpthreads-git mingw-w64-x86_64-zlib mingw-w64-x86_64-zstd


    10. Then install the following libs (for Wii U and for now these are just optional, but why not!):

    pacman -S wiiu-sdl2_gfx

    pacman -S wiiu-sdl2_image

    pacman -S wiiu-sdl2_mixer

    pacman -S wiiu-sdl2_ttf

    To install more fast copy this:
    Code:
    pacman -S wiiu-sdl2_gfx wiiu-sdl2_image wiiu-sdl2_mixer wiiu-sdl2_ttf
    11. Then install the following libs:

    Code:
    pacman -S git make python3 wiiu-sdl2
    These are all the libs environment that allows you to build up the SM64 Porting.

    Now to copy the @AboodXD GitHub repository folder (as you can find this instruction to @AboodXD page) , and write this command to the shell:

    Code:
    git clone https://github.com/aboood40091/sm64-port.git
    So, the above command will download the sm64-port folder directory to your User Account computer name folder; but could be that (and only in this stage, because maybe fresh of all the installations) the Command shell will write you that this command it doesn’t exist :glare:; don’t worry because it’s a part of these buggy stuff that come out only in this stage of installation. If happen so, go to @AboodXD GitHub project and download the zip folder. Once downloaded, unzip this folder and place it, in C:\Users\"Your User Account"\sm64-port (so renamed the folder from sm64-port-master to just sm64-port) and of course place the backup game into the sm64-port directory folder and called it baserom.us.z64 or baserom.eu.z64 or baserom.jp.z64.

    12. Then write this:

    Code:
    cd sm64-port
    13. And then as final for build, write this (for single core):

    Code:
    make
    (Optional) If you want build more fast and use the multi core/ thread cpu , instead of write make, write this:

    Code:
    make -j4
    (I advice it especially if you are going to build up and test the new Texture mods, because it can take you more; even 1 hour with single CPU usage)

    Then, once the Mingw64 will finish to build-up the rpx and elf file, go to your sm64-port folder downloaded and into it you will find a new folder called “build” navigate into the subfolder and Congratulation you will find your fresh rpx for WiiU .

    Recommendations: If you will use the PC software just for test sm64pcbuilder2.exe when will ask you that cannot find the MSys2 software installed, and then pop up the software window to navigate and looking for the MSys2 directory, please navigate to the devkitpro directory in C:\devkitPro\msys2, and then the software, it will work like a charm…

    For settle all the Environment from a fresh MSys2 (so without using DevkitPro), I’m under testing, maybe later I will do a separately guide to how to do it. But for now, after settle well the DevkitPro you shouldn’t have any problems about.

    Lastly, when you made successfully your first build rpx, for the next one (if you want test different Mod like me), you can use either MSys2 and Mingw64 without differences, because all the buggy stuff disappear and Msys2 can work like Mingw64 for this project.


    PS: @elk1007 follow this guide to settle the Environment but change all the staff for WiiU to 3DS building. If anything I will help you.
     

    Attached Files:

    Last edited by CrisMod, Jan 10, 2021
  20. Yergermeister01

    Newcomer

    Joined:
    Dec 6, 2020
    Messages:
    9
    Country:
    United States
    Can I be a noob and just ask why cant a prebuilt version be supplied?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Super, Mario,