Gaming So this happened...

Casis

I'm no hero, but I try to help when I can.
OP
Member
Joined
Apr 11, 2016
Messages
240
Trophies
0
Age
34
XP
214
Country
United States
wii problem 1.jpg
So recently I felt like playing some Project M, only to find this appear on my TV screen when I turned the Wii on. It just kept showing lines going back and forth with these colors, and I don't know why this is happening but I don't like it. I made sure everything was plugged in correctly and I still have this issue. This is the first time I've seen this, in MY WHOLE LIFE of my Wii console use history. I tried using the quick loader menu (the white screen that appears with a bunch of options to go straight to a channel/game by holding the reset button) and by just normally turning it on. I can obviously tell that this is probably a defect inside the system, but I wonder: how could this have happened? Am I completely screwed and shouldn't waste my time sending it for repairs?

*Note that this system has RARELY been dropped by falling on it's side when standing up. That's the hardest impact the system ever came to*
 

Attachments

  • wii problem 2.jpg
    wii problem 2.jpg
    1.9 MB · Views: 158
  • wii problem 3.jpg
    wii problem 3.jpg
    1.4 MB · Views: 161

SecureBoot

Your friendly neighborhood idiot
Member
Joined
Sep 29, 2016
Messages
1,801
Trophies
1
XP
4,732
Country
United States
Interesting, I've seen a similar problem with burnt out LED strips on my TV. Are there any clues that tell you you're still control the Wii and it's not displayed right? For example, can you hear the click when hovering over a channel?
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    T @ Texasauras: SOLILOQUY