should i stick or move on

Discussion in 'Wii - Hacking' started by mikejacobs, Nov 3, 2009.

Nov 3, 2009

should i stick or move on by mikejacobs at 8:54 PM (1,010 Views / 0 Likes) 13 replies

  1. mikejacobs
    OP

    Newcomer mikejacobs Advanced Member

    Joined:
    May 31, 2009
    Messages:
    68
    Country:
    Japan
    i couldn't find the answer to this question while reading stickies.

    'what's the real point of updating?'

    i'm running 3.2U and the usb loader and my friend said i should update to 4.2.

    i asked him 'why?' and he couldn't answer.

    i don't need the sd card loading feature.

    should i still update to 4.2? because even the new games seem to be working fine on my 3.2U and the usb loader.
     
  2. screamq3

    Member screamq3 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    188
    Country:
    United Kingdom
    if games are working fine, then stay as you are m8 [​IMG] no reason to upgrade
     
  3. G0dLiKe

    Member G0dLiKe who needs a title ;)

    Joined:
    Aug 2, 2009
    Messages:
    1,674
    Country:
    United States
    If all is running fine and you´re feeling comfortable where you are, stay there.
     
  4. mikejacobs
    OP

    Newcomer mikejacobs Advanced Member

    Joined:
    May 31, 2009
    Messages:
    68
    Country:
    Japan
    ok.. so i'm not being 'out-dated', am i?
    and then why is everybody moving on to 4.2 here?
     
  5. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
    The only thing you could win from 4.2 is the SD card menu, which you said you don't need

    And you have USB loader, so all games work

    Conclusion: don't fix what ain't broken
     
  6. wyndcrosser

    Member wyndcrosser GBAtemp Advanced Fan

    Joined:
    May 28, 2009
    Messages:
    720
    Country:
    United States
    Because some games (without having to screw around with patches, combined isos, etc.) require 4.2. I prefer to not have to figure out through posts how to make games work, when Rev14 and 4.2FW basically allows me to play every game.

    It's just like a PSP or Xbox 360, if you have the ability to upgrade, why not?

    The SD menu is completely worth it btw.

    Wynd
     
  7. 0M39A

    Member 0M39A GBAtemp Fan

    Joined:
    Apr 24, 2009
    Messages:
    374
    Country:
    Australia
    what games require 4.2?

    hell, what games require more than 3.4?

    as already said, if you like staying on 3.2, and you use usbloader, then there is no explicit reason to change.

    i stayed on 3.2 for a long time, and the only real reason i updated to 4.1 was the sd menu (which i never use now due to triiforce), and to use darkwii extended theme (which wasnt available for 3.2 at the time). pretty petty reasons [​IMG]
     
  8. Retrievil

    Member Retrievil GBAtemp Fan

    Joined:
    Jul 6, 2006
    Messages:
    360
    Location:
    Vancouver
    Country:
    Canada
    I don't think there are any games that require more than 3.4. There is a bug fix in 4.1, that fixes a very minor issue with Wii Sports Resort.

    The main reason to update is SDHC and the ability to load/store Wiiware on SD cards. IMO it's totally worth to up to at least 4.0 just for the SD stuff, but if you don't care about Wiiware or SD cards larger than 4GB, there is no reason to update.
     
  9. 0M39A

    Member 0M39A GBAtemp Fan

    Joined:
    Apr 24, 2009
    Messages:
    374
    Country:
    Australia
    homebrew supports sdhc cards without having to update, just incase anyone gets the wrong idea.
     
  10. TRushInfo

    Banned TRushInfo Banned

    Joined:
    Jun 13, 2009
    Messages:
    978
    Country:
    United States
     
  11. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    the reason i downgrade to 3.2 all my Wiis is because the system menu sees trucha signed games ok. if i load(flatmii because no system menu plays burned games) a custom made game in 3.4, the system menu freaks out and gives the "an error has occurred..." screen. if i load that same game in 3.2 then it works fine. i dont give a shit about the sd card menu.
     
  12. illinialex24

    Member illinialex24 GBAtemp Advanced Fan

    Joined:
    May 26, 2009
    Messages:
    968
    Location:
    The Midwest
    Country:
    United States
    Go to 4.1 and stay there.
     
  13. razorback78

    Member razorback78 GBAtemp Maniac

    Joined:
    Aug 3, 2009
    Messages:
    1,183
    Country:
    Philippines
    4.2 sucks and meaningless. i upgraded to check what changes would it do to my wii...yeah my wii changed alright, it made my usb loading unstable for reasons i do not know...so i return to 4.1.

    just stay at 3.2...
     
  14. ocdetective

    Member ocdetective GBAtemp Advanced Fan

    Joined:
    Mar 19, 2008
    Messages:
    601
    Country:
    Malaysia
    Using a USBLoader means it doesn't matter what Firmware you have as the update partition is scrubbed out. So long as the cIOS is on Rev9 or later. I am still on 3.2U and Rev 9 and have yet to come across a game I cant play. He already said he doesn't need the SD menu.....
    Rev 14 and 4.2 can play every game? Isn't SSBB DL a problem?
     

Share This Page