RetroArch - A new multi-system emulator

Discussion in 'Wii - Emulation and Homebrew' started by Toad King, Aug 23, 2012.

Thread Status:
Not open for further replies.
  1. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    Can you give me a log of what happens? Ie. 'adb logcat'?

    Start with a clean 'datafiles' folder and retry it again - then give me the log. It must be failing somewhere for some reason - but I need to know what it is.

    EDIT: Just tried here again with a clean 'datafiles' dir - it's a black screen for maybe 15 (or 30 secs tops) at first startup but after that it should be running. So the extraction is going fine here on my end at least.
     
  2. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    No, US ROMS, also sega CD is very slow in audio and video on Wii version.
    Is this the bug we discussed earlier?
     
  3. Ninn

    Ninn GBAtemp Fan

    Member
    6
    Dec 1, 2006
    sorry to ask here, but i can't find the answer anywhere, im trying to run RetroArch v0.9.8.1 on my PS3 .355. and i need to "pkg_finalize on the PKG to install it. How do i this? how do i Finalize the PKG?
     
  4. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    This is plainly false. I honestly have no idea what you're even talking about - only thing I know is that you must be doing something wrong somehow.
     
  5. Charco

    Charco GBAtemp Regular

    Member
    2
    Nov 5, 2012
    Ensure the rewind feature is switched off, works perfect for me.
     
  6. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    Ah, that could explain it.

    Yeah, rewind should really come with a big fat warning saying 'WARNING - IF A CORE DOESN'T RUN AT 2x or 3X REALTIME, THIS WILL BE SLOW!!!!!!" - because it seems users are just plain not getting it - this is a power user feature (ie. you know the ramifications and you know what you're doing by enabling it).

    Also, fiddling around with rewind granularity could help making this feature faster for certain cores where you're not getting 2x or 3x realtime on Wii with a core.

    Rewind is probably a better feature on PS3 and/or 360 where you can comfortably leave this on for most cores without it becoming a speed problem. Gambatte/NEStopia/FCEU should all be fullspeed with rewind on Wii - however, SNES9x Next/Genesis Plus? Probably no chance (at least with rewind_granularity at 1).
     
    AntonioJosedeSou likes this.
  7. ilman

    ilman Gbatemp's Official Noise Eraser

    Member
    4
    Jul 25, 2010
    Shibuya
    Tried it again on a clean 'datafiles' and I don't think that my phone is so slow that it extracts everything for 3+ minutes. Also, could you tell me the name of the log file.
     
  8. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    No, 'adb logcat' is something that you run from the commandline when you have your phone connected to the PC. There is no 'file' it outputs to by default.

    Alternatively, if you have Eclipse and the Android SDK installed, you can view live logging from Eclipse when your phone/tablet is connected to the PC.
     
  9. AntonioJosedeSou

    AntonioJosedeSou Member

    Newcomer
    1
    Oct 30, 2011
    Netherlands
    It wouldn't be better if this option is just set off by default? Or maybe set off by default in those cores that for sure gonna cause a speed impact?
    And a warning text next to it like: "This option enabled can cause performance impact. Use at your own risk."
     
  10. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    it should be off by default already. And yes, I intend to add a warning like that when enabling it.
     
  11. B.B.Link

    B.B.Link GBAtemp Regular

    Member
    5
    Feb 6, 2013
    United States
    Colorado
    Please look into the same button input thing I posted earlier and the saves state or save ram in FBA cores and this thing would be perfect.
     
  12. ilman

    ilman Gbatemp's Official Noise Eraser

    Member
    4
    Jul 25, 2010
    Shibuya
    Just downloaded the SDK+Eclipse and when I run adb logcat when my phone is plugged in I get 'No devices connected'. I have USB debugging on.
     
  13. XDel

    XDel Author of Alien Breed: Projekt Odamex

    Member
    9
    Jul 25, 2012
    United States
    Another Huxleyian Dystopia

    Trust me, I understand fully! I still play a lot of stuff in software mode from time to time, especially the classics like DOOM and Quake. A lot gets lost when you go into GL mode.

    Keep up the good work!
     
  14. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    11
    Jan 14, 2012
    Ideas factory :)
    Any plans to fix the argument support and make a setting line for default screen resolution in order to be able to enjoy the new changes in WiiFlow again. Thanks :)
     
  15. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    The next version (0.9.8.3) will have EEPROM saving/loading (which will work at least for CPS2/CPS1) - what this will do is save Service mode settings. However, savestates are still bugged in general - they will only work for the duration of the game running - but not as soon as the game gets unloaded and gets restarted again. We don't know yet how to fix that - I might have to ask the FBA devs if we're doing something wrong there.
     
  16. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    You should probably get these people (WiiFlow plugin authors who made that thing) to contact me so that we can coordinate changes in the future better so issues like this (breakage) won't happen again.
     
    kineticUk and MassiveRican like this.
  17. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan

    Member
    7
    Aug 24, 2012
    Netherlands
    If you get 'No devices connected' then your phone is not properly connected yet. You should check out some tutorials on how to do this.

    Anyways, this really falls outside the scope of this 'RetroArch Wii' thread I'd say at this point. You can make a post on our forum instead about this -

    http://forum.themaister.net/
     
  18. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Simple.
    VBA Next is better than VBA GX - Many game run full speed, like Golden Sun and Final Fantasy IV, V and VI Advanced.
    Sega CD support is in Genesis Plus GX 1.7.3 and is not slow contrary to what other may think; I got NTSC games running at 60 fps all the time and not a single issue.
    Snes9x Next is better because games that ran choppily on Snes9x GX run perfectly (Star Fox now is full speed, as well as Yoshi's Island, which was full speed from the beginning). Not to mention games like Kirby's Super Star also run full speed. Try comparing that to Snes9x GX in terms of stability. No frame skipping hacks are used at all. Did I mention that Final Fantasy VI doesn't run slow in large areas either? There's no audio issue when entering/exiting the emulator menu, and now that the audio sampling has been improved, it will sound better than Snes9x GX.
    Nestopia doesn't have FDS support yet, but the audio/synchronization beats FCEUmm and FCEU GX any day and doesn't have crackling or popping that plagues the port. If you're not satisfied with RetroArch, then use the standalone emulators.
    Well, gotta face the fact that people cannot be fully placated; they'll always complain about something not being right. By the by, any update on the quick release (the cores with the new audio sampling)?
     
  19. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    I have this disabled and never ever enabled it.
    Slow gameplay just happened.
    I remember last week someone having similar problems after switching video modes on his Wii 480P > 480i and vice versa.
    Don't get to cocky my friend, I'm just trying to help here, if you like it or not, I'm not stupid.
    Could it be that their is some config problem?
    Anyways, could you explain why I'm not able to run PAL roms at their normal speed, also?
    Example would be the firemen (E).

    My Wii is connected via Component and set to 480p.
    Please try to refresh your memory about this issue, back then I even tested it for you.
     
  20. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Let it be. There's no need to discuss semantic nonsense.
     
Loading...
Thread Status:
Not open for further replies.