Ret = -1022 ??????????????

Discussion in 'Wii - Hacking' started by Naydog101, Sep 21, 2010.

Sep 21, 2010

Ret = -1022 ?????????????? by Naydog101 at 6:05 PM (4,104 Views / 0 Likes) 23 replies

  1. Naydog101
    OP

    Newcomer Naydog101 Advanced Member

    Joined:
    Sep 1, 2010
    Messages:
    64
    Country:
    United States
    So I'm trying to install the WAD Strong Bad's Cool Game For Attractive People Episode 2 and right at the get go at Installing content #00
    it gives ERROR! (ret = -1022)

    What is this error, bad file, previous installed version of the game?
    I had previously installed the game before and not sure how I deleted it, but deleted it cause it would always freeze at a certain point. Tried uninstalling the wad from the wad manager just to try something and reinstalling it but no dice. Any tips, tricks, advice, advances in fixing this problem?
    I wanna play this game cause I found out playing in wide screen mode freezes the game.
     


  2. dn_angel000

    Member dn_angel000 Phantom User

    Joined:
    Apr 27, 2010
    Messages:
    592
    Country:
    United States
    1022:
    Wad Install Error: Most likely incorrect format or corrupt SD card. Memory might be full.
     
  3. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    -1022: Usually a hash or ticket issue.

    Easiest solution is to just get another wad of the game. If you can't find another one, re-sign the existing wad with a tool like wwPacker.

    @dn_angel000: Most SD-related issues cause -1, not -1022.
     
  4. PPSainity

    Member PPSainity Blinded by Science

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    I would suggest finding another WAD over re-signing the WAD that gives the -1022 error. The error can be caused by the WAD content being bad or the hash value in the TMD being calculated wrong. Without determining the exact reason, by re-signing the WAD you can end up installing a WAD with bad content. Try finding another version of the WAD from a better source instead.

    -[]D
     
  5. Naydog101
    OP

    Newcomer Naydog101 Advanced Member

    Joined:
    Sep 1, 2010
    Messages:
    64
    Country:
    United States
    Ok well, I did find another version of the WAD but same issue, error -1022

    Only with Strong Bad Episode 2 cause I think I deleted that channel/game Using the Wii and not the Wad Manager.

    I had played through Episode 1 but it was always freezing near the end. I uninstalled it using the WAD manager, installed Episode 2 and actually played through it as well, but like the first near the end it kept freezing though this time I think I uninstalled episode 2 using the Wii and not the Wad manager. (really not sure though, pretty sure used the Manager)

    I found out the cause of the freezing and reinstalled Episode 1, played through and finished the game, moved it to the SD card and now want to install Episode 2 and finish it as well. But I got this error happening only with episode 2.

    I can and did install Episode 1 and 3 and uninstalled My aquarium.

    Any other suggestions?

    What is re-signing what does it do? Where do I find that file?
     
  6. Sao Mortel

    Member Sao Mortel GBAtemp Advanced Fan

    Joined:
    Jul 23, 2008
    Messages:
    533
    Location:
    Montreal
    Country:
    Canada
    I am unsure but this seems quite simple; your wad manager might be using ios 36 that was kind of blockd for downgrading.... All you need to do is load for example cios 149 with your wad manager to use... Please post back if this work or not...
     
  7. Naydog101
    OP

    Newcomer Naydog101 Advanced Member

    Joined:
    Sep 1, 2010
    Messages:
    64
    Country:
    United States

    149? Do you mean 249 cause 249 is all I ever use and it's always worked, if you mean 149 how and where do I find it? Think I'm having an issue with having deleted Episode 2 wrong and now something is keeping only that game from installing.

    All I want to do is finish the game. Well actually redo the game. I notice that when you remove a WAD via the Manager it also deletes the save files too.
     
  8. PPSainity

    Member PPSainity Blinded by Science

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    Deleting the Channel via Wii's Channel Management screen can be the cause of your issue. The WAD that you originally used before may have had a different hash than the WADs you have used now. When you delete the Channel via the Wii's Channel Management screen, the corresponding ticket containing the hash is not deleted. Try using a program like Any-Title-Deleter to remove the channel completely including it's ticket. When you try to install the WAD afterward it should not give out the same error unless the WAD itself is corrupted.

    -[]D
     
  9. GrahamWatts

    Member GrahamWatts GBAtemp Regular

    Joined:
    Nov 13, 2011
    Messages:
    104
    Hi, just joined this group. I am having the same issue with strong bad episode 2. All new installations 1, 3 and 4 work from the wad manager and episode 2 ret = -1022.
    i was getting the same from splatterhouse but i downloaded another file that then was fine but i have downloaded 3 or 4 different strong bad 2 wads none work even the one that works on my friends wii wont work on mine. i have downloaded any title downloader but don't know how to use it i assume put it in the apps folder?
     
  10. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Check your sd card, -1022 means the hash does not match the content:
    http://wiibrew.org/wiki//dev/es

    Or in english, it's a checksum error. Either your sd card is corrupted or you might want to try another WAD Manager version, as it might contain a different sd card driver.
     
  11. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    -1022 is a content hash error, so something is corrupt. This is a sometimes a wad issue, other times its an SD issue. Since you tried another wad already, try another SD card. If that doesn't help, what program are you using to install the wads?

    "AnyTitle Downloader" is probably AnyTitle Deleter, a tool that's not relevant to your issue. Don't play with that app...if you don't know what you're doing, you can very easily brick your wii with it.
     
  12. Foxi4

    Reporter Foxi4 On the hunt...

    pip
    Joined:
    Sep 13, 2009
    Messages:
    22,705
    Location:
    Gaming Grotto
    Country:
    Poland
    Neither of those answers are true. The WAD you are trying to install is trying to install itself on a Slot that is write-protected or the IOS used for installing does not have the privilages over overwritting said slot.

    Try using a different IOS to install, if that is impossible, clear the slot with AnyTitle Deleter, if that doesn't work, use DopMii, delete the IOS you are using to install it (if it is not an essential one) and re-install it properly.

    I don't have to mention a backup copy of NAND in case of a f*ck-up, do I?
     
  13. TiMeBoMb4u2

    Member TiMeBoMb4u2 GBAtemp Maniac

    Joined:
    Oct 25, 2008
    Messages:
    1,169
    Country:
    United States
    Agreed. This is definitely an IOS issue.
    DEFINITELY recommend a sysCheck dump, then ModMii to update the out-of-date IOS's.
     
  14. GrahamWatts

    Member GrahamWatts GBAtemp Regular

    Joined:
    Nov 13, 2011
    Messages:
    104
    In relation to my last post i have used any title deleter and found the title 00010001 installed channel title, deleted ticket wbye 57425945 but still can't install strong bad 2 wad despite using quite a few different wads, does anybody know what else i can try? i have tried a region free and european version but still can't get any success. im using version 4.3e but isn't dopmii for 4.2? i'm using wad manager v1.7, i have tried different sd cards but still the same issue, i have posted a m8 my spare sd and he will drag and drop the file onto the sd card so when i get it back i will drag and drop that into my title folder on my wii sd card, this will work , right?
    sysCheck reports everything is up-to-date, pimp my wii wont install this wad either. I have backed up my nands.

    p.s cheers tech boy, any title deleter thats the one i was downloading more wads at the time sorry i put downloader by mistake :)
     
  15. TiMeBoMb4u2

    Member TiMeBoMb4u2 GBAtemp Maniac

    Joined:
    Oct 25, 2008
    Messages:
    1,169
    Country:
    United States
    Will you please run sysCheck, and post your results, so we can see what IOS's you have.
    Once you do this, we can assist you in troubleshooting. Thanks! :D
     
  16. GrahamWatts

    Member GrahamWatts GBAtemp Regular

    Joined:
    Nov 13, 2011
    Messages:
    104
    clicked on IOScheck app and got exception dsi occured followed by loads of mumbo jumbo codes,
    SYScheck testing now.... my display report on my old fashion fat tv is very blurry....note to self get santa to buy me a new tv.... let my try and read it.....
    region pal
    system menu 4.3e (v5:14)
    priiloader installed
    the drive supports dvds
    homebrew channel 1.id.78 running on IOS58
    found 173 titles
    found 51 IOS on this console. 5 of them are stub (looks like stub to blurry)
    IOS4 (rev 65280): stub
    IOS 10 STUB
    IOS 16 TRUCHA BUG, ES IDENTITY, FLASH ACCESS,NAND ACCESS
    IOS 30 TRUCHA BUG
    IOS 36 TRUCHA BUG, ES IDENTITY, NAND ACCESS
    IOS 40 STUB
    IOS 50 TRUCHA BUG
    IOS 51 STUB
    IOS 52 STUB
    IOS 58 USB 2.0
    IOS 60 TRUCHA BUG
    IOS 70 TRUCHA BUG
    IOS 80 TRUCHA BUG
    IOS 90 TRUCHA BUG
    IOS 202 INFO HERMES, TRUCHA BUG, NAND ACCESS, USB 2.0
    IOS 222 TRUCHA BUG, NAND ACCESS, USB 2.0
    IOS 223 TRUCHA BUG NAND ACCESS, USB 2.0
    IOS 224 TRUCHA BUG NAND ACCESS, USB 2.0
    IOS 236 TRUCHA BUG, ES IDENTITY, NAND ACCESS
    IOS 247 TRUCHA BUG, NAND ACCESS, USB 2.0
    ALL UNMENTIONED IOS SAY NO PATCHES :) HOPE THIS HELPS MEANS NOTHING TO ME LOL
     
  17. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Guys, really?

    I'm yet to see WiiBrew being wrong:
    Another explanation would be a corrupt WAD. Well, the used IOS plays a role in this, but the sd card driver from the used homebrew is as important as the used IOS or more.
     
  18. Foxi4

    Reporter Foxi4 On the hunt...

    pip
    Joined:
    Sep 13, 2009
    Messages:
    22,705
    Location:
    Gaming Grotto
    Country:
    Poland
    You *should* be able to install the .wad with any IOS that has NAND Access and is Trucha Bugged, your chances are best with 36, 202, 222, 223.

    If you will still be unable to do so, conscider re-installing/updating those IOS'es using IOS16 (It has FLASH access, so you shouldn't have any problems) or the IOS'es recommended by the installers they come with.

    They're not *wrong*, that's what the returned value signifies. It's just the causes may be numerous. I tackled the exact same -ret on my girlfriend's Wii, so I'm speaking from experience, not thin air. It *happens*.

    If numerous .wad's were tested on numerous SD's and still return that -ret, it's an internal issue.

    In any case, I found another solution if the above fails:

    In other words, if you attempted installation and something got messy mid-way, it may return that error aswell. It could also reffer to a wrongly packed .wad, or as previously mentioned, a corrupt one, althought I'd say that's the rarest of cases - I personally never downloaded a single corrupt wad of the net - they tend to disappear quickly.
     
  19. GrahamWatts

    Member GrahamWatts GBAtemp Regular

    Joined:
    Nov 13, 2011
    Messages:
    104
    FOXI4 I LOVE YOU :) TRIED 202 IT FAILED TRIED 36 IT INSTALLED I NOW HAVE STRONG BAD 2 INSTALLED ON MY CHANNELS
    THANK YOU , THANK YOU , THANK YOU...... THE HOURS I HAVE SPENT TRYING TO FIX THIS .... SCOURING THE INTERNET .... YOU TUBE.....DOWNLOADS .... YOU ANSWERED MY PRAYERS I WANT TO BUY YOU A BEER :D
     
  20. Foxi4

    Reporter Foxi4 On the hunt...

    pip
    Joined:
    Sep 13, 2009
    Messages:
    22,705
    Location:
    Gaming Grotto
    Country:
    Poland
    Told ya. You're welcome, really. I'm just glad I could help.

    (See, community? I'm not ALWAYS a jerk! *snickers*)
     

Share This Page