Rejuvenate "Waiting to connect": I tried everything, I'm desperate...

Discussion in 'PS Vita - Hacking & Homebrew' started by cloudfe, Jul 22, 2016.

  1. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    I'm on 3.15, used the 1.05 update, followed HackInformer process, rebuilt the database, checked and re-checked everything, and still I'm stuck on "Waiting to connect", followed by "Failed the authentication to execute application. Please re-create a Device Seed and App Key using with PSM Studio or Publishing Utility" with VitaDefiler.

    I checked guides, videos, threads, and still nothing. I'm desperate :(
    Please somebody help me...
     
  2. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    I could really use some help :(
     
  3. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    Not sure if you're still having this issue, but just incase anyone needs this.

    The "Failed to authenticate..." message means you need to redo the PSM+ setup (Hackinformer has a decent guide). You'll need to redo some of the mail writer stuff, and eventually reimport a publisher key, device seed and app key from the files provided (I believe the files are linked in one of the guides on Hackinformer).

    It's a pain to setup, but hey, you can write to PSP/GAME/ freely (Including EBOOT.PBP) once you have rejuvenate running if you're on a more restricted FW (3.5-ish? Not sure when they started blocking it). So, there's some benefit (Word of warning, emulators in pspemu are a pain if you install them in /GAME, as they can't write new files there. At least some of them come with editable configs to solve that...)
     
    Last edited by Townsperson, Jul 27, 2016
  4. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    Thank you for replying :)

    For what I've read on this page from Wololo (I used Hackinformer), this error is linked to a wrong pairing between Vita and computer files.
    Here's what it says:

    I followed the instructions to solve the problem, but still nothing :( I think I could try with Wololo, just in case Hackinformer files are corrupted in some way.
    Any suggestion on how to completely wipe everything and restart the process from zero?
     
  5. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    Did you get the files from hack informer that include the publisher key, device seed and appkey? You need to follow this http://hackinformer.com/psmplus/ui/psmdevunity_new.html, but you need the files from the bottom of this page http://hackinformer.com/psmplus/ui/psmdev.html (At the very least, this has the appropriate key, seed and app key)
     
  6. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    Yes, I received those files, and triple-checked the ID number of my Vita.

    Today I had the chance to redo the process from scratch with Wololo. Still the same result... This machine hates my guts...
    How can I check if my Vita is actually capable of connecting to the computer? Just to see if there is something wrong with Defiler, or the license files, or anything else.
     
  7. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    Well, when you run Setup.bat and the PSM Publishing Utility launches, there should be a button on the left labeled "Package & App". On that page, there's a table labeled "Online Devices". If you see a device listed in there ("Type" should show a little vita icon, and "Device Name" should be some long string of numbers), then your Vita is connected.
     
  8. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    You said "when you run Setup.bat and the PSM Publishing Utility launches". Does it mean the utility should launch automatically when I run the Setup.bat? Because this never happened.
    Once I finish seeding the license files using the PC utility, I connect the Vita to the PC via USB, open the Unity App, and run the Setup.bat. This install the Defiler. Then I disconnect the usb and try using the Defiler to install the "Hello World" file. And I fail :(
    At what point in this process should I be able to see the Vita in the Online Devices?
     
  9. Voxel

    Voxel Fable Junkie

    Member
    GBAtemp Patron
    Voxel is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,209
    5,956
    Jun 27, 2015
    United Kingdom
    England, UK
    If you have already ran setup.bat and installed VitaDefiler onto your Vita, you should drag and drop the "hello world" velf homebrew onto the "run_homebrew_unity.bat" and then run VitaDefilerClient on the Vita. It should take a few seconds for it to do its thing, then afterwards, it should load the hello world homebrew successfully.
     
  10. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    This is what I do every single time. To my frustration :(

    There must be some kind of misstep not easily identifiable, something that a guide wouldn't expressly say but that people can get wrong...
     
  11. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    You should be able to see the Vita pop up in online devices shortly after launching the PSM Publishing application. However, if you can install Vita Defiler, your Vita should be connecting fine. You're still getting the "Failed the authentication..." error, right?

    I will say that I had this exact same issue not too long ago. Redoing the steps from the Hackinformer PSM+ guide fixed it, but I do know that Rejuvenate is finicky as all hell, so there might be some simple, completely un-obvious issue holding you up.
     
    Last edited by Townsperson, Jul 28, 2016
  12. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    I install Vita Defiler following the initial Setup.bat process, and during the whole process I always have the Vita connected via usb. So I can't really say if the Vita actually connects via Wifi. I'll check the "online devices" as soon as possible.

    Just to be sure: when the Setup.bat asks me if I'm installing for Dev (instead of Unity) I should say "n", correct?
    And is there any rule regarding what can/must and can't/mustn't be open/connected during the various steps (like when the guides say to keep the Vita Unity app closed while applying the license files via the email app)?
     
  13. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    You're concerned if your Vita is connected via WiFi? Unless you're stuck at the "Waiting for connection" message when trying to run homebrew, it doesn't really matter (At this point). Everything involving the authentication issues is done over USB, as that takes place before trying to run homebrew.

    When you're stuck on "Waiting to connect" while Vita Defiler is actually functioning (No authentication failures), it usually just means you have some setup error in your WiFi network (AP isolation might be on, or you have your Vita and computer on different networks).
     
    Last edited by Townsperson, Jul 28, 2016
  14. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    I'm stuck at the "waiting to connect" on the pc, but Defiler does give me an error message regarding the authentication. So do you think it could only be a "license" problem or also/only a network problem?
     
  15. Townsperson

    Townsperson GBAtemp Fan

    Member
    398
    272
    Dec 7, 2015
    United States
    At this point, it's just the license/authentication problem. Vita Defiler needs to actually launch before it can connect, but it can't launch if the app key, device seed and publisher key aren't set correctly (When Vita Defiler successfully launches, it'll leave your Vita at a "Powered by Unity" screen until your computer connects to it and launches homebrew).
     
  16. cloudfe
    OP

    cloudfe GBAtemp Regular

    Member
    243
    27
    Feb 24, 2013
    Belgium
    Well, I thank all of you for trying to help me. But life is too short to keep banging my head against this wall. I'll just wait and see where HENkaku will lead, and in the meantime I'll play something else :)