R4i-SDHC Upgrade Not working on DSI

Discussion in 'R4 DS' started by yusuo, Jun 14, 2011.

  1. yusuo
    OP

    yusuo GBAtemp Addict

    Member
    2,586
    944
    Oct 19, 2006
    So my stupid brother decided to update my dsi and now my r4i card no longer works, im guessing its a kernel update to the dsi firmware that disallows flash cards running.

    Ive tried doing this
    http://r4i-sdhc.com/downloade.asp
    but still no dice, im guessing I have to flash the card itself via another ds to get it runnning on my dsi again, problem being i dont know what file I need to flash the card with.

    Can anyone help

    Im on firmware 1.4.2e on my dsi.

    To add to this post the error i get when choosing the flashcard is
    "An error has occured.
    Press and Hold the Power
    Button to turn the system off.
    Please refer to the Nintendo DSi
    Operations Manual for details."
     
  2. s4mid4re

    s4mid4re  

    Member
    1,669
    430
    Apr 2, 2011
    United States
    Yes, DSi v1.4.2 blocks flashcarts.

    first of all, we need to know which one of the r4i it is: r4i SDHC v1.4, r4i SDHC v1.4.1, or r4i SDHC 3DS. You can check your r4i's sticker to identify which one it is.

    The update only works on v1.4.1 or 3DS version. It's located under "UPGRADE FIRMWARE AREA" (scroll down a little bit and you'll see it) from the download section. Download the one that says "how to upgrade products labeled "V1.4.1" or "3DS" for NDSi V1.4.2 (2011-05-21)"

    You will also need a DS phat or DS lite in order to update. Or if there's another DSi that is under 1.4.1, you can use that too. If you don't have any, borrow one.

    If you have any questions, just ask here. [​IMG]
     
  3. yusuo
    OP

    yusuo GBAtemp Addict

    Member
    2,586
    944
    Oct 19, 2006
    r4i SDHC v1.4

    thats the card i have, does that mean there is no hope for me
     
  4. s4mid4re

    s4mid4re  

    Member
    1,669
    430
    Apr 2, 2011
    United States
    unfortunately, the team never released an update for v1.4. [​IMG]

    You can either buy a DS phat/lite (which works for that cart, unless it's bricked) or you can buy a better flashcart like acekard 2i, SuperCard DSTWO, or r4i Gold DSN (from www.r4ids.cn)
     
  5. yusuo
    OP

    yusuo GBAtemp Addict

    Member
    2,586
    944
    Oct 19, 2006
    do u think i could try it with the update with the current card, the worst it can do is well not let the card work anymore, but more than likely tell me its not compatible, im going to chuck the card anyway if i cant get it to work
     
  6. NES SNES V.B. N64 G.C. Wii WiiU

    NES SNES V.B. N64 G.C. Wii WiiU Now with extra redundancy!

    Member
    859
    99
    Feb 10, 2011
    The EoF
    You can try upgrading the kernel with the 1.4.1 update, though it will probably not work after that at all.
     
  7. Invierno

    Invierno Member

    Newcomer
    35
    7
    Mar 14, 2010
    Cote d'Ivoire