Please help with NEEK!

Discussion in 'Wii - Hacking' started by kraqh3d, Jan 9, 2015.

  1. kraqh3d
    OP

    kraqh3d Member

    Newcomer
    28
    4
    Jan 17, 2009
    United States
    I cannot get NEEK to work for the life of me. I cannot figure out what may be wrong. I'm no stranger to any of this. Just about every device in my possession is modded, hacked, jail broken or rooted.

    My history is that I originally soft modded my Wii many, many years ago using the original Twilight hack. I don't have a vulnerable boot2 so I have BootMii on IOS. My Wii has been running 4.1U for quite some time and I have been happy with it. I have had no problems launching games from a FAT32 USB drive where my game images are in the WBFS folder in split wbfs format. Priiloader is installed for some protection.

    Last weekend I decided to see what's happened since and update it. I manually updated PostLoader4 and USX Loader GX. Both of which have no problems launching my games. I then installed nintendont and tested a GC from a GAMES folder using USB Loader GX which worked. I also upgraded to the seemingly unofficial PL4.7.95 version to test it with nintendont but I haven't tried it yet.

    I ran sysCheck and ran the output csv through the latest ModMii which seems to be 6.3.1. It said I was fine and didn't recommend any changes as it still seems to recommend staying on 4.1U. While in ModMii I figured I'd try NEEK which I never did before. I created a blank 4.1U image with only the PL and NEEK forwarder channels and injected a few WiiWare wads via ShowMiiWads.

    I figured I'd start with SNEEK to make sure the image was good but all I get is the dreaded single blinking light forever. ModMii installed SNEEKo rev96. I have the files in the correct place (its hard not to with ModMii.) My SD card is only a 1GB card with a 16KB cluster size. From what I understood 32KB and under is ok. Launching from the NEEK channel on my real nand leaves me with "Reloading BootMii IOS". Launching with PostLoader leaves me with a black screen.I placed the eslog.txt file in the SNEEK folder but I get no logging at all. (Though now that I think about it, it is a zero byte file. I will place "foo" in it and see if that matters.) I tested with the virgin emunand and one where I copied my real nand's shared2 folder over. Both give me the same result.

    Not really sure if 16KB was truly ok, I decided to scrap SNEEK and try UNEEK instead as I know my hard drive is correct. It's FAT32 with 32KB cluster size. I copied /nands/pl_us to USB and placed the SNEEK folder on USB and replaced the SNEEK folder on the SD card. With USB, I don't get the flashing drive, but I still can't boot my emunand. And I still don't get any logging via eslog.txt.

    Any help at all diagnosing this is greatly appreciated. It is driving me crazy.
     
  2. Plunt

    Plunt GBAtemp Regular

    Member
    143
    40
    Nov 21, 2010
    Canada
    Ontario
    You can try to use usbloader gx to load your emunand instead of sneek. Set your emunand path in custom paths. Make sure you tell usbloader gx to show emunand channels
     
  3. kraqh3d
    OP

    kraqh3d Member

    Newcomer
    28
    4
    Jan 17, 2009
    United States
    Thanks. I have not tried that but I will today. My understanding is there's a difference between USB Loader GX and PostLoader regarding how they use emunand. PostLoader boots the emunand when running channels from it and then (somehow) returns back to the real nand when its exited. USB Loader GX does not boot the emunand but can run the channels installed in the emunand in a manner I assume must be like the old TriForce app. While this works for most cases, there are some limitation that can only be overcome by booting the emunand. Is this correct?

    I have a BootMii nand backup but I've not converted it to a emunand because it's got Priiloader and I've read that you should not install Priiloader in an emunand. There's an incompatibility with neek2o (and I am trying rev96 which seems to the be last version.) I will convert though if someone recommends it as a test.

    __EDIT__

    USB Loader GX can load WiiWare games installed in both usb1:/nands/pl_us and sd:/nands/pl_us so that's good. At least I have something working. Can anyone explain the difference between the two EmuNand path configuration options in USB Loader GX? I set them both the same but why are there two?

    I went back and tested all variants of NEEK and confirmed that basic SNEEK works. It boots into the emunand and I can play WiiWare games from their channel display. SNEEK+DI, UNEEK, and UNEEK+DI all stop at "Reloading BootMii IOS" so I can only assume that I must have some USB hard drive incompatibility.