other flashcard like acekard

Discussion in 'Acekard' started by Vigilante, Jan 1, 2010.

  1. Vigilante
    OP

    Vigilante TempLurker

    Member
    1,555
    46
    Jan 1, 2010
    CyberSpace IQ:OVER 9000
    i know that acekard2i is one of the best cards for dsi but what if i do not find one. what is the next flashcard i should look for that is like acekard2i that supports the newest ds games and supports dsi
     
  2. fairlyevenparents

    fairlyevenparents GBAtemp Fan

    Member
    417
    0
    Sep 21, 2009
    United States
    united states
    M3i Zero
    I'm pretty sure SCDS2 will support DSI, so you might want to go with that
    If you do find a Acekard2i Then buy it!!!
     
  3. penthaler

    penthaler GBAtemp Fan

    Member
    357
    1
    Oct 28, 2009
    mystique
    Many people recomended "SuperCard DSOne i" - it is a little bit more expensive than AK, but game compatibility is the same (maybe a bit higher)
     
  4. Hatsu

    Hatsu Someone's been killing, eh?

    Banned
    2,143
    0
    Oct 19, 2009
    __________________ Warn: 50%
    Get the AK2i or wait for the Supercard DSTWO!
     
  5. Normmatt

    Normmatt Former AKAIO Programmer

    Member
    2,142
    544
    Dec 14, 2004
    New Zealand
    Nothing is better than AKAIO's compatibility.
     
  6. Jasper07

    Jasper07 GBAtemp Fan

    Member
    318
    0
    Aug 17, 2009
    Netherlands
    Parallel universe
    The EZ-Flash is very good in my opinion, it also gets alot of updates...
    but the AK is better [​IMG]
    - never mind
     
  7. Vigilante
    OP

    Vigilante TempLurker

    Member
    1,555
    46
    Jan 1, 2010
    CyberSpace IQ:OVER 9000
    need more answers everyone
     
  8. fairlyevenparents

    fairlyevenparents GBAtemp Fan

    Member
    417
    0
    Sep 21, 2009
    United States
    united states
    Get the acekard2i.
    End of story.
     
  9. EyeZ

    EyeZ GBAtemp Addict

    Member
    2,496
    523
    Dec 4, 2009
    the acekard + AKAIO, a very hard act to follow, the support with the loader updates for these newer

    games is awesome, so there can't be "what if i do not find one", you gotta find one