Ok to Update DSi?

Discussion in 'Acekard' started by lexluthor5, Sep 16, 2009.

  1. lexluthor5
    OP

    lexluthor5 Member

    Newcomer
    19
    0
    Sep 30, 2008
    United States
    I just got my DSi and am awaiting my AceKard from DealExtreme.

    I notice that it won't let me into the DSi unless I perform the system update.

    Am I definitely safe to do that system upgrade or is there a risk the AceKard won't work? It looks likes from the other posts, there is a fix, but I want to be sure.

    Has anyone system upgraded? Any problems at all after?

    What else won't it let me do if I don't upgrade?
     
  2. tedmg09130913

    tedmg09130913 GBAtemp Regular

    Member
    215
    0
    Aug 23, 2007
    United States
    If you don't have a ds lite you should wait until you get the acekard and first update the acekard to run on dsi firmware 1.4. Then update the dsi.
     
  3. lexluthor5
    OP

    lexluthor5 Member

    Newcomer
    19
    0
    Sep 30, 2008
    United States
    Why does the order matter? And what would it matter if I have a DS Lite (which I do).

    How do I update the AceKard to work with DSi 1.4?

    I just downloaded the AceKard files from the download section on their website. That's not the newest version that supports 1.4?
     
  4. C175R

    C175R GBAtemp Pirate

    Member
    662
    0
    Sep 12, 2009
    United States
    DS 1.4 will block your acekard unless if you upgrade your acekard to a Dannycard or whatever people calls it.
    but if you have a ds lite you can update your acekard with your ds lite and then play it on your updated dsi
     
  5. lexluthor5
    OP

    lexluthor5 Member

    Newcomer
    19
    0
    Sep 30, 2008
    United States
    Oh, I see. So I need to update the firmware on a DS, not on my windows machine.

    So, how do I get this Dannycard update? Once I have in installed on my Acekard, there's definitely no problem upgrading the DSi to 1.4?

    Is Acekard committed to releasing an official fix for 1.4? I see the note on the web site saying so, but that's a month and a half old yet. That doesn't inspire much confidence. Do you think they'll actually continue to properly support the DSi and release an official update?

    Lastly, is it possible to get into the DSi store (and whatever else you can't do) without upgrading the DSi to 1.4?
     
  6. tedmg09130913

    tedmg09130913 GBAtemp Regular

    Member
    215
    0
    Aug 23, 2007
    United States
    After you get the acekard2i install akaio software which is better than the official acekard software. Then run the dsi1.4 firmware compatible bootloader update firmware. You will now have a dsi firmware 1.4 compatible acekard2i. You must have dsi firmware 1.4 to access the dsi store.
     
  7. tedmg09130913

    tedmg09130913 GBAtemp Regular

    Member
    215
    0
    Aug 23, 2007
    United States
    Please ignore this second post which was caused by connection problem with gbatemp.
     
  8. lexluthor5
    OP

    lexluthor5 Member

    Newcomer
    19
    0
    Sep 30, 2008
    United States
    So I want to use this firmware
    http://gbatemp.net/index.php?download=5069

    As opposed to this one?
    http://www.acekard.com/download.php (version 4.18)

    Then one top of that, I want to this
    http://www.gbatemp.net/index.php?showtopic=174529
    by running it on my DSi prior to upgrading the DSi to 1.4 firmware.

    That's pretty much it now?

    What about on the Akaio download link where it says I need a loader too? What's that do?

    Also, how can I be certain that the fix took before I upgrade to 1.4 firmware?