Hacking New SX OS user, cannot seem to boot in CFW

EV90

New Member
OP
Newbie
Joined
Oct 8, 2019
Messages
4
Trophies
0
Age
33
XP
62
Country
Netherlands
Hi everyone, I have a day1 Switch, and I have been trying to get custom firmware on it for multiple days now. I have bought an SX OS license, and a 200GB MicroSD card which is formatted to FAT32.

My Switch is on official firmware 9.0.1, and when I put my Switch in RCM it gets detected bij TegraRcmGUI, and when I inject the SX OS launcher bin I see 3 options on my switch: Boot custom FW, Boot original FW and Options. When I select custom fw, it prompts me for a license file, and when I click continue 2 times I get a black screen and nothing happens. Is there anything I'm doing wrong? When I create a license dat file through the website the whole Switch refuses to bootup the SX OS menu, it only shows the SX OS logo for a few seconds, and after that I get a black screen. Also it says in the boot menu on the switch that EMUNAND is disabled. I'm kinda lost here...
 
Last edited by EV90,
D

Deleted User

Guest
Did you get the latest SXOS version? Only the latest one is able to boot 9.0.X firmware.

--------------------- MERGED ---------------------------

You need to have the license.dat file on the SD card, and also make sure you have the latest SXOS as it's the only one of the SXOS versions to be able to boot 9.0.X
 

EV90

New Member
OP
Newbie
Joined
Oct 8, 2019
Messages
4
Trophies
0
Age
33
XP
62
Country
Netherlands
It sounds like you doesn't have the license.dat file on your SD card.
That's the problem, when I place it on the MicroSD the whole SX OS boot menu doesn't work anymore. The logo only flashes for 2 seconds after injecting the payload file.

--------------------- MERGED ---------------------------

Make sure you are using SXOS 2.9.2.
Yes I'm using the 2.9.2 beta from the official SX OS website, but no luck...

--------------------- MERGED ---------------------------

Did you get the latest SXOS version? Only the latest one is able to boot 9.0.X firmware.

--------------------- MERGED ---------------------------

You need to have the license.dat file on the SD card, and also make sure you have the latest SXOS as it's the only one of the SXOS versions to be able to boot 9.0.X

Yes I'm using 2.9.2 beta.
 

linuxares

The inadequate, autocratic beast!
Global Moderator
Joined
Aug 5, 2007
Messages
13,385
Trophies
2
XP
18,314
Country
Sweden
Is your license.dat file injected with your serial etc from their website? Because first time you run the sxos boot menu, it will create a license file. This file you need to take to their website, upload it and put in your serialkey for the software, then generate. Copy said file back to the SD Card.
 

EV90

New Member
OP
Newbie
Joined
Oct 8, 2019
Messages
4
Trophies
0
Age
33
XP
62
Country
Netherlands
Is your license.dat file injected with your serial etc from their website? Because first time you run the sxos boot menu, it will create a license file. This file you need to take to their website, upload it and put in your serialkey for the software, then generate. Copy said file back to the SD Card.
That did the trick! Thanks!

When I inject the payload bin now it automatically boots into the CFW, is this normal behavior?
 

linuxares

The inadequate, autocratic beast!
Global Moderator
Joined
Aug 5, 2007
Messages
13,385
Trophies
2
XP
18,314
Country
Sweden
That did the trick! Thanks!

When I inject the payload bin now it automatically boots into the CFW, is this normal behavior?
Yes, they set it to autoboot normally. If you want to access the menu, just hold down the L (I think it was, maybe it was R) button when you turn it on or reboot your Switch.
 
  • Like
Reactions: EV90

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    SylverReZ @ SylverReZ: He's the reason why the banks closed lol.