N3DS LL motherboard replacement help

Discussion in '3DS - Console, Accessories and Hardware' started by anonynom, Nov 22, 2016.

  1. anonynom
    OP

    anonynom Punchyleaf

    Member
    405
    94
    Aug 19, 2015
    United States
    New Jersey
    got a new pikachu 3DS LL in and opened it up, was very gentle with everything. Took my NEW 3DS XL NA motherboard and switched, made sure everything was back in place, but now the system won't even turn on. It just makes a popping noise with the blue power light on, no screen flashing nothing comes on. Just blue power light for a few seconds and popping sound before It turns off.
     
  2. Potato hoarder

    Potato hoarder Hoarder of Potatoes

    Member
    383
    102
    Feb 2, 2016
    Canada
    Toronto, Ontario, Canada
    Double check that the ribbon cables are properly seated. That's the most likely reason. The second is that they are torn.
     
  3. anonynom
    OP

    anonynom Punchyleaf

    Member
    405
    94
    Aug 19, 2015
    United States
    New Jersey
    Could the long ribbon cable shown in the last image be damaged ? I've just noticed small scratches or so and I know I didn't do those because they're on parts I didn't touch
     

    Attached Files:

  4. Neptune

    Neptune GBAtemp Advanced Maniac

    Member
    1,588
    531
    Dec 7, 2003
    United States
    Internet
    Does one of the screens flash? If so the one that did NOT flash is not plugged in/damaged. If neither flashed then both are damaged/not plugged in correctly.
     
  5. anonynom
    OP

    anonynom Punchyleaf

    Member
    405
    94
    Aug 19, 2015
    United States
    New Jersey
    Neither flash. Just nothing but blue light goes on for 3 seconds or so and "pop" and off. I guess I'll try checking for damage. What are the most obvious signs of damage besides tearing of course.
     
    Blue_Mew likes this.
  6. Ericjwg

    Ericjwg Good

    Member
    2,828
    683
    Jul 2, 2015
    Canada
    all of these only for the pikachu shell.
    you won:)
     
  7. anonynom
    OP

    anonynom Punchyleaf

    Member
    405
    94
    Aug 19, 2015
    United States
    New Jersey
    I have the NTSC one so not really no. My friend wants one as well so I'm trying to do this for him.
     
  8. Eruandou

    Eruandou Member

    Newcomer
    46
    18
    Feb 15, 2016
    Argentina
    the flex ribbon for the top screen (shown in img_4439) is plugged backwards (and not as you show on img_4437). The brown section should face up, not down.
     
  9. anonynom
    OP

    anonynom Punchyleaf

    Member
    405
    94
    Aug 19, 2015
    United States
    New Jersey
    !!!!! I will try this now and report back :)

    — Posts automatically merged - Please don't double post! —

    Seems to be plugged in right actually. In 4439 I had it unplugged to show the cable underneath :/

    Looks like this currently, shiny side up and dull side down
     

    Attached Files:

  10. SuperJosh64

    SuperJosh64 Member

    Newcomer
    21
    2
    Oct 29, 2016
    United States