My EZFlash IV experience and how I solved my game loading problem.

Discussion in 'EZ-Flash' started by AirplaneRandy, Nov 8, 2014.

  1. AirplaneRandy
    OP

    AirplaneRandy Newbie

    Newcomer
    4
    0
    Nov 8, 2014
    Canada
    Day 1

    EZFlash IV finally arrived, super excited. Do everything normally, update the firmware to the latest version removing that god awful Star Wars skin, replacing it with Clearlooks. Use the client to put all my favorite GBA games and potential new favorites into the 1GB micro SD card. All the games work amazingly, no slowdowns, no NOR problems, heck, Mother 3 worked with a small hitch (254 Mb write problem), but overall, super happy with my unit.

    Day 2

    Problems arise, games just don't work when trying to play directly off the SD card via psram, super annoyed at this point. But the games run off the NOR perfectly, able to flash, delete, and write off it easily. Okay, that's alright, can still play my GBA games, no problemo.

    Day 3 (more like day 5 cause I haven't touched the thing in a while)

    Brother asks to play Castlevania: Circle of the Moon. I gleefully abliged. Try deleting existing game off NOR, won't work. Nothing worked, eventually, when try to play existing game off the NOR (Minish Cap), it would go to a corrupted screen instead 50% of the time (the other 50% it worked).

    At this point, I was super mad, I thought I was ripped off, 70 Canadian Dollarydoos I paid for this thing. Left dissapointed that my brother could not play Castlevania.

    Had a revelation, what if it was not the hardware that was at fault, but the software, what if that modified skin was doing something funny with my EZFlash... remembered that I put a game into the Star Wars EZFlash and it worked. Thought to myself, what if I replace the firmware with the official one from the Chinese site, AKA, the Star Wars one. I did it, and guess what, all my games worked, the psram worked, the NOR worked. I can finally start playing my games and my brother can play Castlevania. All was good again!:rofl:

    TL;DR

    Use the original official unmodified firmware if you got any problems with you EZFlash IV, it's damn ugly and campy, but it works! :gba:

    Thanks for reading my journey, my brother is playing the GBA right now as I posted this. Will update if problems arise again (HOPEFULLY NOT DAMN IT!).

    EDIT: The only game not working so far is Super Mario Bros 3, but it could very well be a compatibility issue as it loads fine, but the graphics and sounds are corrupted. This issue is not related to my original problem however. Will replace the rom in the future if it will fix the problem.
    Fixed Super Mario Bros 3, just had to change the default save space from 1024kb to 128kb.

    Also, I forgot to mention, minesweeper only worked using the Star Wars original firmware. It never worked when I used the Clearlooks v5 skin. That really says something here.

    EDIT: Streetfighter 2 Revival only worked on NOR (awesome). Goldensun 1 froze at the big boulder part on psram, but it was able to get pass that part by running off NOR (great).
     
  2. Xygrid

    Xygrid Member

    Newcomer
    34
    14
    Dec 24, 2012
    United States
    Texas
    Thanks for the detailed info... I am always curious about the little details...
    Someone said the supercard available on amazon was poor quality... and you have to patch individual games and not all games will work....BUT, it works with some games in a pinch ... if your patient and keep things organized...
    (oh yeah... no real save function... you can save in a slot... but may or may not always work) that can be a definite deal breaker!
    Also the battery drain is a huge factor! about 1/2 the battery life or less ... depending on game and screen brightness...!!!

    Did you notice any large battery drain with the EZFlash IV?
     
  3. AirplaneRandy
    OP

    AirplaneRandy Newbie

    Newcomer
    4
    0
    Nov 8, 2014
    Canada
    I can't tell, this is a really old GBA battery, the battery always changes the led to red quickly (SP model), I'm gonna need to purchase a replacement from nintendo in the future. So I can't answer your question.
     
  4. MartinAugustsson

    MartinAugustsson Member

    Newcomer
    46
    15
    Jan 17, 2012
    You could try downloading this version of the clearlooks skin if you already haven't.
    http://www.mediafire.com/download/h4xmh2vbdk3pp9d/Clearlooks v5.zip
    It has both the 1.72 and 1.74 version of the skin. (1.72 is for the older version of the flashcard and the 1.74 is for the newer version)
    I've never had any problems with the 1.74 version on my flashcard. You should give it a shot!
     
  5. AirplaneRandy
    OP

    AirplaneRandy Newbie

    Newcomer
    4
    0
    Nov 8, 2014
    Canada
    That was the version that I used. Heck, I tried switching to several different 1.74/1.72 modified skin versions before deciding to go back to the official star wars one.
     
  6. MartinAugustsson

    MartinAugustsson Member

    Newcomer
    46
    15
    Jan 17, 2012
    Ah, that is weird. Sounds to me that there's an issue with the card, but I'm glad that it's working with the star wars skin at least!
     
  7. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    4,050
    1,154
    Nov 21, 2005
    United States
    get a real Mini-SD Card will solve all issues with saving/loading all that crap
     
  8. N7Kopper

    N7Kopper Proud lover of a three-inch girlfriend

    Member
    412
    148
    Aug 24, 2014
    The issue was solved by using the stock skin with the latest firmware - which must be a problem with the cart itself, as I myself use Clearlooks with a microSD adapter. No problems.