Moving from o3DS XL to n3DS - Questions

Discussion in '3DS - Flashcards & Custom Firmwares' started by IronClouds, Dec 2, 2016.

  1. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    n3DS: Stock 11.0.0-33U
    o3DS XL: A9LH+Luma 11.2U

    Got a New 3DS yesterday that came with 11.0 on it (it's the $99 limited edition one, for anyone wondering what FW it comes with!). Been pushing through Plailect's guide since I'm planning on making the n3DS my new main one and selling my o3DS. Anyway, I just completed section III - steelhax, which looks to be done all on the SOURCE 3DS (my o3DS XL). I was able to launch the HBL from Steel Diver twice and have already selected N3DS 11.0.0-33 as the firmware the on the second launch of the game/exploit, and have moved the starter.zip contents to the root of the TARGET 3DS (my n3DS) SD card.

    So on to section IV of the guide. I don't have any way to launch the HBL on the n3DS since obviously it's stock FW and I don't own any of the games that have exploits. Here are my questions:

    1. Do I have to stay on 11.0 on the TARGET 3DS? Can't I just update to 11.2 and skip the ctr-httpwn section altogether?
    2. I don't own any of the games that have launch exploits (or a Powersaves), so I can't launch HBL on the n3DS. How can I get HBL to launch on the n3DS?
    3. I have two SD cards, but the bigger one is obviously in the SOURCE 3DS (my o3DS). When the system transfer eventually happens, I'm assuming the TARGET 3DS (my n3DS) will run out of space on the included microSD (it's a paltry 4GB). I don't have another bigger one to replace it with, either. I eventually plan to switch the cards once all is said and done, and don't mind having to manually re-download stuff later on the n3DS if that's possible. What can I do about this?
     
  2. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    1) Yea you can update
    2) Buy a 11.2 entry point primary or secondary entry point and set up on source 3DS
    3) Backup SD card and reduce enough space on source 3DS <4gb (keep in mind illegal downloads and data won't transfer so get rid of these first)

    You can restore the SD card after the transfer I believe, but will have to re-add the tickets once hacked for your previous illegal/illegitimate apps to show up again.
     
  3. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    Thanks for the answer! I'd already bought Legends of Exidia on the source 3DS and set up/tested the save in section 2, so I'm good there. So then once I update my n3DS to 11.2:
    • Clear up space on my o3DS' bigger SD card to <4GB space.
      • I have some big legit eShop games that take up most of the space. I already backed up my saves using JKSM, though. I should be able to safely delete them from the o3DS, re-download them from the eShop on the n3DS once the transfer is complete, and import my saves after that, right?
    • Skip the ctr-httpwn part of Plailect's guide.
    • Proceed to the system transfer section of Plailect's guide and just continue through the rest of the guide, right?
     
  4. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    • Clear up space on my o3DS' bigger SD card to <4GB space.
      • I have some big legit eShop games that take up most of the space. I already backed up my saves using JKSM, though. I should be able to safely delete them from the o3DS, re-download them from the eShop on the n3DS once the transfer is complete, and import my saves after that, right? Yes, legit items move over with NNID and you can restore saves after hack with JKSM (double check you indeed backed all up).
    • Skip the ctr-httpwn part of Plailect's guide? Yes, after 11.2 update you may.
    • Proceed to the system transfer section of Plailect's guide and just continue through the rest of the guide, right? Yes.
     
    IronClouds likes this.
  5. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    Alright so the system transfer is complete and I'm now on section 8 of the DSi Downgrade guide (Flashing the target 3DS' NFIRM). It clearly says in the guide not to downgrade on a device that has a9lh installed or I'll brick, but I shouldn't have a9lh installed already as a result of the transfer, right? So I'm clear to proceed?

    This DSi Downgrade guide is simply to enable an entrypoint for HBL on my n3DS (steelhax, it seems), and with that entrypoint, I'd use another guide to get Luma+a9lh on this n3DS like I did with the o3DS I transferred from, right?
     
  6. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Yes if your A9LH system was red and stock system was blue, you should be on the blue system now.

    DsiWare is set up so you can downgrade the firmware from 11.0 to 9.2 and install A9LH. The purpose of steelhax is to have HBL entry to run downgrader on stock 3DS after the DSiWare hax is executed successfully.
     
    Last edited by el_gonz87, Dec 3, 2016
  7. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,222
    2,861
    Jul 23, 2012
    United States
    Octo Canyon
    Yeah, updating to 11.2 and following the guide skips the entire crt-httpwn section, so I did that and all went smooth. After the DSi downgrade method, SafeA9InstallerHax did a flawless downgrade to 9.2, and it was smooth sailing from there. Backed up my otp.bin and everything while I was at 9.2 as well.

    Wanna know what was the hardest part of this entire hack?

    Waiting the 7 days to transfer my 2DS stuff back from my girlfriend's unit. (I got her a 2DS that has the blue face, came with 11.0, but 11.2 was easier to do the NFIRM downgrade for me.)

    It was torture having to use her 2DS for my own selfish StreetPasses during the week... The guilt ate me alive inside, haha! :yay3ds:
     
  8. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    Awesome! So I completed that section to dump my f0f1 and flashed 10.4 per the guide. My fw still shows as 11.2 in system settings and Steel Diver won't launch (keeps saying "An error has occurred"). Any ideas as to why?
     
  9. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    What did you set the install firmware for when you did this on CFW 3DS? If you updated to 11.2 then you should have selected 11.2
     
  10. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,222
    2,861
    Jul 23, 2012
    United States
    Octo Canyon
    I never got the Steel Diver section working, and used BaseHax instead. If you have a way to flash saves to a cartridge game, use either Cubic Ninja, Pokemon OR/AS, or OoT3D.
     
  11. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    Ahhh there's my problem. I originally set it to 11.0 because that's what the n3DS started at. Then we figured it'd be easier to just update it to avoid httpwn and I never went back to redo it in Steel Diver on the CFW 3DS

    I have none of these cartridges or a PowerSaves :<
     
  12. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Darn it, prob should have stayed this as it is implied, unfortunately you are gonna need a cart now to set it up. You can do any secondary, do u have OOT3D?
     
  13. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    The only cart I own is Pokemon HeartGold. :<
     
  14. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Welp gonna need to get one, borrowed or rented don't matter, but you need a new entrypoint. Otherwise you are stuck I'm afraid
     
    Last edited by el_gonz87, Dec 3, 2016
  15. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    So if I rent OOT3D, isn't there a cart version that can't be used for the exploit? Like, a Nintendo Selects version or something?
     
  16. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    No if you rent it, u can install the HBL hax on your CFW 3DS and use it on the stock
     
  17. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    So no matter what, I can use any OOT3D cart on my n3DS to install/launch HBL, then proceed through the rest of the DSi Downgrade guide and eventually get Luma+a9lh on it, right? My CFW 3DS (the o3DS XL) I'm guessing is no longer needed since the transfer is complete?
     
  18. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Since OOT3D is secondary exploit by itself you need CFW 3DS to install the exploit. After that you don't need it anymore, but test after install before you get rid of it
     
  19. IronClouds
    OP

    IronClouds GBAtemp's Pokébro

    Member
    1,019
    460
    May 8, 2010
    United States
    Well now my o3DS XL isn't even powering on (blue light flashes for a second and turns off). I'm guessing because I'm not using the SD card it needs for the a9lh stuff or whatever. Sorry to be a bother, can you remind me what files it needs in the SD card so it'll boot up properly?

    — Posts automatically merged - Please don't double post! —

    o3DS XL = old/source CFW 3DS
    n3DS = target non-CFW (yet) 3DS
     
  20. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    Download the latest luma release and put the file "arm9loaderhax.bin" on root of as card. It should boot to luma config