M3i and DSLinux

Discussion in 'M3 Adapter' started by ARK6476, Dec 5, 2009.

Dec 5, 2009

M3i and DSLinux by ARK6476 at 11:09 PM (2,200 Views / 0 Likes) 8 replies

  1. ARK6476
    OP

    Newcomer ARK6476 Member

    Joined:
    Dec 1, 2007
    Messages:
    13
    Country:
    United States
    First off, sorry if this has already been addressed. I've googled around, and used gbatemp's search function but I can't seem to find an answer.

    I'm having trouble getting DSLinux to run on the M3i Zero. I know Sakura has issues with homebrew, but I've had no luck with the touchpod either. On both firmwares, I've tried all the different booting options, but no matter what I just get two white screens.

    I also have a M3 Lite that has DSLinux on it. When I boot to the M3 Lite from the touchpod, DSLinux won't work; however, if I use my old passcard to boot, DSLinux works just fine. Don't know if that is relevant to my problem, but it seemed worth mentioning.

    Is there any sort of fix for this, such as a 'made for sakura' version of dslinux? Or am I just out of luck?
     
  2. lincruste

    Member lincruste GBAtemp Regular

    Joined:
    Jan 13, 2008
    Messages:
    165
    Location:
    france
    Country:
    Hi,
    Please give information about your hardware. Neither did I manage to get DSLinux to run on an M3izero (Touchpad) on DSi. Since many features are no more accessible with the DSi new hardware (like backlight control, sleep mode on a few homebrew apps or real time save on commercial roms), something may prevent DSLinux from booting.
     
  3. ARK6476
    OP

    Newcomer ARK6476 Member

    Joined:
    Dec 1, 2007
    Messages:
    13
    Country:
    United States
    I'm using a DS Lite. I'm pretty baffled, it should be working since it's DLDI compatible, maybe I should try patching it myself instead of counting on the M3's autopatcher?
     
  4. ARK6476
    OP

    Newcomer ARK6476 Member

    Joined:
    Dec 1, 2007
    Messages:
    13
    Country:
    United States
    Well that didn't work either. I'm out of ideas at this point. Can anyone else think of something?
     
  5. Traz

    Newcomer Traz Member

    Joined:
    Apr 8, 2009
    Messages:
    18
    Country:
    United States
    For some reason, pressing X instead of A when loading DSLinux will make it work for me, maybe it will work for you too.
     
  6. lincruste

    Member lincruste GBAtemp Regular

    Joined:
    Jan 13, 2008
    Messages:
    165
    Location:
    france
    Country:
    I remember having DSLinux to work great on my DSLite with an M3DSREAL. You can try this:
    - Verify your DSLinux version. Use DSLinux.nds, not DSLinuxM.nds wich is for Slot-2 RAM expansions equipped DS only.
    - Try to replace your Sakura dual boot with the original Touchpod firmware.
    - Try running DSLinux.nds within DSOrganize !

    Keep us informed about your tests please.
    Goog luck!
     
  7. ARK6476
    OP

    Newcomer ARK6476 Member

    Joined:
    Dec 1, 2007
    Messages:
    13
    Country:
    United States

    Thanks for your suggestions! Unfortunately, I'm still getting the same results. I tried the original touchpod firmware, but I just ended up with a top black screen and a bottom screen that says "DLDI Compatible". DSOrganize doesn't work either. I'm thinking this might be because the M3i was designed to run on the DSi.
     
  8. lincruste

    Member lincruste GBAtemp Regular

    Joined:
    Jan 13, 2008
    Messages:
    165
    Location:
    france
    Country:
    Thanks for the feedback, too bad it didn't work.[​IMG]
    Actually it does not either run on an M3i Zero on my DSi. I suspected the new hardware so far, but with your feedback it indeed seems it comes from the linker itself.
     
  9. kolijoco

    Newcomer kolijoco Newbie

    Joined:
    Jan 28, 2010
    Messages:
    1
    Country:
    United States
    i alo am having trouble running dslinux on a dsi with m3i zero...
    i get as far as two black screens, the touch one displaying:
    "DLDI Compatible" in the center, and "Loading..." in the bottom right corner.
    i'm using the supplied m3 manager v4.7d X launcher/loader thingy... (i think my m3i firmware is as up-to-date as it gets)
     

Share This Page