Looking to buy a supercard but i have some questions

Discussion in 'Supercard' started by xkaotic1, May 17, 2012.

  1. xkaotic1
    OP

    Newcomer xkaotic1 Newbie

    Joined:
    Apr 1, 2012
    Messages:
    5
    Country:
    United States
    I have a Dsi on 1.4.4 will i need another Ds to update it? Is it worth the 40 bucks or should i just buy a cheaper flashcard?
     
  2. Crystal the Glaceon

    Member Crystal the Glaceon GBAtemp Inkling™ Squishies~

    Joined:
    Sep 13, 2009
    Messages:
    14,729
    Location:
    Inkopolis
    Country:
    Antarctica
    You do need another DS to update it. (last I checked)
    If you have the money to buy a Supercard DStwo, it has tons of features no other flashcard has. I also suggest getting it cheaper here
     
  3. xkaotic1
    OP

    Newcomer xkaotic1 Newbie

    Joined:
    Apr 1, 2012
    Messages:
    5
    Country:
    United States
    i guess i wont be getting one since i only have 1 Ds. unless i can find a place that has them preflashed for 1.4.4 i will buy one. I already have a acekard im looking to update
     
  4. Rasas

    Banned Rasas Banned

    Joined:
    Apr 7, 2010
    Messages:
    643
    Country:
    United States
  5. Rasas

    Banned Rasas Banned

    Joined:
    Apr 7, 2010
    Messages:
    643
    Country:
    United States
    If you won't use the features the DStwo adds like Real time save, GBA and some others there is no point buying one. Waste of money. Just ask yourself will you use them and how much will you use them if any.
     
  6. Terminator02

    Member Terminator02 ヽ( 。 ヮ゚)ノ

    Joined:
    Apr 10, 2010
    Messages:
    4,517
    Location:
    Somewhere near monkat
    Country:
    United States
    This is not true, DSi compatibility is solely based on the EOS, which is simply files drag-n-dropped onto the MicroSD. The OP does not need another DS to update (that's only required for 3DS compatibility).

    And the DSTWO supports DSi v1.44 too, without flashing either.
     

Share This Page