Is it safe to install Sonic 4 (NTSC) on a PAL Wii?

Discussion in 'Wii - Hacking' started by Zeldafanzero, Oct 12, 2010.

  1. Zeldafanzero
    OP

    Zeldafanzero Advanced Member

    Newcomer
    61
    0
    Nov 12, 2008
    I know that NTSC games on disks can brick PAL Wiis, but can I install Sonic 4 on my 4.1E Wii?

    Also, which IOSes do I need to install, and do I need the US versions or the PAL ones?

    Many thanks!
     



  2. Use first "freethewads". Then install the wad with Wad Manger 1.7. Runs perfectly on PAL Wii. Pal languages are included too.

    The game uses ios56 to run, so maybe you should install the latest version, when problems occur.
     
  3. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,234
    3,885
    Nov 17, 2008
    Australia
    Queensland
    if you've used the latest version of pimp my wii ios56 should be installed right?
     
  4. Gangboy

    Gangboy Advanced Member

    Newcomer
    88
    0
    Sep 21, 2007
    Netherlands
    Installed the NTSCU on my PAL 4.2E without any changes/modifications. So it works for me without any problems. [​IMG]
     
  5. Zeldafanzero
    OP

    Zeldafanzero Advanced Member

    Newcomer
    61
    0
    Nov 12, 2008
    Thanks! Can anyone else confirm? [​IMG]
     
  6. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,234
    3,885
    Nov 17, 2008
    Australia
    Queensland
    you would have had to use freethewads or something otherwise you get this chan cannot be run??
     
  7. G0dLiKe

    G0dLiKe who needs a title ;)

    Member
    1,674
    51
    Aug 2, 2009
    United States
    I personally used anyregionchanger to output ntsc video signal on my wii and i used preloaders regionfree games and channels hack or so.
     
  8. Zeldafanzero
    OP

    Zeldafanzero Advanced Member

    Newcomer
    61
    0
    Nov 12, 2008
    Is Freethewads safe? I seem to remember when it first came out people advised against using it.
     
  9. Gangboy

    Gangboy Advanced Member

    Newcomer
    88
    0
    Sep 21, 2007
    Netherlands
    Didn't need to change anything, no freethwads to change the region. Maybe it's because i'm on 480P and doesn't need a singal output change [​IMG]

    Do have priiloader on with region free games, so maybe that's why I didn't had to patch it. [​IMG]
     
  10. G0dLiKe

    G0dLiKe who needs a title ;)

    Member
    1,674
    51
    Aug 2, 2009
    United States
    I remember from my wii when i start a channel other than the wiis region it just said this channel cannot be used or so, no bricking here.
     
  11. Zeldafanzero
    OP

    Zeldafanzero Advanced Member

    Newcomer
    61
    0
    Nov 12, 2008
    Thanks!

    Also, is the release name on here correct?
     
  12. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,234
    3,885
    Nov 17, 2008
    Australia
    Queensland
    that would be why than

    penguin bar FINALLY decided to upload it lazy asses!
     
  13. Dirtee

    Dirtee Newbie

    Newcomer
    2
    0
    Oct 12, 2010
    He Guys i cant get this to run at all!!

    i have the NTSC version of sonic 4 and i have a PAL Wii 4.1E

    i have never got my priiloader to run channels in region free even though i set it to do so in the hacks!

    so i used FreeTheWads gui and patched my Sonic 4 to PAL

    both my NTSC and my (supposed PAL patched) wads dont run! even with priiloader hacks set to region free channels!

    i currently get the blue screen error "ERROR #002" an error has occured please press the eject button, remove the game disc and power off the console blah blah!

    if anyone knows an answer to my problem ill be most helpful!!

    im going to look for a newer ios56 now and ill report back

    cheers!!
     
  14. Bladexdsl

    Bladexdsl ZOMG my posts...it's over 9000!!!

    Member
    16,234
    3,885
    Nov 17, 2008
    Australia
    Queensland
    your not missing much this is a great big disappointment i knew sega would somehow find a way to fuck it up.
     
  15. Dirtee

    Dirtee Newbie

    Newcomer
    2
    0
    Oct 12, 2010
    haha i see what you mean! i managed to fix it though! it was ios56!!

    downloaded via NUS Downloader as wad and installed with wad manager 1.7 = all good!

    shame the game is more like sonic advance than sonic 1,2,3 :-(
     
  16. Alv

    Alv Newbie

    Newcomer
    1
    0
    Aug 16, 2010
    Hello,

    I have 4.3E with Wasabi DX. I havent anything homebrew. I have a PAL Wad of it.

    Then i need install Homebrew channel and Wad Manager, but for run Wad Manager with my 4.3E, i need modify IOS/cIOS/trucha bug or anything?


    Thanks,
     
  17. Jamstruth

    Jamstruth Secondary Feline Anthropomorph

    Member
    3,456
    185
    Apr 23, 2009
    North East Scotland
    Having trouble installing Sonic 4 at all on my 4.3E Wii. I have installed WADs before for homebrew but my Sonic 4 WAD (treated with freethewads to PAL) refuses to install. Can't remember the exact error that comes up in WADManager though.
    Should I use someothing like "Pimpmywii" to just trucha bug everything? I usually use IOS249 to install.
     
  18. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    I've installed NTSC wads with no problems. Used the sticky about four months back and used USB Loader to launch them.
    [​IMG]
    I installed it (PAL) with no problems. (It's a shitty game anyway, wait for Sonic Colors :3)
     
  19. creativ

    creativ GBAtemp Regular

    Member
    144
    1
    Sep 12, 2009
    Gambia, The
    you are shitty !
     
    1 person likes this.
  20. Jamstruth

    Jamstruth Secondary Feline Anthropomorph

    Member
    3,456
    185
    Apr 23, 2009
    North East Scotland
    I want to see how terrible the Console versions are compared to the iPhone version (which I also pirated).
    Anyway, I get Error (ret=-4100) whatever that means. It could mean I've fucked up the WAD (which is entirely possible)