Is DSTWO compatible with firmware 9.9 on 3DS ?

Discussion in 'Supercard' started by Miggg, Aug 2, 2015.

  1. Miggg
    OP

    Miggg Member

    Newcomer
    12
    0
    Aug 1, 2015
    Canada
    Just wondering if I can buy one or not.
     
  2. Sheimi

    Sheimi A cute Vixen!

    Member
    1,992
    899
    Oct 22, 2009
    United States
    Pretty sure it works on the latest firmware.
     
  3. Miggg
    OP

    Miggg Member

    Newcomer
    12
    0
    Aug 1, 2015
    Canada
    K, thanks. I'm pretty new with this stuff so sorry if I sound stupid :P
     
  4. BestR4i3DS.com

    BestR4i3DS.com GBAtemp Regular

    Member
    215
    36
    May 21, 2014
    United States
    it's not your fault ,Nintnedo always update firmware:ph34r:
     
  5. Innos

    Innos Member

    Newcomer
    10
    0
    Aug 27, 2015
    United States
    I recently bought one from here (it says Factory-Updated to DSi 1.4.5 and 3DS 9.7.0-25x), but I've heard that Nintendo has stopped blocking the DSTwo, so will it work on the n3dsxl (latest firmware)?
     
  6. axemurderer

    axemurderer GBAtemp Regular

    Member
    219
    58
    Sep 1, 2014
    United States
    Hoenn nostalgia town
    Yes, I have a dstwo on that update and a n3ds on 9.9, and it works.
     
    Innos likes this.
  7. KennyWYL

    KennyWYL Member

    Newcomer
    41
    10
    Aug 20, 2015
    Malaysia
    Yes,

    I owned a chinese version DSTWO, loaded with Chinese firmware & EOS. Self mod to English compatible menu. Still works until O3DS 9.9.
     
  8. oFire

    oFire GBAtemp Regular

    Member
    119
    35
    Oct 6, 2015
    United States
    I have a 10.1 New 3ds XL and it works fine on this version for me. Using the newest Firmware 1.25 from the DStwo website.
     
  9. 89turbocs

    89turbocs Advanced Member

    Newcomer
    60
    0
    May 20, 2010
    Canada
    Is the flash cart (and roms) all that is needed to run ds/gba/snes games on n3dsxl with fw 9.9?

    Sorry, I've been doing a lot of reading on the subject and I believe the answer is yes, but I'm not quite sure and lots of info is about 3ds rom support which doesn't necessarily interest me.

    Thanks in advance
     
  10. Alternator47

    Alternator47 Advanced Member

    Newcomer
    64
    33
    Sep 2, 2015
    United States
    Yes,
    You can also skip this card altogether and just use GBA and SNES emulators through browerhax.
     
  11. 89turbocs

    89turbocs Advanced Member

    Newcomer
    60
    0
    May 20, 2010
    Canada
    Thanks a lot! I'll look into browerhax. That' just snes and gba emulation?
     
  12. Alternator47

    Alternator47 Advanced Member

    Newcomer
    64
    33
    Sep 2, 2015
    United States
    Well, theres emulators for a ton of systems like nes, etc. You can find the emulator threads in this subforum by searching.
     
  13. Arecaidian Fox

    Arecaidian Fox Pink Foxi

    Member
    947
    1,045
    Sep 5, 2013
    United States
    Snohomish, WA
    There's NDS games themselves to consider. Even if there's currently a way to install DS ROMs onto sys/emuNAND (which I don't believe there is), the DSTWO is still pretty much the best way to play those games. Built-in cheat support and save states for DS games are great tools to have fun with.
     
  14. Baccabechoppin

    Baccabechoppin GBAtemp's Finest Bacca!

    Member
    746
    300
    Aug 10, 2015
    Australia
    Magnolia Town
    Whilst on the topic of DSTwo, is it worth buying one now or waiting to see how the new DSTwo Plus fairs in comparison to the other flashcarts?
     
  15. Arecaidian Fox

    Arecaidian Fox Pink Foxi

    Member
    947
    1,045
    Sep 5, 2013
    United States
    Snohomish, WA
    I would wait, unless patience isn't your thing :P . Waiting means that the DSTWO+ will either drop the price of the original (if you can snag it in that space where both are being produced) or it won't see the light of day at all. But if you buy one now and then the better version comes out, you'd probably be kicking yourself (I know I would). There's also the question of if you even need a 3DS flashcart. If you already have a good CFW on your system, it kind of renders the need for a 3DS flashcart useless. That being said, a regular DSTWO would still be a good way to go to supplement that, solely on the benefits it has when running regular DS games.
     
    Last edited by Arecaidian Fox, Oct 8, 2015
    Baccabechoppin likes this.
  16. bahamut920

    bahamut920 GBAtemp Fan

    Member
    451
    108
    Jan 23, 2009
    United States
    I bought a Supercard off of Playmods and I've downloaded the latest EOS and firmware update. I ran the firmware update on my DSLite and it said "no need to update". I'm assuming this means the Supercard should work just fine on my 9.5.X firmware 3DS? I know I'm probably being overcautious, but I just want to be absolutely certain it will work before I try it on my 3DS, because I know the 3DS bricks any flashcarts it detects. My DSLite works okay, and I'd be fine with using it exclusively on the DSLite, but the L button is unreliable and it's fewer electronics to carry around.

    Is there any way for me to check which firmware version the Supercard is running? I checked myself, but I couldn't find anything in the menus.