Internal modchip - SAMD21 (Trinket M0, Gemma M0, ItsyBitsy M0 Express) Guide, Files & Support

Discussion in 'Switch - Tutorials' started by mattytrog, Jun 20, 2018.

  1. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    They are the same software sir! ;)

    The joycon and volume look too...big?

    You need some smaller wire there mate. But good job mostly :)
     
    goudje likes this.
  2. xstre pwnsx

    xstre pwnsx Member

    Newcomer
    1
    Nov 16, 2008
    United States
    What AWG would you suggest? I was using 30 AWG.
     
  3. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    30 is fine :)
     
  4. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Looks thicker than 30 AWG. If it is 30AWG then you are all good
     
  5. NeoLTK

    NeoLTK Newbie

    Newcomer
    1
    Jan 17, 2019
    France
    Hi, Thank very much you for this work

    I have a problem when the console is started, every 2 seconds the joycon disconnects and reconnects
    I was able to observe on the chip (Trinket M0) when this happens LED 13 lights up and then goes off

    if i disconnect strap joycon, this corrects the problem

    Otherwise everything works

    * I'm use switchboot joycon strap with simple UF2
     
  6. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Poorly soldered GND connection is chief suspect.

    Reflash both files... Leave plugged in for a couple of seconds after flashing. Try again.
     
    NeoLTK and goudje like this.
  7. NeoLTK

    NeoLTK Newbie

    Newcomer
    1
    Jan 17, 2019
    France
    Thank you ! you have solved my problem, reflash was the solution
     
    mattytrog likes this.
  8. B3nnyb0y1990

    B3nnyb0y1990 Newbie

    Newcomer
    1
    Jan 18, 2019
    United Kingdom
    Hi all. Love the work but I actually made a profile just to find out what's wrong. I have a trinket m0 and have done the volume up and joycon mod. It's gone really well and it works but only problem is now that my battery is draining so fast. It's gone from 73 to 66 in the times it's taken to write this. Hopefully someone can help. I've checked my soldering and can't see anything wrong. Been using my trinket since it first started but decided to update how it's all done and kind of regretting it now.
     
  9. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Your battery is draining? It shouldn't be. Want to pay spice of your install? Have you connected the usb strap or have you not bothered?
     
  10. B3nnyb0y1990

    B3nnyb0y1990 Newbie

    Newcomer
    1
    Jan 18, 2019
    United Kingdom
    No one didn't connect the usb strap. Shall I?
     
  11. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    No need really.

    What point are you using for power to trinket?
     
  12. B3nnyb0y1990

    B3nnyb0y1990 Newbie

    Newcomer
    1
    Jan 18, 2019
    United Kingdom
    The one closest to the battery
     
  13. B3nnyb0y1990

    B3nnyb0y1990 Newbie

    Newcomer
    1
    Jan 18, 2019
    United Kingdom
    Just noticed that now that It seems to be that when I unplug the battery and plug it back in my switch instantly says it's 100% then just keeps going down? I am now using the other point closest to the joycon rail and it's the same. Also using the usb strap hasn't changed anything. Might just let it run down and see if it stops?
     
  14. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Your BQ24193 or battery is damaged sir.

    The trinket wouldn`t cause that problem unless you had maybe accidentally linked the capacitors on M92T36
     
  15. B3nnyb0y1990

    B3nnyb0y1990 Newbie

    Newcomer
    1
    Jan 18, 2019
    United Kingdom
    My battery is new. Are the capacitors the one you have in the diagram? The 2 that are really close by the battery that's used for power? If so then I'll check tomorrow and what would be the best way to remove the solder from such a small area?
     
  16. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Could be that.

    But there is certainly nothing in the method to drain the battery like that.

    Best thing to do is take some good high-res pictures of your board with the install and let me take a look :)
     
  17. B3nnyb0y1990

    B3nnyb0y1990 Newbie

    Newcomer
    1
    Jan 18, 2019
    United Kingdom
    Well I woke up this morning and it had gone from 45 to 32. I've been at work for ages and it's now on 30 and I've used my switch and it's still on 30. Seems to have settled down now. That was really strange but it isn't draining anymore. Never had that happen before. Seems like when I remove the battery and put it back in my switch instantly says 100% then slowly trickles down to the correct amount. Thanks for the advice. Been following the switch hacking scene since day one and modded my switch with a trinket as soon as this guide started.
     
  18. metaljay

    metaljay GBAtemp Fan

    Member
    5
    Jan 10, 2012
    @mattytrog any ideas what the tiny capacitor directly below the new USB line is? I am not entirely sure but i think ive removed one side of the solder

    it charges when i plug USB C cable in but its become a right pain to get the switchme into boot loader

    [​IMG]
     
    Last edited by metaljay, Jan 19, 2019
  19. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Shouldn't affect it Jord.

    What sort of delay are you leaving between presses? You are leaving usb disconnected until you are in bootloader mode?
     
    metaljay likes this.
  20. metaljay

    metaljay GBAtemp Fan

    Member
    5
    Jan 10, 2012
    Pretty slow, almost like a second between them?
     
Loading...