Hacking How to convert dumped cartridge saves to work with cia installed games?

pwnsweet

Well-Known Member
OP
Newcomer
Joined
Jul 20, 2008
Messages
53
Trophies
0
XP
283
Country
Australia
Please please help me! I own a Gateway and when I was on 9.2 emuNAND I used it to dump the saves from my legally owned 3DS game cartridges. I did this by using the option in the Gateway menu. I've since sold my games and moved over to luma3ds and installed the equivalent cia versions of my games. Furthermore, my 3ds is a New3DS and it's now on 11.5 sysNAND. I want to know if it's possible to convert these saves to work with my cia installed versions of the same games.

Edit - if it helps, I also dumped the cartridges to .3dz files as well.

Edit2 - So I think I know what I need to do. I think I need to create an emuNAND in Godmode9, then downgrade it to 11.2 so that I can use the Gateway card. Then I need to mount the game rips that I made, one by one, and use savedatafiler or JKSM to dump the save each time.
 
Last edited by pwnsweet,

pwnsweet

Well-Known Member
OP
Newcomer
Joined
Jul 20, 2008
Messages
53
Trophies
0
XP
283
Country
Australia
If you didn't dump the saves with JKSM /SVDT/etc then you'll need a Gateway to extract them using https://gbatemp.net/threads/importing-gateway-saves-to-cia-games.425743/
Yep found that thread but being on 11.5, I have no way of opening the Gateway menu. So, correct me if I'm wrong, I'm thing of creating an emuNAND on a separate SD card (which will be on 11.5), downgrading it to 11.2, then I should be able to use the Gateway to mount the games and proceed with that guide.

My question is, does Gateway work on 11.2 on n3ds or only on o3ds? I can't seem to find any answer to this question anywhere. All I can find is that is supports up to 9.2 sysNAND and up to 11.2 emuNAND but I don't know really know what that means. What is the highest firmware that can be used to boot into the Gateway menu???
 
Last edited by pwnsweet,

Quantumcat

Dead and alive
Member
Joined
Nov 23, 2014
Messages
15,149
Trophies
0
Location
Canberra, Australia
Website
boot9strap.com
XP
11,071
Country
Australia
Yep found that thread but being on 11.5, I have no way of opening the Gateway menu. So, correct me if I'm wrong, I'm thing of creating an emuNAND on a separate SD card (which will be on 11.5), downgrading it to 11.2, then I should be able to use the Gateway to mount the games and proceed with that guide.

My question is, does Gateway work on 11.2 on n3ds or only on o3ds? I can't seem to find any answer to this question anywhere. All I can find is that is supports up to 9.2 sysNAND and up to 11.2 emuNAND but I don't know really know what that means. What is the highest firmware that can be used to boot into the Gateway menu???
11.2 is the highest. See https://gbatemp.net/threads/tutorial-using-luma3ds-gateway-on-b9s.431691/ to get Gateway working (once you have an emuNAND on 11.2). As for how to get a lower emuNAND, if you can find a 9.2 CTR transfer file you can CTR transfer the emuNAND down to 9.2 then enable Gateway with the above guide, and try to play Yoshi's Wooly World on Gateway with rom updating turned off (hold Up in the Gateway menu when booting Gateway mode) and that will update the emuNAND to 11.2. Best of luck!
 

pwnsweet

Well-Known Member
OP
Newcomer
Joined
Jul 20, 2008
Messages
53
Trophies
0
XP
283
Country
Australia
11.2 is the highest. See https://gbatemp.net/threads/tutorial-using-luma3ds-gateway-on-b9s.431691/ to get Gateway working (once you have an emuNAND on 11.2). As for how to get a lower emuNAND, if you can find a 9.2 CTR transfer file you can CTR transfer the emuNAND down to 9.2 then enable Gateway with the above guide, and try to play Yoshi's Wooly World on Gateway with rom updating turned off (hold Up in the Gateway menu when booting Gateway mode) and that will update the emuNAND to 11.2. Best of luck!

Thanks for your help so far! It's 36 degrees here in Perth so it's a great day to be indoors working on this stuff but I'd still rather we had your weather today. One question:
Could you help me with this part?

"if you can find a 9.2 CTR transfer file you can CTR transfer the emuNAND down to 9.2"

Is it necessary to go all the way down to 9.2? Earlier you said Gateway can work on 11.2. Can I just CTR Transfer down to 11.2 instead? Also, I was going to downgrade using this guide instead:

https://gbatemp.net/threads/tutoria...to-a-specific-version-with-sysupdater.409633/

Is one method better or easier than the other? I'm sitting here with my emuNAND set up figuring out the best way to downgrade it. Any advice you can give would be appreciated.
 
Last edited by pwnsweet,

Quantumcat

Dead and alive
Member
Joined
Nov 23, 2014
Messages
15,149
Trophies
0
Location
Canberra, Australia
Website
boot9strap.com
XP
11,071
Country
Australia
Thanks for your help so far! It's 36 degrees here in Perth so it's a great day to be indoors working on this stuff but I'd still rather we had your weather today. One question:
Could you help me with this part?

"if you can find a 9.2 CTR transfer file you can CTR transfer the emuNAND down to 9.2"

Is it necessary to go all the way down to 9.2? Earlier you said Gateway can work on 11.2. Can I just CTR Transfer down to 11.2 instead? Also, I was going to downgrade using this guide instead:

https://gbatemp.net/threads/tutoria...to-a-specific-version-with-sysupdater.409633/

Is one method better or easier than the other? I'm sitting here with my emuNAND set up figuring out the best way to downgrade it. Any advice you can give would be appreciated.
You can CTR transfer to 11.2 if you can find the right file, but I think only 9.2 and 11.5 are publicly available.

Jealous of your 36, it has been cold rainy and miserable here all week :)

Edit: if you search for 3Down you might find an 11.2 file but not sure
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
22,206
Trophies
4
Location
Space
XP
11,698
Country
Norway
Yep found that thread but being on 11.5, I have no way of opening the Gateway menu. So, correct me if I'm wrong, I'm thing of creating an emuNAND on a separate SD card (which will be on 11.5), downgrading it to 11.2, then I should be able to use the Gateway to mount the games and proceed with that guide.

My question is, does Gateway work on 11.2 on n3ds or only on o3ds? I can't seem to find any answer to this question anywhere. All I can find is that is supports up to 9.2 sysNAND and up to 11.2 emuNAND but I don't know really know what that means. What is the highest firmware that can be used to boot into the Gateway menu???
Unless they have changed it recently, this will only work with 512KB saves as that's the only save type Gateway supports (when you use the Gateway cart, all saves are made as 512KB so it's no problem, but real cartridges use various save sizes)
There might be a workaround for that, though I've never heard of one.
 

You may also like...

General chit-chat
Help Users
    M4x1mumReZ @ M4x1mumReZ: :rofl2: