how do I solve this errcode=4?

Discussion in 'DSTT' started by Ruzz, Feb 13, 2010.

  1. Ruzz
    OP

    Ruzz Advanced Member

    Newcomer
    55
    0
    Mar 28, 2008
    Senegal
    I'm using DSTT with the latest firmware 1.17 but when I try playing certain games, it still prompts

    [Rom loading failed]
    load rom errcode=-4

    Please reset system.


    the games that I'm trying to get to work are relatively new (i think) - 4622-Bookworm(U) and 4644-Bejeweled Twist(U)
    surprisingly though, my other games work fine like Mario Kart, Brain Age, Legend of Zelda: Spirit Tracks.

    what should I do?
     
  2. basher11

    basher11 GBAtemp's Official Vocaloid Lover

    Member
    4,385
    128
    Jun 29, 2009
    United States
    wait for a fix.
     
  3. Dark^'^Knigh

    Dark^'^Knigh GBAtemp Maniac

    Member
    1,043
    5
    Apr 25, 2007
    Paradise
    Yep, that error could relates to game compatability with DSTT firmware....you need to wait for an update for the unofficial fw 1.17.a12.....if that ever happens again for this flashcart.
     
  4. Ruzz
    OP

    Ruzz Advanced Member

    Newcomer
    55
    0
    Mar 28, 2008
    Senegal
    kk thanks guys.
     
  5. All4consoles-UK

    All4consoles-UK Member

    Newcomer
    44
    0
    Jan 28, 2010
    United Kingdom
    If Ruzz is lucky update for unofficial 1.17a12 should be out in not too distant future provided NDSTT realised they were lagging behind in fixing games compatibilty issues..
     
  6. twiztidsinz

    twiztidsinz Taiju Yamada Fan

    Member
    4,981
    6
    Dec 23, 2008
    United States
    1.17a12 firmware is already out.
    If you meant a newer version than 1.17a12, then I wouldn't hold my breath.

    The official DSTT team isn't 'lagging behind', they flat out aren't releasing new firmware.
    All 1.17a## firmware was "stolen" from ashley (who "stole" 1.17 from DSTT and added compatibility).


    There are tools available to maintain the DSTT firmware -- official or otherwise -- but it requires quite a bit of knowledge and time to do so, so I doubt there will be many people willing to step up and add support to a cart that the official team won't.
     
  7. drwhojan

    drwhojan GBAtemp Psycho!

    Member
    3,658
    685
    Jul 14, 2009
    United Kingdom
    Where I Am!
    Error code=-4 problem has somethink to do with infolib.dat or extinfo.dat for TTDS or ysmenu for R4

    Take the game world of zoo (E)

    If i use the infolib.dat from http://sites.google.com/site/weeklyinfolib/ , the game will get a error code =-4

    If i use the infolib.dat from dsm0125.zip from http://gamewiki.jp/uploader/dsma/ JAP version, the game runs no problem

    But infolib.dat uses the extinfo.dat file

    So it possable that we have to wait for a working extinfo.dat of infolib.dat
     
  8. Valguerra

    Valguerra GBAtemp Regular

    Member
    284
    0
    Jan 1, 2007
    United States
    I do not think it has anything to do with infolib or extinfo cause I have updated and still get the error.
     
  9. twiztidsinz

    twiztidsinz Taiju Yamada Fan

    Member
    4,981
    6
    Dec 23, 2008
    United States
    Technically you're right... It's an antipiracy check failing that gives errcode=4
    What people mean when they say that it has to do with extinfo.dat is that the file, extinfo.dat, contains antipiracy fixes which will sove the errcode=4.
     
  10. bitonio6

    bitonio6 GBAtemp Advanced Maniac

    Member
    1,801
    6
    Sep 30, 2009
    Swaziland
    it's simple, if you pariticipate with the name & the number of the game dont work
    we can create a new extinfo.dat

    So go to this topic and participate -> http://gbatemp.net/index.php?showtopic=210705