Homebrew Haxchi black screen -3 error

toonliger

Member
OP
Newcomer
Joined
Dec 13, 2016
Messages
9
Trophies
0
Age
31
XP
84
Country
Hello team,

I started using my WiiU after a year and a half of not using it. I was installing some GC games using teconmoon inyector. I did something and everytime I use Haxchi while pressing a button (normally to access WUPInstaller or HBMenu) it gives me an error with a black screen and a message -3. Also I tried accessing the Homebrew through the webexploit with no success.

Can someone help me figure out what is happening in my case? Thanks!
 

EmulateLife

Well-Known Member
Member
Joined
May 30, 2016
Messages
3,981
Trophies
0
Age
40
XP
1,860
Country
United States
Go in Haxchi folder on root of sd card and open config.txt, it should have those shortcuts that you're trying to do. Then check in wiiu/apps and make sure that app is still there. Could also be corruption on your sd card if everything is in the appropriate place.
 
  • Like
Reactions: jeannotte

pwsincd

Garage Flower
Developer
Joined
Dec 4, 2011
Messages
3,680
Trophies
1
Location
Manchester UK
XP
4,203
haxchi code

int status = private_data->FSGetMountSource(pClient, pCmd, 0, tempPath, -1);
if (status != 0) {
private_data->OSFatal("-3");
}
status = private_data->FSMount(pClient, pCmd, tempPath, mountPath, FS_MAX_MOUNTPATH_SIZE, -1);
if(status != 0) {
private_data->OSFatal("-4");
}

status = private_data->FSOpenFile(pClient, pCmd, filepath, "r", &iFd, -1);
if(status != 0) {
private_data->OSFatal("-5");
}

-3 would suggest SD card problem
 
  • Like
Reactions: jeannotte
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: +1