GBAExploader freezes? A possible fix

Discussion in 'GBA - Flashing Hardware and Software' started by Movi, Feb 8, 2009.

  1. Movi
    OP

    Movi Advanced Member

    Newcomer
    2
    Aug 16, 2007
    Poland
    Ok, so i have a combo of EZ 3-in-1 Expansion pack and a R4. I was using rudolfs old 3-in-1 expansion tool, it worked admirably well, no problems. Then Exploader started beeing worked on, the 3-in-1 tool beeing abandoned. I tried Exploader and it didn't work. I thought back then that this is because it was beta-quality or something, so i kept using 3-in-1 tool.

    Today i decided to give my DS a "fresh start", cleaning out my SD card and so on. This time ive set myself on getting exploader to work, since Moonshell 2 is using it, and with it i don't need to patch those big gba games.

    Well, i got the newest one, and it froze the moment it was supposed to soft-reset. I tried moving the folders, modifying ini files, getting new clean roms and so on. Nothing got it to work. Then i had an idea. I went to WINDOWS box, and formatted my card to fat16. And lo and behold, it worked!. Now i tried fat32 under windows, and it worked too. See, i use a Mac, with Leopard. And i knew that both Linux and OSX have a little different implementation of vfat.

    So, if youre not using windows and Exploader won't work but the 3-in-1 tool does, format your SD card under windows (tried XP, dont know about Vista or 7, but they shouldn't differ).

    Hope this helps somebody.
     
  2. unknownworlder

    unknownworlder GBAtemp Regular

    Member
    1
    Dec 25, 2008
    United States
    Very helpful. Thanks! I just wonder if it works the same way in Linux.
     
Loading...