Firmware status

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Nah3DS, Jan 24, 2018.

  1. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    There is nothing in the pipeline for 8.x on patched systems. It might never be hacked, and if it is hacked, it'll probably be years. If you want to hack your system, sell it and get an unpatched one.
     
  2. Ranford

    Ranford Member

    Newcomer
    1
    Mar 30, 2017
    Russia
    It's very very bad news :(
     
  3. toxic9

    toxic9 GBAtemp Advanced Fan

    Member
    4
    Dec 13, 2016
    If RCM exploit wasn't a hardware bug, and it was patched on the early years, I'm certain everyone was trying to discover an entrypoint.
    Now that RCM is the most common thing, no one cares about the rest...
     
    Last edited by toxic9, Jul 8, 2019
  4. x124

    x124 Member

    Newcomer
    2
    Mar 22, 2019
    United States
    No.
    And even if 8.1 is hacked, you'll be on 15.x anyway
     
  5. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    People care, but you're right that it's not a priority. However, it should be noted that Nintendo did a really good job with security this time around. It should also be noted that 5.x-7.x will probably be hackable on patched systems in the distant future. If someone a.) willfully purchased a patched systems, and b.) willfully updated to 8.x or bought a patched system on 8.x, then the onus is entirely on the user, not the developers.

    We're very fortunate to have the RCM exploit on unpatched systems, we're very fortunate to have the warmboot browser exploit on 4.1 (and eventually 5.x-7.x), and people have been screaming from the mountaintops for years about what to do and not do.
     
  6. Ranford

    Ranford Member

    Newcomer
    1
    Mar 30, 2017
    Russia
    Why?
     
  7. Hayato213

    Hayato213 GBAtemp Guru

    Member
    11
    Dec 26, 2015
    United States
    No
     
    Lacius likes this.
  8. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Because by the time an exploit is released for firmware 8.X on patched units, the Switch will most likely be at the end of its life cycle and Nintendo will have moved onto the next console.
     
    Lacius likes this.
  9. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Maniac

    Member
    8
    Jun 19, 2018
    United States
    Hell
    We'll probably have usable pk1ldrhax before patched systems on 8x+ are hacked kek
     
  10. Clockdryve

    Clockdryve Advanced Member

    Newcomer
    2
    Mar 10, 2019
    United States
    What is the hold up with releasing Deja Vu? It has already been snitched off to Sony - It's been patched in Firmware 8.0 anyway..... Needs to be released so those that can use it "can use it" ????
     
  11. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    It's not compatible with anything above 4.1.0 at the moment. While it should be able to be made to work with 5.x-7.x, the work hasn't been done yet.

    In the meantime, unpatched Switch systems are hackable using the RCM exploit, and patched systems are hackable on 4.1.0 (without the supernag).
     
    Last edited by Lacius, Jul 11, 2019
    Draxzelex likes this.
  12. Mrtattootoyou

    Mrtattootoyou Newbie

    Newcomer
    1
    Jul 14, 2019
    United Kingdom
    What if I'm on 8.1.0 and my consoles not patched what's the best route for me?
     
  13. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    1. Get a jig (a paperclip bent properly works nicely).
    2. Make a backup of your NAND in Hekate before doing anything else.
    3. Use Atmosphere as your CFW.
    4. Optional: setup an emuNAND for your offline hackery if you want to use your clean sysNAND for online play.
    5. Optional: install AutoRCM so you don't need to use your jig anymore.
     
    Mrtattootoyou likes this.
  14. Ranford

    Ranford Member

    Newcomer
    1
    Mar 30, 2017
    Russia
    emuNAND supported in Atmosphere? I thought only in OS SX.
     
  15. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    Atmosphere added support for emuNAND approximately a month ago.
     
    Ranford and Draxzelex like this.
  16. Rahkeesh

    Rahkeesh GBAtemp Advanced Fan

    Member
    6
    Apr 3, 2018
    United States
    Technically they call it emuMMC, there's supposed to be some difference but I wouldn't know, its more or less the same concept as emuNAND, just keep that name in mind if you have to search.
     
  17. Clockdryve

    Clockdryve Advanced Member

    Newcomer
    2
    Mar 10, 2019
    United States
    I don't see any reason for it to not be released then.... Since only 4.1.0 and "maybe up to 7.XX - so it's old news for Nintendo and out of reach for many. I'm on 6.2.0 (need to update) but running AutoRCM with no-fuse burn with 4.1.0 (waiting) in downgrade reachable form. I purchased my Switch (new stock with good serial) just to put CFW on in 5 0r 6 months ago more or less. She's a Dock Queen (little to no use) pretty much to say.
     
  18. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    It's not done. That's why.

    What are you waiting for? The warmboot browser exploit is probably the best 4.1.0 is ever going to get.
     
  19. Zak_K

    Zak_K Newbie

    Newcomer
    1
    Jul 18, 2019
    United Kingdom
    Hi all. New to the forum.

    Where can I find a video or a text walkthough to install cfw on a patched switch with a fw of 4.1 and under?

    Thanks.
     
  20. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    https://switch.homebrew.guide/
     
Loading...