EZ4_client.exe crashes at startup

Discussion in 'EZ-Flash' started by HumbertHumbert, Jun 5, 2008.

Jun 5, 2008
  1. HumbertHumbert
    OP

    Newcomer HumbertHumbert Member

    Joined:
    Jun 5, 2008
    Messages:
    21
    Country:
    United States
    Hi there,

    I just got an EZIV and am really excited, but I can't get the client software to work. The first time I ran the software, I got to the language selection prompt. I chose English, and it promptly crashed. Now, every time I run ez4_client.exe, it crashes immediately with the error "EZ4_ClientC6 MFC Application has encountered a problem and needs to close. We are sorry for the inconvenience."

    I've downloaded many versions of the client and they all have the same error. I've tried running the client in compatibility mode too, but no dice.

    I saw this topic, which seemed like my problem: http://gbatemp.net/index.php?showtopic=86523

    However, that person fixed it by running an sfc /scanall and virus check. I did both of those things and the problem still exists. Can anyone help, please? I would really like to be able to use my EZIV... [​IMG]
     
  2. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,713
    Country:
    United Kingdom
    Two main causes of the crashes are bad rom lists or language files or there not being a drive where it expects.

    c:\windows\temp\ EZ4para.ini is the location of an ini file which you can delete (no idea why the EZTeam buried it in there) or you can map a drive (I tend to just use daemon tools).

    Newest client pack I made that I know works:
    http://www.4shared.com/file/38644523/edd5e...rified=82bd34ea
    Newest patch (just replace the old one)
    http://www.4shared.com/file/45909041/cee44...rified=82bd34ea
     
  3. HumbertHumbert
    OP

    Newcomer HumbertHumbert Member

    Joined:
    Jun 5, 2008
    Messages:
    21
    Country:
    United States
    Thanks for replying. I did try these before, but just in case I re-downloaded them from your links (unzipped the client, replaced the patch DLL file) and deleted the INI file from the Windows\temp\ directory. I also re-downloaded the romlist with updateEZ4.exe.

    When I ran ez4_client.exe, it prompted me for the language again, but it crashed after that, just like before.

    ...Any other ideas? Is there any other software that I can use other than the EZ4 client?

    (If it matters, I'm on XP SP2, Core2Duo E6600)
     
  4. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,713
    Country:
    United Kingdom
    The romlist is likely the problem then as a bad list tends to cause the program to crash. Simple stuff like not having a return at the end of the list is the usual cause.

    My machine is the same as yours as far as what you said.
     
  5. DUM4S5

    Newcomer DUM4S5 Newbie

    Joined:
    May 7, 2009
    Messages:
    3
    Country:
    United Kingdom
    is there a fix to this yet?

    i've downloaded several versions of the ez4 client but am yet to find one that works =[
     

Share This Page