1. WiLLiW

    WiLLiW Member
    Newcomer

    Joined:
    May 2, 2020
    Messages:
    30
    Country:
    Brazil
    Keep it up with the good work!
     
  2. EZ-Flash2

    OP EZ-Flash2 Official EZ-FLASH Stuff
    Member

    Joined:
    Jul 16, 2003
    Messages:
    508
    Country:
    China
    fixed Keitai Denjuu issues
    fixed pokemon series time jump(need more users report) , I recommend create a new save with new firmware and kernel, do not use the older one.

    Never use fw5 created sav file on fw4, definitely error time.
    know issue: Prism still has time jump, need Prism's developer investigate(we'd sent sample to them)
     

    Attached Files:

    Last edited by EZ-Flash2, Jul 10, 2020
    Shadow#1 likes this.
  3. aaaaaa123456789

    Newcomer

    Joined:
    Apr 16, 2020
    Messages:
    11
    Country:
    Argentina
    We're working on it. We've been trying to find some RTC test ROMs to check if the issue is in our side or yours, but apparently nobody has written a test ROM yet. So I guess we'll have to do that.
     
    RetroKarl, Shikaki, WiLLiW and 2 others like this.
  4. EZ-Flash2

    OP EZ-Flash2 Official EZ-FLASH Stuff
    Member

    Joined:
    Jul 16, 2003
    Messages:
    508
    Country:
    China
    It's really a good news. A reliable RTC test ROM is also what we need.
     
  5. WiLLiW

    WiLLiW Member
    Newcomer

    Joined:
    May 2, 2020
    Messages:
    30
    Country:
    Brazil
    A new beta release and probably a new test rom! yaaay!
     
  6. limpbiz411

    limpbiz411 GBAtemp Fan
    Member

    Joined:
    Oct 12, 2007
    Messages:
    319
    Country:
    United States
    thank you, but i am still having issues with time. while i am playing it doesn't skip, after i save and come back it goes 5 minutes back every time.
     
  7. zackabee

    zackabee Newbie
    Newcomer

    Joined:
    Jul 10, 2020
    Messages:
    4
    Country:
    United States
    My vanilla Crystal doesn't hold time at all now. Every time I return to the continue screen it asks me to set the time again.
     
  8. EZ-Flash2

    OP EZ-Flash2 Official EZ-FLASH Stuff
    Member

    Joined:
    Jul 16, 2003
    Messages:
    508
    Country:
    China
    Which game?
    Did you create the new save with new firmware and kernel?
     
  9. limpbiz411

    limpbiz411 GBAtemp Fan
    Member

    Joined:
    Oct 12, 2007
    Messages:
    319
    Country:
    United States
    pokemon crystal usa version
     
  10. EZ-Flash2

    OP EZ-Flash2 Official EZ-FLASH Stuff
    Member

    Joined:
    Jul 16, 2003
    Messages:
    508
    Country:
    China
    did you create the new game save from scratch?

    what method between each boot, reset button or power off?
     
  11. RetroKarl

    RetroKarl Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    41
    Country:
    Mexico
    Hi, I just tested the new test firmware in a couple of the weird cards that I have and I got this:

    MicroSD's just formated (FAT32 32Kb Cluster), New Firmware, New Kernel, Clean Games, All New Saves.

    Card #1
    Pokemon Silver (Spanish)
    Test time 23:30-00:15 hrs
    (Tested with reset button & Switch Off-On)
    -RTC in the EZFJR Menu is Fine
    -RTC in the game loading (first save) 50/50 Correct time/ Ask to set time
    -RTC in the game loading (after several saves) Correct time/ Ask to set time/Wrong time
    *If you reboot several times with the reset button (without saving) you will eventually get the correct time-date.
    *After more test I get that loading the game while the RTC of the EZFJR is from XX:XX:30 to XX:XX:45 seconds, I was always getting the correct time/date loading the game, even after several saves. ( about XX:XX:00 to XX:XX:29 wrong time-date, about XX:XX:46 to XX:XX:59 ask to set time-date)
    *After several hours from my first test, the card was no longer getting the right time-date, even loading under previous circumstances.
    -Sometimes I start to get corrupted Bios logo (never present on FW4 K1.04e) like the previous FW5 K1.05, gets fixed by powering off the system.

    Card #2
    Pokemon Silver (USA)
    Test time 22:00-23:10 hrs
    (Tested with reset button & Switch Off-On)
    -RTC in the EZFJR Menu is Fine (but it continues with the weird behaviour of switching some of the numbers for like a tenth of a second and then getting back to normal)
    -RTC in the game loading (first save) 8 out of 10 times is stuck in the date-time of the first save
    -RTC in the game loading (after several saves) continues the same, or gets back like 5 minutes or so, but starts to get the correct time, but the day of the week keeps changing all the way around.
    *If you reboot several times with the reset button (without saving) you can get the correct time-date, but it is very difficult.
    -Sometimes I start to get corrupted Bios logo (never present on FW4 K1.04e) like the previous FW5 K1.05, gets fixed by powering off the system.

    Final Notes:
    -In both cards once I get in to the game with the correct time-date, time-date always runs just Perfect.
    -Even after all the reboots, the RTC from both cards NEVER got resetted (to 2000/00/00 00:00:00) by itself like the previous FW5 K1.05.

    I will continue with the test, and thanks @EZ-Flash2 for the hard work mate. Cheers
     
    Last edited by RetroKarl, Jul 11, 2020
    EZ-Flash2 likes this.
  12. EZ-Flash2

    OP EZ-Flash2 Official EZ-FLASH Stuff
    Member

    Joined:
    Jul 16, 2003
    Messages:
    508
    Country:
    China
    Thank to your test report.
     
  13. zackabee

    zackabee Newbie
    Newcomer

    Joined:
    Jul 10, 2020
    Messages:
    4
    Country:
    United States
    Yes, brand new save created on the cartridge with a new, clean game file after updating the kernel and fw. I'm experiencing the same issues RetroKarl details in his post. I've tried Gold and Silver as well, same issues. Thanks for being diligent with your replies and continued work on fixing this issue. I'm really enjoying the EZ-Flash JR otherwise, and would love to see it get even better.

    Thanks for the detailed information on the testing you've done, you're going a long way in helping this bug get squashed. Great props to you. Though I'm curious, when you say that after you get into the game with the correct time-date, do you mean that the time-date works as normal even after powering off? Or do you simply mean that once the game is running that the clock progresses as normal until powering off?

    Cheers
     
    Last edited by zackabee, Jul 11, 2020
  14. Toivogamer

    Toivogamer Member
    Newcomer

    Joined:
    May 14, 2020
    Messages:
    18
    Country:
    Finland
    Pokemon prism jumps about 30 seconds now.
     
  15. limpbiz411

    limpbiz411 GBAtemp Fan
    Member

    Joined:
    Oct 12, 2007
    Messages:
    319
    Country:
    United States
    i used a clean save, and turned it off then turned it back on.
     
  16. Toivogamer

    Toivogamer Member
    Newcomer

    Joined:
    May 14, 2020
    Messages:
    18
    Country:
    Finland
    i backed up the save and created new save and its still there.
     
  17. RetroKarl

    RetroKarl Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    41
    Country:
    Mexico
    Hi @zackabee , I mean the second statement, that once the game is running the clock progresses as normal until powering off. Cheers.
     
  18. bbsan2k

    bbsan2k Member
    Newcomer

    Joined:
    Jul 6, 2019
    Messages:
    42
    Country:
    Germany
    @EZ-Flash2 will you Open Source the Kernel once it is stable (like with omega) or will it stay completely closed source?
     
    wiewiec likes this.
  19. RetroKarl

    RetroKarl Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    41
    Country:
    Mexico
    Hi @EZ-Flash2, I just tested Pokemon Gold (Spanish) & Gold (USA) and this are the results:

    MicroSD's just formated (FAT32 32Kb Cluster), New Firmware, New Kernel, Clean Games, All New Saves.

    Pokemon Gold (USA)
    Test time 13:00-14:50 hrs
    (Tested with reset button & Switch Off-On)
    -RTC in the EZFJR Menu is Fine (but it continues with the weird behaviour of switching some of the numbers for like a tenth of a second and then getting back to normal)
    -RTC in the game loading (first save) 50/50 Correct time/ Ask to set time (depends on the seconds of loading the game that I explain below)
    -RTC in the game loading (after several saves) Correct time/ Ask to set time
    *If you reboot several times with the reset button (without saving) you will eventually get the correct time-date.
    *After more test I get that loading the game while the RTC of the EZFJR is from XX:XX:55 to XX:XX:10 seconds, I was always getting the correct time/date loading the game , even after several saves. ( about XX:XX:15 to XX:XX:50 ask to set time-date)
    -Sometimes I start to get corrupted Bios logo (never present on FW4 K1.04e) like the previous FW5 K1.05, gets fixed by powering off the system.

    Pokemon Gold (Spanish)
    Test time 13:00-14:50 hrs
    (Tested with reset button & Switch Off-On)
    -RTC in the EZFJR Menu is Fine (but it continues with the weird behaviour of switching some of the numbers for like a tenth of a second and then getting back to normal)
    -RTC in the game loading (first save) wrong time-date always
    -RTC in the game loading (after several saves) Wrong time
    *Even if I try to reboot several times with the reset button (without saving) I never got the right time-date.
    *Never got the correct time-date, so I decided to delete the save and start again, and to my surprise, the game started working just like Gold (USA), If I load the game while the RTC of the EZFJR is from XX:XX:55 to XX:XX:10 seconds, I was always getting the correct time/date loading the game.
    -Sometimes I start to get corrupted Bios logo (never present on FW4 K1.04e) like the previous FW5 K1.05, gets fixed by powering off the system.

    Final Notes:
    -It seems that the time in the RTC when you make the first save, or the time in the RTC when a save is created (by the first loading of the game) in the temporary memory of the EZFJR before you dump it is deciding this behavior of "From XX:XX:55 to XX:XX:10 is loading fine, XX:XX:15 to XX:XX:50 ask to set time-date". Because previously, in the Pokemon Silver (Spanish) it was loading correctly from XX:XX:30 to XX:XX:45 instead.

    I will continue with this test with Gold (Spanish & USA) to see if I can get it working fine (with the trick of the loading timing) after several hours. Thanks @EZ-Flash2 for the hard work mate. Cheers

    UPDATE: Now, about 7 hours away from the last save of both games (Gold USA & Spanish), I can't get them to load with the correct Time-Date. In the loading screen they are stuck in the correct day of the week, but the time is 2:23 Day & 2:39 Day, wich are maybe the last time I save each one for the last time. I get this Times, or I get asked to set the time-date again. I will continue the test with Crystal I think.

    New behaviour: After some reboots sometimes I get stuck on the boot screen "loading..." of the EZFJR menu, It gets solved by Power Off-On.
     
    Last edited by RetroKarl, Jul 12, 2020
  20. kerobscure

    kerobscure Advanced Member
    Newcomer

    Joined:
    Oct 28, 2015
    Messages:
    64
    Country:
    Hi! There's the guy with the Quarz Crystal broken, with the latest stable firmware keeps me with the last date saved, which was more comfortable coexisting with my factory error, but with this testflight the date always returns me to 2000/01/01 00:00 and it is very tedious to have to set the date from the start, I prefer to keep the date it had when the console was turned off
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - TestFlight, Junior, FLASH