EZ Flash 3in1+ Nor issues and NDS backup

Discussion in 'EZ-Flash' started by TheDrifter363, Feb 11, 2013.

Feb 11, 2013
  1. TheDrifter363
    OP

    Newcomer TheDrifter363 Newbie

    Joined:
    Feb 11, 2013
    Messages:
    2
    Country:
    United States
    Hello everyone, I have some quick questions hopefully someone will be able to help me out. Recently I purchased an EZ Flash 3in1+ from www.realhotstuff.com and it's a pretty nice piece of work. However, some issues. I have kingdom hearts: chain of memories. Since this is one of the 32 MB games, it has to flash to NOR. I can click on the game from the AKAIO menu (btw 1.9.0 firmware), and it erases and writes the game to NOR. However immediately afterwards the game boy logo appears with no nintendo logo: the game is frozen. I restart and this time click on the slot 2 gba game at the beginning of the acekard screen. This time the nintendo and game boy logos appear however I hear some strange distortions and the game freezes. :-( Finally I play it through the actual NDS menu and it works! Great!......except I would've preferred playing it through AKAIO, it's more convenient. :-D Not only this, but unlike my other gba games which ask me to backup my save every time I restart the DS Lite, this time it doesn't ask me. Most likely because I'm playing through the NDS menu. So how can I save or update my save then? I eventually plan on playing Mother 3, so looks like these 2 games may be troublesome. Any suggestions? Is there anything I can do to play these 2 games through AKAIO?

    Now then, on another note; another neat function of this device is the ability to backup my DS games. I know I can back them up through wifi but I tried that roughly a year ago and it didn't work out. Not too reliable. So this is a much quicker and cleaner method.......or so I thought. One, games larger than 32 MB will have to be dumped by restarting the DS in a sequence and reinserting both the acekard 2i and the game to be dumped in a specific sequence. This can get cumbersome, anyway around this? Also, the main issue, when I dump my games I like to verify their sha1sum check by comparing them to the no intro set. Since this is a set that is verified to be clean roms, it gives me a good indicator if my games are dumped correctly. However, I've been having an issue with Mario and Luigi: Partners in time. It dumps correctly and is playable; however, its sha1sum does not match the no intro set. This cannot be, unless it was dumped correctly or is a fake. I doubt its the latter since I did buy this game new from what I can remember so it must be that it wasn't dumped correctly. I've attempted to dump it twice and both times the sha1sum did not match. It is a 64 MB game, other games I have that are this size are the 2 castlevanias for the DS: Dawn of Sorrow and Portrait of Ruin. These two games were verified and passed the no intro set. Any suggestions on what's going on with the dumping process? I'm using the NDS Dumper 3in1+ 0.31a.

    Lastly, on the topic of dumping, I know some DS games are 256 MB and larger, to dump these games I would have to reinsert both the flashcart and the game 8 times. This can take roughly 2 and a half hours to complete, I know I roughly timed it. Any way around this. What about all that talk about 64 mb of NOR for plus edition. Is it useless? Do they still sell the previous hardware versions?

    Well that's about all my questions. Thanks in advance for any help anyway can provide. :-D

    PS: I should've mentioned this earlier but I have an acekard 2i with 1.9.0 AKAIO firmware. Also the ez flash pcb is EZ5C3 and the sram battery is at a healthy 3.2-3 V.
     
  2. how_do_i_do_that

    Member how_do_i_do_that Blue Wizard is about to die.

    Joined:
    May 16, 2008
    Messages:
    4,803
    Country:
    Antarctica
    Answers are color coded to the quote.

    Nope.
    Games dumped by some in the scence are in most cases are blind dumps with padding to a rom. sha1sum does not see a file that was trimmed and untrimmed as the same file when you check it. Does it really matter if it is not the same as long as it works?
    Other causes of this are that you are dumping a version 1.1 of the game when your comparing it to a 1.0 version of the game, which can give you a different sum.


    The dumper your using is a hacked version to support the 3in1+. The way it was hacked was to add the NOR information by replacing one of the other NOR defined in the program, nothing else was changed. The 32MB is a fixed size that the NDS and GBA can see and address upto, a loader on the gba flashcart is required for you to be able to access all 64MB, the 3in1 (all versions) are basically loaderless.

    The 64MB of NOR is only good for those that use a slot1 EZ-Flash V/i/plus with a certain firmware or lower can use. Everyone else with a different slot1 is limited to 32MB.



    As for the first part, either it is a dirty rom or try with the AK2i not in the slot.
     
  3. Leader2light

    Newcomer Leader2light Newbie

    Joined:
    Feb 16, 2013
    Messages:
    4
    Country:
    United States
    I have the exact same setup and even bought from same seller. I also have the same issue.

    Playing without a Slot 1 card is the only fix i have found. Same as you.

    Also this happens with any 32MB game not just kingdom hearts .

    I have tested with GBAexploader and have same problem. WTF

    I would love to find a fix!!!!!


    I am wondering if older firmwares worked fine? 1.9.0 firmware is the only firmware i have ever used.
     

Share This Page