Question Emunand 7.0.1 not working with sx 2.6.1

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by ProtoxiDe22, Apr 8, 2019.

  1. ProtoxiDe22
    OP

    ProtoxiDe22 Newbie

    Newcomer
    1
    Apr 8, 2019
    France
    Hello, i have a switch with sxos and ofw 4.0.1, long story short, i triggered an update flag on 6.2 emunand, and decided to install 7.0.1 on sx 2.6.1 (i'm on hidden partition emunand)
    So i did the standard procedure of downloading the fw, and tried to install it via ChoiDujourNX, first time i selected exfat install and left the autorcm thing on.
    when i reeboted the switch i didn't get anything past the sxos Splashcreen, so what i did was completely wipe off my sd card and start over, i recreated hidden emunand on 4.0.1 which is working just fine, and then tried updating to 7.0.1 again, however, this time i got adviced to update in non exfat mode, and disable the autorcm mode in choidujour, since i was told that could cause problems since i'm updating emunand.
    After updating, i rebooted the switch and nothing has changed, after the sx os logo, nothing appears on screen, not even a battery logo.
    the original nand is on 4.0.1 and still works properly if i boot ofw
    What am i doing wrong? can't seem to make this emunand work properly
     
  2. paulzheng

    paulzheng GBAtemp Regular

    Member
    2
    Dec 10, 2013
    China
    is it emunand crashed?
    lots of sxos user maintain real system such as 4.1or 5.1 lower version. and always update to latest ver. by choidujournx in offline mode.
    everything is okay after upgrade emunand.

    so i think maybe the problem is from microsd card.
     
  3. Switch_Maniac

    Switch_Maniac Advanced Member

    Newcomer
    2
    Dec 16, 2018
    United States
    I believe there is an issue with hidden partition on 2.6.1/FW7.0.1. I think you can mount the hidden partition with hackdiskmount and convert it to SD Files version or of course just back your saves up, wipe the SD and reinstall your games on SD Files.
     
  4. SaggyBeans

    SaggyBeans GBAtemp Regular

    Member
    3
    Jul 8, 2014
    Canada
    I had a similar issue, did you happen to download the 2.6.1 beta off of a sx os mirror site? One of the mirror sites that says "2.6.1" is actually "2.5.3" thus not allowing you to load 7.0.1 and end up on a black screen. Try to get the 2.6.1 beta from the alternate mirror site and it should work. This fixed the issue for me. Only way I noticed is when I was on 6.2 firmware prior to upgrading to 7.0.1 I noticed the sx splash screen still said 2.5.3 despite me putting the 2.6.1 beta boot file on my SD, at the time I thought it was just a mistake on TX's part but it turned out the 2.6.1 download was actually packaged with the 2.5.3 boot file. I'm sure other people will run into this issue as well.
     
    Sumandora likes this.
  5. larrypretty

    larrypretty GBAtemp Fan

    Member
    3
    Oct 18, 2018
    United States
    I get this trouble too.
     
  6. kurodax

    kurodax GBAtemp Regular

    Member
    2
    May 29, 2015
    i have the same issue, i tried to install emunand today, but cfw only run when emunand disable. The problems is the update. What i did is update is on ofw, THEN you need to make the Emunand again. Because Emunand is a exact copy of your ofw, so you need to emunand also have to have the update of the sd card too. Take me the whole day but it's working now.
     
    Last edited by kurodax, Apr 9, 2019
  7. JJTapia19

    JJTapia19 I fight for my friends.

    Member
    9
    May 31, 2015
    Puerto Rico
    After the sx boot screen wait a couple of seconds on the black screen and try pressing the power button once. Many users reported this workaround on their forums.if nothing works re create with emunand the files on sd option. Then update to 7.0.1 with exfat.
     
    van0 and Creszent like this.
  8. Creszent

    Creszent Newbie

    Newcomer
    1
    Feb 24, 2019
    Philippines
    You were right. Thanks to you. it took me almost 6 hour to figure this out and yes it was not booting automatically. Tested both on my exfat sd one with hidden and others with none (4x each).
     
    JJTapia19 likes this.
  9. alexantao

    alexantao Newbie

    Newcomer
    1
    Apr 15, 2019
    Brazil
    Hi, I have the same issue, but my console is already on 7.0.1, the previous owner updated it and it was never uninstalled any CFW.
    When I turn it on, I can see the Nintendo logo and after that I get a black screen. If I boot SXOS with menu, I also cannot boot OFW.
    Emunand is enabled and on SD partition. Using SXOS 2.6.1. No AutoRCM.
    I can only boot original if I boot normally.
     
  10. matias3ds

    matias3ds GBAtemp Maniac

    Member
    8
    Oct 25, 2017
    Argentina
    Emunand is enabled and on SD partition i am on latest software i could run emunand the first time , but when i turn of my switch and turn it back on i have , the BOOT.DAT ? message .
    does somebody knows about this error , i created the emunnad fresh with the latest 7.0.1 firmware and after restart , keep asking for the boot.dat file , and the file is on the micro sd card i can see it on the pc
     
  11. gizmomelb

    gizmomelb GBAtemp Advanced Fan

    Member
    6
    Jul 13, 2006
    Australia
    hi all,

    I literally just updated my SD card and created emuNAND with SX OS 2.6.1 and updated the emuNAND to 7.0.1 a few hours ago, so hope this helps someone.


    my OFW is 3.0.2 (exfat - couldn't detect the SD card otherwise), 400GB SD card and I've created SX OS v2.6.1 beta emuNAND as files (fat32 formatted partition).

    what I'd really like to do though is be able to convert my hidden partition emuNAND (6.2.0) from my other SD card to files, then just move them to the bigger SD card. Much less work moving save games, profiles etc.etc.


    Starting the nothing, I formatted the SD card as FAT32, then copied the SX OS v2.6.1 "boot.dat" and "payload.bin" to the SD Card.

    Then I booted into the SX OS launcher with a generic dongle and RCM jog (could use tegrasmash) and SX OS launcher created the licence-request.dat file.

    I then powered off the switch, ejected the SD card, put the SD card in the PC and uploaded the licence-request.dat file to the sx.executor.rocks (but the main site is now back online) registration page, entered my licence number and it then prompted me to download a licence.dat file.

    I copied the licence.dat file to the SD card, put the SD back in the Switch and booted into the SX OS launcher again. only AFTER I had the licence.dat file on the SD Card was I able to create the emuNAND as files on the SD card (do not create as hidden partition as it appears some people have the cannot boot issue).

    Once the files were created I had to reboot the Switch, then went back into the SX OS launcher and then it allowed me to enable emuNAND. Once I'd tested I could boot into emuNAND I decided to make a copy of the emuNAND files to my PC, just in case I needed to restore them in future (they zipped down pretty small, cannot recall file size at moment sorry).

    When I was booted using the emuNAND I used choidujourNX to install firmware 7.0.1 and followed all the instructions, then it prompted me to reboot when it had finished.

    I used my generic USB dongle and jig again to boot into the SX OS launcher and into the emuNAND succesfully.


    So yes, I can confirm I now have SX OS 2.6.1 with emuNAND as SD files on a FAT32 formatted 400GB SD card, with 7.0.1 running in emuNAND and 3.0.2 in sysNAND.

    A tip I like to give with emuNAND is change the background theme colour - so it's obvious at a glance if you're in emuNAND or sysNAND.

    Cheers.
     
    Last edited by gizmomelb, Apr 15, 2019
    BATMAN-, icewarp and Switch_Maniac like this.
  12. matias3ds

    matias3ds GBAtemp Maniac

    Member
    8
    Oct 25, 2017
    Argentina
    Thanks that's very usefull , one question should I install checkpoint and others before I create Emunand or after ?
     
  13. gizmomelb

    gizmomelb GBAtemp Advanced Fan

    Member
    6
    Jul 13, 2006
    Australia
    you'd have to install checkpoint / edizon before (unless you have a second SD card, like what I was upgrading for / to) and backup your saves etc.

    then if you're using the same SD card go through all the steps and create the emuNAND, then restore your saves.. only thing is I haven't found out how to copy profiles between CFW as yet.
     
  14. matias3ds

    matias3ds GBAtemp Maniac

    Member
    8
    Oct 25, 2017
    Argentina
    Actually I'm doing this in a new switch I have no saves . So I guess I can first use the install All program that is posted in gbatemp and let you install all the hombrews at once , and after that I would create de Emunand in a non hidden partion
     
  15. RedHunter

    RedHunter GBAtemp Fan

    Member
    5
    Dec 12, 2014
    Italy
    Have a similar issue. I had my sysnand at 7.0.1 and emunand at the lower 6.2. I decided to update emunand to 7.0.1 too but now it doesn't work with autorcm on, it gives me black screen, I can only boot Sysnand or SX OS without emunand, or I have to remove autorcm but I don't want to use a paper clip everytime.
    Tried doing emunand again but no luck.

    Someone here has 7.0.1 on both nands and autorcm on?
     
    matias3ds likes this.
  16. matias3ds

    matias3ds GBAtemp Maniac

    Member
    8
    Oct 25, 2017
    Argentina
    Like to know that as well
     
  17. RedHunter

    RedHunter GBAtemp Fan

    Member
    5
    Dec 12, 2014
    Italy
    Also tried hekate autorcm option. Also resetting the Switch but nothing. Now I'm putting all my stuff back again :/
    At least now I know I'm not the only one with this issue. Maybe SX is not really fully compatible with 7.0.1 yet.
     
    matias3ds likes this.
  18. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    No, that's not how it works. You can have sysNAND and emuNAND on different versions, they're completely separate.
     
  19. gizmomelb

    gizmomelb GBAtemp Advanced Fan

    Member
    6
    Jul 13, 2006
    Australia
    works for me with RCM off (never been a fan as it is detectable of a hacked switch and RUMOUR is with OFW 8.x it detects RCM'd consoles and they won't boot), my switch is on standby most of the time so I have no need to completely power it off. I carry the USB dongle and jig in my switch carry case in case I ever need to do a full reboot (like I have been with the recent upgrade to a different SD card and then trialling upgrading to 7.0.1)
     
    Last edited by gizmomelb, Apr 15, 2019
  20. matias3ds

    matias3ds GBAtemp Maniac

    Member
    8
    Oct 25, 2017
    Argentina
    So with Emunand you can't enable autorcm ??
     
Loading...