1. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    Reread the 0.4 update changes. You need goldleaf.
     
  2. tatundria

    tatundria GBAtemp Fan
    Member

    Joined:
    Feb 24, 2009
    Messages:
    355
    Country:
    Argentina
    I have goldleaf. That is how I turned on emuiibo emulation in the first place. Do I have to install it as an application in the home menu also?
     
  3. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    no.. how else would you be able to hot swap amiibos if you're closing the program that you're triyng to use it on?

    All you do is select the amiibo in amiibo management and it'll be the selected amiibo.

    There is a way to re add the key combo (as mentioned in the 0.4 changelogs) but it current crashes the system.

    — Posts automatically merged - Please don't double post! —

    Once you have 50ish or more amiibos in your amiibo folder goldleaf lags. Once you hit 50+ it stalls. (Probably because of the images.)
     
  4. oBluEx

    oBluEx Advanced Member
    Newcomer

    Joined:
    Jan 1, 2013
    Messages:
    64
    Country:
    United States
    Please help me, I will provide as much detail as possible. I know I have everything set right. Nothings happening. I know I must be missing something small. But it's not working in the game BOTW (Only one I have tried).

    Emuiibo v0.4
    Switch Firmware: 8.0.1
    CFW: Atmosphere - AMS 0.8.8
    No Other SysMods.
    Using Joycons
    Combo Buttons ENABLED

    I downloaded Emuiibo V0.4 Zip and Emutool V0.4 Zip.
    Under Emuiibo-v0.4 Zip, I extracted 0100000000000352 Folder into SD:/Atmosphere/titles

    That Zip file is now no longer needed, everything is in place. The 0100000000000352 folder I placed had the exefs.nsp along with the flags folder which contained the boot2.flag file.

    I extract Emutool-v0.4 into it's own folder. I open it up. I choose Legend of Zelda > Ocarina of Time Link Amiibo > Name is (linkoot) > I leave the box UNCHECKED for UUID.

    I generate the Amiibo. Now I have the generated folder that contains all 4 of the .json files. Under my SD Root I create the folder emuiibo, then create a folder inside emuiibo called, amiibo. Within amiibo I place the folder that I generated (From Emutool) called (linkoot) inside the amiibo folder.

    So that structure looks like SD:/emuiibo/amiibo/linkoot/(4 .json files).

    Now everything is perfectly in place. If I press Right Stick and D-Pad up. Home Button Blinks. If I do it again, it blinks but stays a bit longer). I've tried to use the Amiibo rune in Zelda, it doesn't work. I've tried doing it before I start the game, before the rune is active, after, etc.

    I've explained everything so anyone can understand this. I have no errors or anything. Just nothing happens. I really hope I get a response, I've detailed just about everything I know I should.

    EDIT:: I decided to put Amiiswap onto my Homebrew. Activate HB through Album, go to Amiiswap. I'll connect to my Emuiibo which says it's connected to the folder "ootlink" (Which contains my .json files) which was generated from Emutool. "OOTLINK" was put inside my SD:/emuiibo/amiibo/

    Honestly no clue what I am missing. I've read every page on this Topic and people start mention .bin files. Which is no where under the tutorial or github. Only .bin mentioned is the mii-charinfo.bin, which says is generated here "sd:/emuiibo/miis/<index> - <name>/mii-charinfo.bin.". Which was not true at all, it generated inside my "ootlink" folder" where my .json files were.

    I feel stupid trying this honestly and have not felt this stupid figuring out simple drag/drop + easy interfaces since I was 10 in 2000 using GFAQS, P2P programs, AIM and GameMaker.

    What the fuck am I missing?
     
    Last edited by oBluEx, Jan 6, 2020
  5. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    @oBluEx try using goldleaf to select amiibos.
     
  6. oBluEx

    oBluEx Advanced Member
    Newcomer

    Joined:
    Jan 1, 2013
    Messages:
    64
    Country:
    United States
    @Jonhy I don't have the latest Goldleaf! It's missing an extra Emuiibo option. No wonder! I've only got the dump option!

    Really quick, people are mentioning bin files. EmuTool only creates .json. Do those .bin go into sd:/emuiibo or do I not need to worry about those? The github and OP do not state this.
     
  7. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    I mentioned bin files a bit earlier, yes. That is because emuiibo 0.1 through 0.2.1 supported bin files, but it seems like since then, bin files aren't supported any more. I've asked around, still havent found any info.
     
  8. leanderson2006

    leanderson2006 Advanced Member
    Newcomer

    Joined:
    Dec 19, 2012
    Messages:
    83
    Country:
    Brazil
    Did the Wolf Link work with 20 hearts?
     
  9. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    As mentioned in my previous post, it doesn't seem like emuiibo supports .bin files anymore. Even when it did emuiibo failed to send over the amiibos "save data" to games, unless it was was with the emuiibo. (Which is impossible because there is no emuiibo for WiiU.
     
    Last edited by JonJaded, Jan 7, 2020
  10. NinjaTurtle

    NinjaTurtle Banned
    Banned

    Joined:
    Jan 9, 2020
    Messages:
    20
    Country:
    United States
    Did you mean that you had to press R-Stick and D-pad up simultaneously, at the dashboard before you entered the game to get everything working? Is there a tutorial I can follow? I've tried everything, and only got one amiibo appearing.
     
    Last edited by NinjaTurtle, Jan 9, 2020
  11. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    Update to 0.4 and read the patch logs.
     
  12. NinjaTurtle

    NinjaTurtle Banned
    Banned

    Joined:
    Jan 9, 2020
    Messages:
    20
    Country:
    United States
    I did, it only worked half way. I enabled the amiibos in Goldleaf, started Fire Emblem 3 Houses and went to the Gazebo, while it was scanning for it I pressed R-Stick & D-pad and only 1 amiibo worked after a 20-30 second lag. The other 10 did not, so what am I doing wrong? Do I need to just wait???Do I press anything and THEN wait?
     
  13. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    Wait longer. FIre Emblem is just weird with detecting amiibos.
     
  14. KingKazmaOfficial

    Newcomer

    Joined:
    Oct 2, 2019
    Messages:
    12
    Country:
    United States
    Ok, so I'm having an issue where when I start up Breath of the Wild, it just loops the game loading screen eventually forcing me to shut off my system. The game loading screen doesn't freeze, it just loops the animation over and over. This only happens when I start of BotW, I've tested 5-6 other games and they start up just fine.

    Anyway, here is what I'm working with:
    OFW: 9.0.1
    CFW: AMS 0.9.4|S
    emuiibo version: 0.4
    Goldleaf: 0.8

    Yes, I am not using the most up to date build of Atmosphere (yet). I just haven't gotten around to updating it, but if I've read the info offered here correctly, that shouldn't matter. If anyone thinks otherwise, I'll be sure to update ASAP. Also of note, I am chainloading Atmosphere via Hekate, if that makes any difference.

    Now this is all I've done so far. I downloaded the latest version of emuiibo (I've done this both via the hb appstore and github with same result). I placed the the title folder in the appropriate location [sdmc:/atmosphere/titles/], and confirmed that boot2.flag was present in the 'flags' folder. I loaded some virtual amiibos via the emutool and placed them in the appropriate location [sdmc:/emuiibo/amiibo/*/]. Thinking I was good to go, I booted up and started BotW and got stuck at the game loading screen.

    That's where I am now. Not really sure how to proceed. Thanks for any help offered.

    EDIT 1:
    Small update. I've been working at it and I'm now able to see the home button flash when i do the command. I am able to see the amiibos that I have loaded on my SD card in Goldleaf's 'emuiibo management'. Also, using emuiibo management, I am able to confirm that the amiibo emulation state is active. I even installed amiigo to double check this for good measure, and for potential future use once I get it working.

    Whats happening now is when trying to "scan" an amiibo, the game freezes. Well to be more clear, it doesnt do anything and when i try to go back to the previous screen or press the home button then it freezes. This of course forces me to reboot. I tried this in SSBU and Mario Kart 8 with same results. I am still not able to start BotW past the game loading screen mentioned in original post.

    BotW not working is possibly the biggest source of confusion for me in this. Can't place my hand on why it wont start all the way up.

    Not sure if this helps but all of my games are .nsp/.nsz files.

    Hopefully I can get this resolved.

    EDIT 2:
    Finally got it to work after updating the OFW to 9.1.0 and CFW to 0.10.1. Moral of the story, always keep your stuff up to date if you wanna play with the latest tricks!
     
    Last edited by KingKazmaOfficial, Jan 15, 2020
  15. jewgleisabotnet

    Newcomer

    Joined:
    Jan 26, 2020
    Messages:
    3
    Country:
    United States
    I'm usually good at lurking and figuring out how to do something but for the life of me I can't figure out how to enable "randomizeUuid" in v0.4. I tried it in all of the .json files in emuiibo/amiibo/* as well as settings.json (which may or may not be the correct method, it crashes atmosphere though)
     
  16. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    It's in the emuiibo creator. The program where you actually make the amiibos. I'm not sure if it's possible to toggle it anymore.
     
    jewgleisabotnet likes this.
  17. jewgleisabotnet

    Newcomer

    Joined:
    Jan 26, 2020
    Messages:
    3
    Country:
    United States
    Thank you so much. To do this manually you just replace
    Code:
    {
      "uuid": "1DA679084E57683B9D"
    }
    with
    Code:
    {
      "randomUuid": true
    }
    in the tag.json file.
     
  18. Shadow Fyre

    Shadow Fyre Advanced Member
    Newcomer

    Joined:
    Nov 20, 2014
    Messages:
    99
    Country:
    United States
    So the combo keys are broken right now? If set to true in the settings it just crashes? If so, how can you swap amiibos in BOTW?
     
  19. JonJaded

    JonJaded GBAtemp Fan
    Member

    Joined:
    May 22, 2016
    Messages:
    474
    Country:
    United States
    Gold leaf, use the latest nsp, scroll down to amiibo.
     
  20. Xyphoseos

    Xyphoseos Hack or no games
    Member

    Joined:
    Jun 29, 2016
    Messages:
    1,748
    Country:
    France
    can anyone make a zip with all amiibo in emuiibo format please .?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - emulation, services, emuiibo