DSTT compatablity on N3DS [N00b]

Discussion in 'NDS - Flashcarts and Accessories' started by Ahote, Jul 23, 2016.

  1. Ahote
    OP

    Ahote Newbie

    Newcomer
    9
    1
    Jul 15, 2016
    United States
    I purchased a DSTT on nds-card.com and used DSTT V1.18 official kernel.

    N3DS is using luma3ds, but the card that pops up in the loader is a blank ds cartridge icon. When I boot it, it give me a message saying that the device has an error and needs to power off.

    What am I doing incorrectly?

    Thanks in advance!
     
  2. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,922
    257
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    You could have spent the time looking at the description and a few other flashcarts, you would notice that DS flashcarts capable of running on a 2/3DS/XL/LL/NEW are listed in the description.

    Comparing this R4 clone:
    http://nds-card.com/ProShow.asp?ProID=149

    with this DSTT:
    http://www.nds-card.com/ProShow.asp?ProID=157

    You will notice that it states the DSTT works on a DS/lite, this does not say it works on a 2/3DS/XL/LL/NEW.


    Basically you bought the wrong thing, likely because you wanted to save yourself a few bucks.
     
  3. cainamm

    cainamm Member

    Newcomer
    16
    10
    Apr 15, 2013
    United States
    I have two dstt cards. Both work on luma cfw. Search for a thread labelled stage two launcher. Download and install the loader cia.

    Edit: here is a link.https://gbatemp.net/threads/r4-stage2-twl-flashcart-launcher-and-perhaps-other-cards-soon™.416434/
     
    Last edited by cainamm, Jul 23, 2016
    Ahote likes this.
  4. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,922
    257
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
    nm
     
    Ahote likes this.
  5. Ahote
    OP

    Ahote Newbie

    Newcomer
    9
    1
    Jul 15, 2016
    United States
    :rofl2:
     
  6. emmanu888

    emmanu888 6 years and still going strong

    Member
    1,283
    411
    Jan 25, 2009
    Canada
    Victoriaville,Québec
    That card is heavily outdated at this point.
     
  7. Ahote
    OP

    Ahote Newbie

    Newcomer
    9
    1
    Jul 15, 2016
    United States
    I've seen other posts that suggest otherwise.

    So we've ascertained that this card is compatible with an n3ds, but requires that you patch TWL_FIRM--or install a prepatched .cia for a n3ds--and twl slot-1 launcher, but I have yet to find a tutorial that is up to date. I have the forwarder channel installed, but I'm unclear on what exactly to install and when.

    In this thread, Apache Thunder even makes reference that it is the better choice:
    https://gbatemp.net/threads/wheres-that-5-ds-flashcart-i-heard-so-much-about.421659/#post-6226573
     
  8. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Spooky cute.

    Member
    20,080
    21,210
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Actually, with retro's files it's pretty good cart if all you need is the most basic of carts. So just ROMs and cheats, no RTS or anything special.
    And I've used this and my boyfriend is currently using this
    https://gbatemp.net/threads/r4-stage2-twl-flashcart-launcher-and-perhaps-other-cards-soon™.416434/
    Worked great for both of us, all features for YSMenu work just fine.

    Also with pretty much all CFW's, you don't need to patch your NAND(s,) as they all basically provide the same patches in one form or another
    http://gbatemp.net/threads/faq-what-cfw-is-best-for-me.428509/
    Since you are using Luma3DS, just follow the Luma3DS wiki and it does explain how to get DS(i) apps to work
    https://github.com/AuroraWright/Luma3DS/wiki/FAQ-and-Troubleshooting
     
    Last edited by Lilith Valentine, Jul 26, 2016
  9. Ahote
    OP

    Ahote Newbie

    Newcomer
    9
    1
    Jul 15, 2016
    United States
    Do I understand correctly, I don't need to patch TWL_FIRM because I have luma3ds?

    I have attempted to install the stage 2 launcher, but I keep getting an error, where I then have to force power-off the device. I don't want to give up on this, but I can't find a tutorial to get this to work.

    I have FBI, but the info that I've seen concerning the stage 2 launcher, suggests that I have to install to sysNAND and EMUnand. The only problem, is with the current version of FBI, there doesn't appear to be a simple way to install to both. The only thing that strengthens my resolve, is that there are people out there that have found a way for this to work.

    I'm on Emu 9.0.0-20U, and sysNAND is the same is this a hangup to the process?
     
  10. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,574
    2,585
    Jan 10, 2016
    Canada
    NO COFFEI!
    Just easily inject FBI into health and safety on sysnand through decrypt9 so you can also install it there
     
  11. Ahote
    OP

    Ahote Newbie

    Newcomer
    9
    1
    Jul 15, 2016
    United States
    I've updated emuNAND to 10.3.0-28U.

    Using FBI 1.4.17 I was able to install Apache Thunder's stage 2 launcher to sysNAND and then installed to emuNAND. When I inserted the card a blank cart appears onscreen. In FBI, it appears as a DSi title with titleid: 0000000000000000 and no option to delete it. - See (Blank_cart.JPG) Is this typical?

    When tapping the Apache Thunder's launcher, it displays "Menu?"- See (dstt-menu-error.jpg) Where I then have to reboot the device to get it back to functioning.

    Could the problem be with my file structure on the DSTT sd? - See (DSTT_sd.png)
     

    Attached Files:

  12. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,144
    648
    Oct 22, 2011
    Gambia, The
    I'm pretty sure that you are required to have a kernel for the DSTT on the SD.