DSi 1.4 firmware

Discussion in 'NDS - Flashcarts and Accessories' started by Fabis94, Nov 11, 2009.

  1. Fabis94
    OP

    Fabis94 Xbawx playa

    Member
    847
    0
    Jan 5, 2009
    Is there an update for the iTouch2 so it works on the DSi 1.4 update?
     
  2. edracon

    edracon Advanced Member

    Newcomer
    54
    4
    Sep 14, 2008
    United States
    http://www.itouchds.com/

    that's the home page. and it has the following message.
    "Currently there are no Flash carts that will work with 1.4 firmware on the Dsi.

    We are working on it .

    Please don’t update your console to 1.4 until we find out the solution ."

    By that they mean their flashcart does not work with it.
     
  3. bach3609

    bach3609 GBAtemp Fan

    Member
    367
    0
    May 31, 2009
    Loading................
    nope. Currently, sadly the Itouch is not Bootlfash upgradable. Well at least it looks like it is not. Maybe they will release a new version of the card, but who knows? [​IMG]