Hacking Don't get on 3.00 stay on your current firmware version

tunip3

[debugger active]
OP
Banned
Joined
Oct 31, 2016
Messages
1,675
Trophies
0
XP
1,661
Country
United Kingdom
What ever firmware you are don't update I can almost guarantee there are more bugs on your firmware version than 3.00

Plus sciresm has confirmed that a downgrade from 2.3 to 2.0 is theoretically possible
IMG_20171230_181606.png
IMG_20171230_181546.png
 
Last edited by tunip3,

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
3
XP
18,361
Country
United States
This is great advice. Better to stay on 1.0.0, for example, and have to update to 3.0.0 later than to update to 3.0.0 now and the miss out on something released for 1.0.0.

If you're on 1.0.0-3.0.0, stay wherever you're at. There's no need to update to 3.0.0 (yet).
 

cholaloula

Well-Known Member
Newcomer
Joined
May 15, 2017
Messages
62
Trophies
0
Age
38
XP
348
Country
France
As I'm OK with staying on current firmware, how could plutoo recommend to go to 3.0.0 and at the same time say they're exploits patched by 3.0.0? I fully watched the conference and didn't see that, also 3.0.0 is the firmware that introduces the new exploit...
I won't update as I'm not in a rush at all, but some proof may be needed.
 

V-Temp

Well-Known Member
Member
Joined
Jul 20, 2017
Messages
1,227
Trophies
0
Age
34
XP
1,342
Country
United States
Well in the ReSwitched discord server they said 1.0 is the most optimal fw.

1.0.0 is really the only one that stands separate from 3.0.0, the rest are just gradients on 3.0.0 with maybe something to be found that no one has looked for or found if they did. Most of the earnest development will be focused on 3.0.0, those more savvy with do more with 1.0.0 but that is a very, very rare system now.

With how rare 1.0.0, don't be surprised if no one ports anything to it with any speed since the majority will be/have access to 3.0.0. 1.0.0 will be that console that people like daeken and sciresm will have and will be able to make tools with for themselves for extended use with their extensive skills.
 
Last edited by V-Temp,
  • Like
Reactions: peteruk

tunip3

[debugger active]
OP
Banned
Joined
Oct 31, 2016
Messages
1,675
Trophies
0
XP
1,661
Country
United Kingdom
Well, if you can ALMOST guarantee, then you'll be happy to know that literally anyone CAN guarantee that there are more bugs on versions that are less patched.
You can but I said almost because if your on 3.01 or above I cannot guarantee it
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
3
XP
18,361
Country
United States
My understanding is kernel and a built-in way to launch the web browser have both been achieved on 3.0.0. I don't expect a lot to happen on 1.0.0, despite its possibilities, and I expect everything to be released for 3.0.0 between now and the foreseeable future.

In other words, 3.0.0 is analogous to 3DS version 9.2.
 

Paiuand

Well-Known Member
Member
Joined
Aug 24, 2015
Messages
433
Trophies
0
Age
34
XP
1,401
Country
Iraq
This might be true and easier to do, but my understanding is an emuNAND-type solution is also possible on 3.0.0.
I really hope thats true because I myself am on 3.0.0 as well but roblabla who is also in the ReSwitched discord server and is a dev told me that there won’t be some sort of emunand for above 1.0 for a looong time.
 

naddel81

Well-Known Member
Member
Joined
Dec 14, 2009
Messages
2,554
Trophies
1
XP
3,852
Country
United States
My understanding is kernel and a built-in way to launch the web browser have both been achieved on 3.0.0. I don't expect a lot to happen on 1.0.0, despite its possibilities, and I expect everything to be released for 3.0.0 between now and the foreseeable future.

In other words, 3.0.0 is analogous to 3DS version 9.2.

and 1.0.0 would be ps4's 1.76 where nothing really took off. despite 3.0.0 being 4.05 (ps4) where the kernel exploit has been already released and homebrew is about to start for real.
 

tech3475

Well-Known Member
Member
Joined
Jun 12, 2009
Messages
3,736
Trophies
2
XP
6,180
Country
and 1.0.0 would be ps4's 1.76 where nothing really took off. despite 3.0.0 being 4.05 (ps4) where the kernel exploit has been already released and homebrew is about to start for real.

I think the best advice is stay where you are and grab pokken (assuming they haven't updated the carts).

At least you'll have options when the dust settles.
 
  • Like
Reactions: Lacius

NyaakoXD

( ͡° ͜ʖ ͡°)
Member
Joined
Dec 16, 2013
Messages
1,860
Trophies
2
Location
In your closet...
XP
3,701
Country
United States
This might be true and easier to do, but my understanding is an emuNAND-type solution is also possible on 3.0.0.
Maybe possible on 3.0.0. But probably not for a very long while. And this is SciresM, well known for Pokemon datamining and Boot9Strap. If he says to stay on 1.0.0 for EmuNAND-like support and NOT UPDATE to 3.0.0, then best to listen to what he says for hacking the Switch.
 
D

Deleted User

Guest
if you want the real answer 3.0 is bs and just made for homebrew only , 1.0 is the golden firmware why ? because you to play the newest games bought on the store you need the key blobs from higher firmwares which can only be bypassed by an unsigned trust zone which is only possible on firmware 1.0 which can be patched that way , its not possible on 3.0 anymore because the trust zone is blocked by security.

so if you are not stupid rather not update to 3 and wait if you just want homebrew you can enjoy it safely on 3.0
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
3
XP
18,361
Country
United States
if you want the real answer 3.0 is bs and just made for homebrew only , 1.0 is the golden firmware why ? because you to play the newest games bought on the store you need the key blobs from higher firmwares which can only be bypassed by an unsigned trust zone which is only possible on firmware 1.0 which can be patched that way , its not possible on 3.0 anymore because the trust zone is blocked by security.

so if you are not stupid rather not update to 3 and wait if you just want homebrew you can enjoy it safely on 3.0
If one is on 1.0.0, one should stay there. That being said, my understanding is an emuNAND-like solution on 3.0.0 would allow newer games to be played without messing with the TrustZone.
 
  • Like
Reactions: Deleted User
D

Deleted User

Guest
If one is on 1.0.0, one should stay there. That being said, my understanding is an emuNAND-like solution on 3.0.0 would allow newer games to be played without messing with the TrustZone.

i think you are on the discord chat aswell ? they was saying that you need to patch the trust zone which is only possible on 1.0 to get the key blobs to play newer games , because there is no kernelhax on 3.0 to enable anykind of Emunand like solution
 
  • Like
Reactions: Paiuand

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    HiradeGirl @ HiradeGirl: okay