1. SimoxTav

    SimoxTav Member
    Newcomer

    Joined:
    Nov 4, 2014
    Messages:
    21
    Country:
    Italy
    I am still missing what can and what cannot be done on each FW version.
    Basically if you are on:

    1.0.0: Stay here since there is access to the Trustzone and so it means that a cFW can be somehow injected at boot (so it means homebrews + piracy) No ETA
    2.3.0: It seems we have 2 ways to go: Downgrade from 2.3.0 to 2.0.0 might be possible since it uses the same efuses, but what could be the advantage of doing this? On the other hand, upgrading from 2.3.0 to 3.0.0 si doable as well thanks to Pokken. So what the plan here?
    3.0.0: Stay here for ROhan and the consequent homebrew channel (what about piracy, can/cannot?) shortest ETA
    3.0.1+: Relax and enjoy what you can play now since no other exploit are going to be implemented in a short (correct?) longest ETA

    I am getting confused
     
    weatMod, leonmagnus99 and satan89 like this.
  2. hexcode99

    hexcode99 Advanced Member
    Newcomer

    Joined:
    Nov 17, 2013
    Messages:
    94
    Country:
    United States
    What about for those on 2.0.0?
     
  3. SoslanVanWieren

    Banned

    Joined:
    Feb 6, 2017
    Messages:
    1,809
    Country:
    Australia
    they are looking though newer firmwares with a private exploit they are't releasing it so is doesn't get patched
     
  4. SimoxTav

    SimoxTav Member
    Newcomer

    Joined:
    Nov 4, 2014
    Messages:
    21
    Country:
    Italy
    That’s what I am trying to understand, since downgrading from 2.3.0 to 2.0.0 seems doable, I expect something worth on 2.0.0 (or on 2.3.0 itself), otherwise it would make more sense to jump up on 3.0.0
     
  5. LukySplatoon

    LukySplatoon GBAtemp Fan
    Member

    Joined:
    Jun 5, 2016
    Messages:
    306
    Country:
    Belgium
    How did you downgrade 2.0 from 2.3?
     
  6. SoslanVanWieren

    Banned

    Joined:
    Feb 6, 2017
    Messages:
    1,809
    Country:
    Australia
    since it has fuses no downgrading so every new update needs a kernel exploit made for it idk how people are going to get around the fues
     
  7. SimoxTav

    SimoxTav Member
    Newcomer

    Joined:
    Nov 4, 2014
    Messages:
    21
    Country:
    Italy
    I did not, but SciresM stated it’s technically possible with a backup since the same number of efuses are involved in that upgrade/downgrade process (OP). So i decided to list it as a viable option for those who are stuck between 2.0.0 and 3.0.0. That’s why I am confused on what to do next :)
     
    LukySplatoon likes this.
  8. SoslanVanWieren

    Banned

    Joined:
    Feb 6, 2017
    Messages:
    1,809
    Country:
    Australia
    thing is do i wonder do switches that come on the newer firmwares out of the box have no fuses blown. think fues to stop downgrading is a bad idea because if one of the fuses blows on its own due to old age your switch bricks.
     
    Last edited: Dec 31, 2017
  9. cysin

    cysin Member
    Newcomer

    Joined:
    May 30, 2017
    Messages:
    19
    Country:
    Switzerland
    I got 2 switches which are on 1.0 and 3.0. I want to run my cuda applications on switch since they use Tegra X1. :rofl2:
     
  10. MonMonz

    MonMonz GBAtemp Fan
    Member

    Joined:
    Nov 7, 2014
    Messages:
    429
    Country:
    Egypt
    So anyone figured out basically what is the advantage in 2.x over 3.0?
    My switch is 2.1 out of the box so i want to know why should i hold on jumping into 3.0
     
  11. Nezztor

    Nezztor GBAtemp Fan
    Member

    Joined:
    Nov 8, 2016
    Messages:
    474
    Country:
    Mexico
    I Think is worthy if you get your hands in a 1.0.0 unit because is going to be possibly to have emunand (because trustzone code exec)so higher fw with lower real fw if is near impossible to get that console version , don't waste your money on a 2 console
     
    Last edited: Dec 31, 2017
  12. leonmagnus99

    leonmagnus99 GBAtemp Psycho!
    Member

    Joined:
    Apr 2, 2013
    Messages:
    3,619
    Country:
    United States
    damn too late, i updated my 3.0 to 1.0
     
  13. souler92

    souler92 GBAtemp Fan
    Member

    Joined:
    Jan 5, 2017
    Messages:
    394
    Country:
    Netherlands
    sjit sjit sjit i am on 4.* thanks to my brother GODDAM
     
    Nezztor likes this.
  14. leonmagnus99

    leonmagnus99 GBAtemp Psycho!
    Member

    Joined:
    Apr 2, 2013
    Messages:
    3,619
    Country:
    United States
    try selling yours mate, i sold mine which was updated to the latest some month ago , and that wass above 3.0
    i think it was at 3.0.1.

    it was only after a week , i was abit too late to check on gbatemp for things, so i looked it up and was on the 'bad' fw.
    i was then just like 'okay phuck it imma just try to sell this and buy a new one which will come on a lower fw'

    and that is what i did, luckily a friend of mine wanted one.
    i had Splatoon2/FastRMX/MK8 deluxe on the switch (purchased digitally).

    i sold it for 400$ i lost around 100$ of value, because i had the games in them, and because i bought the switch for 430$ at that time (which was roughly 4 months ago i think..)

    and yeah my 2.3 witch has been sleeping for all these months !
    and i regularly check on gbatemp etc.

    just to see what's up..

    i have a copy of Pokken in case i need to update the 2.3 to 3.0

    it seems like the lower you are on the better, i was confused because i often read on here that some of the devs recommend you to update to 3.0 and bla, but now in this thread i read different, anyways let's see what happens.

    and try to sell your switch like i said !
     
  15. the_randomizer

    the_randomizer The Temp's official fox whisperer
    Member

    Joined:
    Apr 29, 2011
    Messages:
    29,474
    Country:
    United States
    I'd rather not, the Switch was paid half by my brother, and he has some important game saves on here I'd rather not lose, not really an option like I said. I'm better off either waiting or getting another Switch.

    1.0.0 consoles are extremely rare and overpriced. I'd be wasting money either way, unless someone on the Temp can do a trade.
     
    Last edited: Dec 31, 2017
  16. SomeGamer

    SomeGamer GBAtemp Guru
    Member

    Joined:
    Dec 19, 2014
    Messages:
    6,763
    Country:
    Antarctica
    "Don't get on 3.00 stay on your current firmware version"
    Thanks, I won't trouble with downgrading from 4.1.0 then.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - firmware, current, version