Cryptofix Still Required on 10.3+ N3DS EmuNAND?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Ichii Giki, Jan 27, 2016.

  1. Ichii Giki
    OP

    Ichii Giki GBAtemp Regular

    Member
    250
    96
    Mar 12, 2015
    United States
    So I was under the impression that we no longer would need to get crypto-fixed versions of games/updates now that GW/ReiNAND support 10.3+ EmuNAND. However, I created a Pokemon Picross CIA and installed it on my 10.4 GW EmuNAND on my N3DS and it just hangs at the 3DS logo with red bars on launch.

    I created this CIA from the ticket.db of my O3DS with FunkyCIA2 as normal, so I was surprised to find it not to be able to launch even with my N3DS EmuNAND on 10.4. Other CIAs, such as the game update for Mario Puzzle & Dragons, I made with the same process from the ticket.db of my O3DS installed and appear to launch fine on my N3DS (granted this title was published before 9.6+ FW was released, which leads me to believe this is a cryptofix-related issue). Is there something different about free-to-play titles like Pokemon Picross that I am missing? Any insight into this issue is appreciated. ^_^
     
  2. JJTapia19

    JJTapia19 I fight for my friends.

    Member
    1,699
    1,065
    May 31, 2015
    Puerto Rico
    You need to go to the download page of the game in the eshop once. That unlocks the seed file and will let you play 9.6+ games.
     
    leonmagnus99 and Ichii Giki like this.
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,486
    5,461
    Mar 17, 2010
    Norway
    Alola
    I don't think you get the required seed key when you install a CIA, only when you download a game/update directly from the eShop, which was where it was the most problematic, as it's a simple enough matter to cryptofix a game when you dump it and most dumps you find are already cryptofixed.

    Ah, that simplifies things.
     
    Ichii Giki likes this.
  4. morvoran

    morvoran GBAtemp Regular

    Member
    154
    65
    Dec 19, 2010
    United States
    Cryptofixing is not necessary only if you have access to the eshop of the same region as the game you want to play since the seed is still required to start the game and can be obtained through the eshop. This is what people mean by cryptofixing not being necessary on 10.3+. If you want to play a EUR region game on a US region 3ds, for example, then cryptofixing is still required as you can't access the EUR eshop to get the seed.
     
    Ichii Giki and peteruk like this.
  5. Neptune

    Neptune GBAtemp Advanced Maniac

    Member
    1,588
    533
    Dec 7, 2003
    United States
    Internet
    There was also some website you could go to that would download all currently known seeds
     
  6. wurstpistole
    This message by wurstpistole has been removed from public view by raulpica, Jan 27, 2016, Reason: Read the rules -rp.
    Jan 27, 2016
  7. Neptune

    Neptune GBAtemp Advanced Maniac

    Member
    1,588
    533
    Dec 7, 2003
    United States
    Internet
    I can't find it right now. I never cared because I didn't need it before lol.
     
  8. RainThunder

    RainThunder GBAtemp Regular

    Member
    212
    134
    Jun 22, 2012
    Hanoi
  9. Ichii Giki
    OP

    Ichii Giki GBAtemp Regular

    Member
    250
    96
    Mar 12, 2015
    United States
    Thank you so much for these clarifications! I guess I'm stuck with CryptoFixed CIAs then for my N3DS as it is a region-changed system, so I won't ever easily be able to get to the eShop download page for anything on my target-region. Maybe some day we'll know the proper format for the seedsave.bin file and we can manually import all the crypto-seeds from the full seeddb.bin into it. At least 10.3+ EmuNAND finally lets me put badges on folders! ^_^