Can I update/install FBI 2.4.8 with O3DSXL 11.4v? (noob hacker)

Discussion in '3DS - Flashcards & Custom Firmwares' started by silverice1994, Jul 9, 2017.

  1. silverice1994
    OP

    silverice1994 Member

    Newcomer
    10
    0
    Jul 9, 2017
    Philippines
    Just bought a 2nd hand O3DS XL with Homebrew (not working) and FBI 2.2.6 (working)

    I've installed the Ace Attorney: Spirit of Justice and it didn't work because of the outdated FBI (stucked at the 3DS logo). But when I installed the Mario Kart 7 CIA to test, it plays without having an issue. So, is it possible to update/install to latest version? I don't want to downgrade mine because the instruction were vague and it may brick the system.

    Please help me. Thank you!
     
  2. bakageta

    bakageta Advanced Member

    Newcomer
    73
    14
    Feb 5, 2016
    United States
    Do you know if FBI is installed as a regular CIA or injected over Health and Safety? Do you know what CFW you're using? Is this an old emunand setup, a9lh, or was it updated to b9s? If you've got instructions from the seller, post what you've got, it'll help narrow down where you need to go from here. Either way, if you've got any cfw set up you won't need to downgrade anything to get the system caught up on the latest methods.

    2.2.6 should have a self-update option that works if you have internet set up, but if your FBI has replaced Health and Safety I want to say it installs a second FBI instead of replacing the current one. That's not a big deal, you can go restore Health and Safety and the FBI you're left with will be able to update itself, or you can move to the new method of using Rosalina to launch FBI without it actually being installed.
     
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,097
    5,169
    Mar 17, 2010
    Norway
    Alola
    Visit the eShop page of the game and as long as the CIA is in-region it should then work, it's because it's missing the seed key which only newer FBI versions and FreeShop will install.
    FBI has a self-update function like the guy above me mentioned.
    Also, I suggest getting FreeShop from here: https://gbatemp.net/threads/release-arc13s-freeshop-fork-open-source-eshop-alternative.468436/
    And scan the QR code from the 3DS titlekeys website in the settings.
    It will make your life much easier, you can download/install games directly on the 3DS.
     
  4. silverice1994
    OP

    silverice1994 Member

    Newcomer
    10
    0
    Jul 9, 2017
    Philippines
    The firmware is "Sys 11.4.0-37U" and yes, my system has two FBIs. Does updating will brick the system? I just want to make sure.
     
  5. bakageta

    bakageta Advanced Member

    Newcomer
    73
    14
    Feb 5, 2016
    United States
    It looks like you're probably using Luma as a CFW, and you'll either have a9lh or b9s, both of which mean you can update the 3DS firmware with no fish of losing CFW. Power your system off, and hold select then power it back on. That should give you a Luma config menu with a version number at top, let me know what it is.

    You need to always update Luma before installing a new firmware. If you don't, at some point your old Luma won't be compatible with the new firmware, and you'll need to pull the sdcard and update on a computer before your 3ds will work again. Luma no longer supports a9lh, so we need to see if you're still on it, since that will mean you can't update Luma. There's a quick and easy guide to replacing a9lh with b9s, and if you're on b9s you just run a Luma updater app then do a system update.

    To get rid of the old FBI, open the other, newer one, go to Titles, and there should be a red FBI listed. Uninstall it, then go to system settings and check for updates. 11.4 is the newest, so this will just grab the Health and Safety app and put it back.
     
  6. silverice1994
    OP

    silverice1994 Member

    Newcomer
    10
    0
    Jul 9, 2017
    Philippines
    It's v6.6. Should I update first the Luma or get rid of FBI?

    — Posts automatically merged - Please don't double post! —

    Eshop doesn't let me browse titles because of unverified account. Does changing Nintendo account make my downloaded games disappear?
     
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,097
    5,169
    Mar 17, 2010
    Norway
    Alola
    You can't normally change the NNID without formatting the console, but it's possible by injecting a blank nnidsave.bin, however if you open eShop afterwards any legitimate games that belong to the other account might disappear, if you have any.
    It doesn't matter if you update Luma or get rid of FBI first. As for updating Luma just follow this: https://3ds.guide/a9lh-to-b9s
     
  8. bakageta

    bakageta Advanced Member

    Newcomer
    73
    14
    Feb 5, 2016
    United States
    You can get rid of FBI first if you want, or do it later, it doesn't matter either way. I'd just put it off and do it once you're up to date.

    6.6 is getting fairly old, it's from November last year. You have a9lh right now, so you're going to need to follow this guide to update to b9s and Luma 8.1. It's pretty straightforward, you'll need a way to read the sdcard on your PC and don't skip any steps. It should take 15-30 minutes start to finish, even for someone who hasn't done it before.

    Once you finish that, go fix FBI, and you're all set. The guide has you install the Luma updater, just run that before you do a system update in the future and you'll be fine.
     
  9. silverice1994
    OP

    silverice1994 Member

    Newcomer
    10
    0
    Jul 9, 2017
    Philippines
    Just made a backup, should I empty the SD card before I proceed?

    Edit: Nevermind, I didn't read the instructions carefully. Sorry!
     
    Last edited by silverice1994, Jul 9, 2017
  10. silverice1994
    OP

    silverice1994 Member

    Newcomer
    10
    0
    Jul 9, 2017
    Philippines
    Wow! Thanks a million!!! It works perfectly!!! Thanks again!
     
  11. bakageta

    bakageta Advanced Member

    Newcomer
    73
    14
    Feb 5, 2016
    United States
    Glad to help! Since your FBI and Luma were older, you should look into updating any other apps you use. The old freeshop isn't being developed anymore, but if its something you use, you should replace it with this fork that's actively developed, there are some nice improvements.