Auto Mounting USB

Discussion in 'PS Vita - Hacking & Homebrew' started by Dave_Chad, Jul 29, 2017.

  1. Dave_Chad
    OP

    Dave_Chad GBAtemp Regular

    Member
    167
    26
    Jun 29, 2016
    So i have updated my Vita to Enso today and it's very nice to have.

    But now i'm wondering for my PSTV, is there already a script or will there be soon to auto mount the usb stick instead of internal memory as ux0?

    Plus i suppose once i get hold of an sd adapter i'll have a similar question for my Vita...is there a way to automount the gamecard adapter as ux0?

    I may have missed something in all the excitement of the new release...
     


  2. Dave_Chad
    OP

    Dave_Chad GBAtemp Regular

    Member
    167
    26
    Jun 29, 2016
    Seriously nobody else is interested in this?

    Sent from my ONEPLUS A3003 using Tapatalk
     
  3. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,477
    2,664
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    There are 2 driver plugins for the SD2Vita adapter. One mounts it to uma0 and the memory stick to ux0, the other mounts the SD to ux0 and the memory card as uma0.
     
  4. Dave_Chad
    OP

    Dave_Chad GBAtemp Regular

    Member
    167
    26
    Jun 29, 2016
    That's cool I'm guessing the beta testers must have used some sort of script at some point. Just not heard people shouting for it!

    Sent from my ONEPLUS A3003 using Tapatalk
     
  5. Burnt Lasagna

    Burnt Lasagna GBAtemp Regular

    Member
    119
    58
    Feb 29, 2012
    United States
    https://github.com/yifanlu/usbmc
    Unfortunately, the current release seems to be broken...
     
    whateverg1012 likes this.
  6. fate6

    fate6 Haha, I killed a Pumpkin!

    Member
    187
    64
    Aug 2, 2014
    United States
    [fate6@Canterlot ~]$
    Yea it doesn't auto mount the USB on PSTV but it does remove the need to disconnect/reconnect the USB drive so it at least lets you do everything without going over the the system.
     
  7. Vampirex

    Vampirex Dhampir

    Member
    248
    62
    Mar 12, 2008
    Canada
  8. Faran Maqsood

    Faran Maqsood Member

    Newcomer
    42
    5
    Aug 12, 2015
    Pakistan
    I've followed the setup but all it does is remove the step where I have to unplug and re-plug the drive.
    Is there any way to auto mount usb as ux0 on boot?
     
    Last edited by Faran Maqsood, Jul 30, 2017
  9. Primula

    Primula GBAtemp Regular

    Member
    133
    23
    Oct 3, 2016
    United States
    remove the need to remove the usb and plug it back in is fine with me... =D
     
  10. Anunnymous

    Anunnymous Advanced Member

    Newcomer
    58
    25
    Oct 27, 2007
    United States
    Works 100% for me. The plugin must be loaded before SceShell. It says add the line "after *Kernel." My config has multiple "*Kernel". I added mine directly after the first one in the txt and it works flawless. If all that's correct, maybe there is a random bug that isn't allowing you but I have 3 PSTVs and it works on all 3.
     
  11. godreborn

    godreborn GBAtemp Addict

    Member
    2,670
    464
    Oct 10, 2009
    United States
    I've encountered a bug with usbmc. I don't know if it's due to cloning the adrenaline game as well as ark and vhbl, but what happened was bighead snooker was installed again. if I delete the additional game, adrenaline/ark don't work anymore.

    — Posts automatically merged - Please don't double post! —

    I've fixed the problem with bighead snooker. what I did was copied over the license to my laptop, deleted the game, then copied the license back. adrenaline works without that game being on my system. :)
     
    Anunnymous likes this.
  12. bananapi761

    bananapi761 Lurkin

    Member
    146
    22
    Jan 8, 2016
    United Kingdom
    Norn Iron
  13. godreborn

    godreborn GBAtemp Addict

    Member
    2,670
    464
    Oct 10, 2009
    United States
  14. Anunnymous

    Anunnymous Advanced Member

    Newcomer
    58
    25
    Oct 27, 2007
    United States
    If there is no option to mount imc0, then your VitaShell is outdated. Update to the latest version and it'll be there. On a side note, I didn't even have a "tai" folder in imc0.
     
  15. godreborn

    godreborn GBAtemp Addict

    Member
    2,670
    464
    Oct 10, 2009
    United States
    I'm on 1.62, and I don't remember an imc partition. is it listed by default? maybe it's due to not having a memory card?
     
  16. Anunnymous

    Anunnymous Advanced Member

    Newcomer
    58
    25
    Oct 27, 2007
    United States
    Oh, possibly. Mine is by default but I guess I haven't tried without a memory card inserted.
     
  17. bananapi761

    bananapi761 Lurkin

    Member
    146
    22
    Jan 8, 2016
    United Kingdom
    Norn Iron
    No, I have a memory card and 1.62, there is no option for mounting imc0. I'll try the Vitashell mod and see if it helps.
     
  18. godreborn

    godreborn GBAtemp Addict

    Member
    2,670
    464
    Oct 10, 2009
    United States
    there's no mention of it in the changelogs. are you sure you're not using a fork of vita shell?
     
  19. Anunnymous

    Anunnymous Advanced Member

    Newcomer
    58
    25
    Oct 27, 2007
    United States
    You are correct, without a memory card I have no imc0 option (because you're already on Internal Memory... makes sense. Lmao). I'm not too sure of Banana's issue though. 1.62 should have the option. Banana, you're on a PSTV or 1000 Vita? The 2000 slim Vita doesn't have imc.

    — Posts automatically merged - Please don't double post! —

    If all else fails, skip that step. It won't cause any harm, if there are any issues, it just won't work properly.
     
    godreborn likes this.
  20. godreborn

    godreborn GBAtemp Addict

    Member
    2,670
    464
    Oct 10, 2009
    United States
    how come it doesn't show up whenever u mount the usb drive as ux0? does that happen to u as well?
     
  21. bananapi761

    bananapi761 Lurkin

    Member
    146
    22
    Jan 8, 2016
    United Kingdom
    Norn Iron
    Sorry, I was on 1.61... I updated it and I see it now. Thanks!