Accessing save files on dumped RedNAND

Discussion in 'Wii U - Hacking & Backup Loaders' started by ponsense, Jul 14, 2017.

  1. ponsense
    OP

    ponsense Newbie

    Newcomer
    2
    0
    Jul 14, 2017
    United Kingdom
    A bit of setup:
    Back in January I followed a guide and got my Wii U with Haxchi + Mocha CFW + RedNAND on my SD card, and pretty much everything worked fine. I only used it to play a few games, so I didn't buy a usb drive and just installed them in the RedNAND memory, which was probably a mistake.

    So BOTW dlc comes around, and I install it to memory and it works fine, but after I shut off the Wii U and turn it back on, it's gone. I assumed the system deleted it, and I was too lazy to look into it and I just installed it again whenever I wanted to play again. So I screwed up. During the 4th time the menus got extremely slow, and I can only assume I was just pilling the DLC data files on top of each other. I managed to delete the last DLC I installed before I shut off the console, but the menus were still slow, and when I rebooted and tried loading the rednand it just freezes at the Mocha CFW screen.

    Current situation:
    My RedNAND is inaccessible on the console, and I want to retrieve my save data if that's possible. I have a back up of my original SysNAND, and I also dumped my current RedNAND from my SD card (MLC, SLC, SLCCMPT, OTP). I tried using Nandextract by koolkdevand and I'm able to access SLC and SLCCMPT, but not MLC (gives me a "Invalid or unsupported dump" error) which is where I assume all the game data is at (and it gives me the same error if I try to access the MLC on my SysNAND back up).

    Can I get my save files or are they lost? I appreciate any help.
     
  2. Kafluke

    Kafluke GBAtemp Psycho!

    Member
    3,422
    1,687
    May 6, 2006
    United States
    Wow redNAND huh? Must have been an old guide.

    Anyway, your goal should be getting your redNAND back and running. You can only recover your savedata if redNAND is working.

    If/when you get redNAND running and save your data then read my guide in my sticky and completely abandon redNAND and mocha.

    You followed a guide that had you use one CFW (HaxChi) to boot a second CFW (mocha) to then launch a 3rd CFW (Rednand).

    I'll bet you followed wiiu.guide. that's a guide that we at gbatemp have NEVER recommended you follow due to incorrect recommendations and outdated info with step by steps and no proper explanation on each step.

    If you lose all your savedata then the best I can say is "lesson learned". All of the devs of the Wii U hacks post here first. Gbatemp is THE source for Wii U hacking. Never trust any other site or YouTube video.
     
    Last edited by Kafluke, Jul 14, 2017
  3. ponsense
    OP

    ponsense Newbie

    Newcomer
    2
    0
    Jul 14, 2017
    United Kingdom
    Yeah, I did follow the wiiu.guide back in December. So there isn't any way to extract the save file data from the MLC.bin file at all?

    That's unfortunate. I don't even know what is wrong with the rednand, but if the problem was that I overloaded it by installing too many files I can't access the MLC.bin to find and clear them up anyway.