Why am I getting an error 2155-8007 when launching games on switch?

Why am I getting an error 2155-8007 when launching games on switch?

spoosh
Aug 18, 2019
Hi guys. Im completely new to the hacking scene and need some assistance.

Im currently on FIRMWARE 7.0.1 (0.9.3ams), when i try to install nsps on tinfoil the installation completes yet when i go to the main menu to launch them theres no pic of the game just a spiral and when i click i get an error 2155-8007 saying the software cant be started. Im on the latest version of atmosphere and have sigpatches installed. i have tried using a fat32 and exfat sd card with no luck. i have also tried being connected and disconnected to the internet.

Any help is greatly appreciated.

» 3 Answers

  • Draxzelex
    Aug 23, 2019
    Have you tried using ReiNX?
  • NoNAND
    Aug 23, 2019
    Don't connect your hacked switch to the internet that's not good, you might get a ban.
    Have you tried to install them with Goldleaf instead and see if they work or not?
    Try using ReiNX or the kosmos bundle and see if that resolves your issues.
    If a game installs but shows as a blank icon with an endless spinning circle it might indicate that the minimum required firmware to run the game isn't met or the NSP of the game might be corrupt and incomplete.

    On a last note. Delete everything and start fresh with the new installation of atmosphere/kosmos or ReiNX(your CFW of choice) and get your NSP from another source?
    by the by, have you tried other games?
  • smf
    Aug 23, 2019
    I use goldleaf 0.5, I was going to upgrade but I heard of incompatibility in later version with some games.