xk3y Remote (1st Gen) Middle Button Issue

Discussion in 'Xbox 360 - Hacking & Homebrew' started by aadrian83, Feb 15, 2015.

  1. aadrian83
    OP

    aadrian83 Newbie

    Newcomer
    3
    0
    Feb 15, 2015
    France
    Hi All,

    Summary: setup is ok, xk3y works fine, but the middle button of my xk3y remote doesn't seem to work. Navigation buttons are ok, but not the middle button. It was never connected/disconnected when the power was on. This is 1st Gen remote with 1 USB.

    Detail:

    I bought an xk3y V2 + Remote over a year ago, but didn't really have the time to put it in as I had to dump my key first. Bought a Maximus Lizard 360 and recently dumped it.

    xk3y seems to work fine, but the middle button of my xk3y remote doesn't seem to work. Navigation buttons are ok, but not the middle button. It was never connected/disconnected when the power was on.

    Bought this set at siliteo website (FR) but I have not contacted them yet, as I'm quite sure the warranty is out (over a year). So I'm reverting to "technical solution" instead.

    The push on button seems to be normal, and nothing obviously wrong on the circuitry. This is 1st Gen remote with 1 USB.

    Any suggestions?

    Thanks in advance.
     
  2. DinohScene

    DinohScene Dino May Fire

    Member
    GBAtemp Patron
    DinohScene is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    15,592
    11,959
    Oct 11, 2011
    Antarctica
    В небо
    I think the buttons just wore out.
    You can use MenuISO without any problems so switch to that ;]
     
  3. aadrian83
    OP

    aadrian83 Newbie

    Newcomer
    3
    0
    Feb 15, 2015
    France

    DinohScene: thanks. this remote is brand new tho. Most people will simply say "contact the seller/re-seller" but this is out of warranty. The button seems to work fine, mechanically. Not electrically obviously. Did some searches but seems like it's not a common issue, and I may have got one with manufacturing defect :(
     
  4. DinohScene

    DinohScene Dino May Fire

    Member
    GBAtemp Patron
    DinohScene is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    15,592
    11,959
    Oct 11, 2011
    Antarctica
    В небо
    If you've got good soldering skills then I'd say crack it open and check/resolder the connections.
    It's possible it's a manufacturing defect, I mean, it's not first party hardware, nor do they make them with quality in mind.
    It remains piracy enabling hardware in the end ;p

    Seeing it's just the remote, I'd personally cut me losses and use MenuISO.
     
  5. aadrian83
    OP

    aadrian83 Newbie

    Newcomer
    3
    0
    Feb 15, 2015
    France
    In fact, I opened it up. The push-on button is indeed broken, somehow. So I just put on a coil of wires instead of the original "spring". It works pretty well now, even without the nice "bouncy" effect. At least for now, good enough for me ;)
     
  6. DinohScene

    DinohScene Dino May Fire

    Member
    GBAtemp Patron
    DinohScene is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    15,592
    11,959
    Oct 11, 2011
    Antarctica
    В небо
    How lovely that simple fixes always work.
    Then again, I'd advice to use MenuISO from now on.
    Use the Remote as a backup.