1. bbq_bob

    bbq_bob Newbie
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    8
    Country:
    United States
    Beta 5 did not work any better on my Wii U. If anything, it seems to jump to restarting WiiFlow faster. There is another peculiarity that I didn't see before. When selecting the game, about 60% of the time, I see a DVD cover on the left, a banner on the upper right, and it plays some music. About 30% of the time, the banner is missing and I see a empty purple box with the name of the game and no music. And about 10% of the time, the back and play buttons are centered and the banner covers most of the screen without a DVD case.

    I used beta 5 to save the NAND to the USB and installed the WAD from the SD /wad directory again. I feel like I am missing a step or some other cIOS or something. Do I have to install neek2o separately from WiiFlow Lite?
     
  2. AdamCatalyst

    AdamCatalyst Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    28
    Country:
    Canada
    Same here, on Wii U.
     
  3. vbarros22

    vbarros22 GBAtemp Regular
    Member

    Joined:
    Jun 20, 2017
    Messages:
    177
    Country:
    Brazil
    For me the latest Wiiflow stable and beta did not worked on vWii to play gamecube. Always give me black screen but when running direct from nintendont app works fine. Running on Open Homebrew Channel injected to have Wii U Gamepad support
     
  4. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,021
    Country:
    United States
    60% is normal
    10% is normal if you've clicked on the banner which switched you to full screen banner with play and back underneath it.
    30% is normal if wiiflow can't find the games banner. without the banner no game music plays and the title is shown instead of the banner. but the fact that wiiflow can't find or load the banner means something is wrong with your game or emunand.

    I've never messed with emunand on wiiu much because things can be a little different on the wii u.
    i dont even know if using wiiflow lite to make an emunand on wii u works correctly?

    I personally prefer to use modmii to make an emunand and showmiiwads to add wads to it.
    plus for wii u the emunand goes in a subfolder of dev:/vwiinands not dev:/nands.

    hopefully @RunningSnakes and @AdamCatalyst can give you more advice. I've gotten rusty when comes to emunands.
     
  5. bbq_bob

    bbq_bob Newbie
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    8
    Country:
    United States
    I wasn't reporting for 60%,30%, and 10% of all of my games. This is the breakdown of what happens for the same game if I did this 10 times in a row. Select the game with A. Click Back. Do not move to another game, but select the same game with A again. Repeat... I didn't click a second time on the banner. It would go there automatically.

    This isn't the problem. I just thought it was strange and might be indicative of some underlying problem. It sounds like the fact that the same game has a problem with loading music and a banner 30% of the time, the emunand isn't working reliably, which is consistent with the games not working.

    I'll try to see if I can dump the NAND to the SD card. I don't have WiiFlow in front of me now. Hopefully there is an option somewhere. I don't recall being asked at the start of the save in WiiFlow.

    Isn't modmii a very bad thing to run on a Wii U? Has something changed? In the thread "Basic Do's and Do NOT's of vWii modding" it says "DO NOT USE MODMII ! FULL BRICK ASSURED"

    Yes, the NAND was saved to USB1:/vwiinands
     
  6. bbq_bob

    bbq_bob Newbie
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    8
    Country:
    United States
    Can you outline the steps that you took to get WiiWare/Virtual Console games working on WiiFlow on your Wii U? What game did you try? What are your WiiFlow EMUNAND settings? How did you dump the real NAND? How did you install the WAD? Thanks!
     
  7. AdamCatalyst

    AdamCatalyst Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    28
    Country:
    Canada
    Sorry, not using EmuNAND for VC games. My apologies if my comment was misleading.
     
  8. RunningSnakes

    RunningSnakes GBAtemp Fan
    Member

    Joined:
    Jun 21, 2018
    Messages:
    324
    Country:
    United States
    Ok, so I wiped the dust off my Wii U (5.5.2 U). It's been quite a while so it was a perfect time to get channels etc. up to date & install EmuNand to see if I could possibly help. Using WFL 5.4.7 beta 6, I extracted NAND through WFL
    NAND Emulation Settings:
    Select NAND = default
    NAND Emulation = Partial
    Select Saved NAND = default
    Saves NAND Emulation = Off
    Saves NAND Partition = USB1
    Use Real NAND Config = Off
    Use Real NAND Mood = Off

    This took about 20 minutes to complete and it created both (vwiinands) & (nands) folders. But using those settings^^^^above, evidently the default folder is "nands" for vWii. After Installing several wads using WFL wad installer, the vwiinands folder is under 20kb in size, where nands folder is checking in around 400mb. I am currently testing all games installed & can tell you some if not all are working properly. I'll leave results soon but just have to say, in my experiences with EmuNAND(s) I've set up through the years, WFL & GX dumps are much more stable than ModMii has ever been. For Guitar Hero & Rock Band, I use GX dumps since I've never had any trouble where as WFL is hit/miss for some reason. For WiiWare-VC-Injects, WFL is the best IMO since you can Edit any way you choose & never had a problem for reliability. This is only the 2nd Wii U I have set EmuNAND up IIRC, the other for a friend 4-5 years ago, but I am not sure how much he used it, if at all. I'm using USB for this setup with no SD just so you know. When I am finished, I'll transfer EmuNAND or create another using SD & post results for that setup as well.
     
    Last edited by RunningSnakes, Sep 29, 2020
    bbq_bob, fledge68 and Tetsuo Shima like this.
  9. RunningSnakes

    RunningSnakes GBAtemp Fan
    Member

    Joined:
    Jun 21, 2018
    Messages:
    324
    Country:
    United States
    Results:
    Adventure Island (WW) - Working
    Alien Soldier (VC) - Working
    Alisia Dragoon (Inject) - Black Screen
    Bionic Commando (Inject) - Freeze
    Castlevania III (VC) - Working
    Contra Rebirth (WW) - Working
    Daimakaimura (Inject) - Working
    Gate Of Thunder (VC) - Working
    Legendary Axe (Inject) - Black Screen Freeze

    All injects not working are my own creations confirmed working on Wii through WFL. So I'm going to dump NAND using GX quickly to test.

    Edit:
    Using GX EmuNAND, I get the exact same results as WFL. EmuNAND is working on vWii through USB (WFL 547b6) using official game releases. 1/4 injects worked in minimal testing, however all injects are working on Wii 4.1U (WFL 547b6) tested immediately afterwards. All settings were left at default for all tests so there is no confusion.
     
    Last edited by RunningSnakes, Sep 29, 2020
    bbq_bob, Tetsuo Shima and fledge68 like this.
  10. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,021
    Country:
    United States
    Thank you so much for taking the time to do all this. Much appreciated.
    Everything seems fine except the nands and vwiinands folders. I'll look into that.
     
  11. bbq_bob

    bbq_bob Newbie
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    8
    Country:
    United States
    Thanks for testing this.

    I dumped my NAND to the the SD from within WiiFlow, and got somewhat better results. Otherwise I used your settings. Here are my results on your list:
    Adventure Island (WW) - Working
    Alien Soldier (VC) - NOT Working
    Castlevania III (VC) - Working
    Contra Rebirth (WW) - Working
    Gate Of Thunder (VC) - Working

    The games I was trying to play before still don't work, but it seems that my set was unlucky and so it seemed like nothing worked.

    I noticed that when I dumped to SD, the NAND was stored in SD:/nand, but when save to the USB, it was saved into USB1:/vwiinand. There is not a nand directory on my USB at all. After saving to the SD, it doesn't seem that I can get WiiFlow to use the USB image.

    To install the games, did you use WiiFlow to load the wads or showmiiwads?

    I was surprised that you set Saves NAND Emulation = Off. I thought this setting was whether game saves are done on the real nand (off) or on the emuNand (on). I think games saves are one of things that causes the most writes to the NAND and therefore it is desirable to avoid writes and use the emuNAND for games saves.
     
    RunningSnakes likes this.
  12. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,021
    Country:
    United States
    Saves nand emulation is for wii games only. Ww and vc games save to emunand automatically . Most likely your games that dont work are bad dumps. And you do know to use a y cable for usb hdd on wii u.
     
    RunningSnakes likes this.
  13. Tetsuo Shima

    Tetsuo Shima GBAtemp Maniac
    Member

    Joined:
    Oct 29, 2008
    Messages:
    1,338
    Country:
    Italy
    Furthermore, with some Wii games you have to set saves nand emulation to Off, because they would freeze at the title screen.
    I had this problem with Dead Space Extraction and Metroid Prime 3 Corruption, for example
     
    RunningSnakes and AdamCatalyst like this.
  14. danny19901

    danny19901 GBAtemp Fan
    Member

    Joined:
    Feb 12, 2016
    Messages:
    309
    Country:
    I created a inject for latest wiiflow from GitHub is it possible to launch games from SD card at all as I get can't launch in Wii virtual console mode but GC games works perfectly fine also I made a custom banner for this also I made 2 versions with 2 banners FB_IMG_1601493446880.jpg FB_IMG_1601493450322.jpg FB_IMG_1601493446880.jpg
     
  15. RunningSnakes

    RunningSnakes GBAtemp Fan
    Member

    Joined:
    Jun 21, 2018
    Messages:
    324
    Country:
    United States
    @bbq_bob

    I installed wads through WiiFlowLite. ShowMiiWads is quicker for mass install and it is required if you are installing WW DLC. GX also offers folder batch install if you want to go that route. Its possible Alien Soldier will work if installed through WFL, no harm in trying.

    Edit:
    As fledge pointed out, Y cable is needed if you are using HDD with no power supply. In my test, I used an older WD My Book 2TB with plug-in power supply. Could you please post what you are using for your test/use, it may be the root of your issues.
     
    Last edited by RunningSnakes, Oct 1, 2020
  16. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,021
    Country:
    United States
    @RunningSnakes when you did your test on wii u vwii you said it made a vwiinands folder and a nands folder. but it only installed the wads to the nands folder right? and of course that was the emunand that wiiflow used for the covers and the games.

    so about the vwiinands folder:

    did it have any folders and files inside?
    does it look like an emunand just not with the wads you later installed?
    and are you sure it wasn't already on there before your tests?

    So in the code it checks if on wiiu and if so to use vwiinands and if not use nands. it makes sense for this check to be failing and wiiflow to think you are on a wii and to use nands. but then why would it make a vwiinands folder too? that's what doesn't make sense.
    It could also be that it uses vwiinands when it dumps the nand but when you install wads it for some reason switches to using nands.

    Another option is to just not use vwiinands for wiiu, instead always use nands regardless of the console. i only changed it because the last beta of neek2o changed it but hardly any one even has that beta.
     
  17. RunningSnakes

    RunningSnakes GBAtemp Fan
    Member

    Joined:
    Jun 21, 2018
    Messages:
    324
    Country:
    United States
    @fledge68

    Yes, it is possible the vwiinands folder was already on HDD before dumping NAND, I used that HDD for WiiU only in the past & I didn't think to look at the dates. I did go through the vwiinands folder and the structure looks like a normal Wii nands dump. All the same sub-folders were created, but there were no files in any of the folders.
     
    fledge68 likes this.
  18. godreborn

    godreborn Retired
    Member

    Joined:
    Oct 10, 2009
    Messages:
    12,044
    Country:
    United States
    try to make the emunand in usb loader gx/features:

    upload_2020-10-2_1-26-18.png
     
  19. bbq_bob

    bbq_bob Newbie
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    8
    Country:
    United States
    I have two HDD. One is for the Wii U, and the other is for the Wii. The Wii U HDD USB first runs to a powered USB hub. Both parts of the Y go from the hub to the Wii U HDD. This has worked fine for Wii U games for years.

    The other HDD is for the vWii / Wii games. It is a WD 500 GB non-powered portable drive. The data portion of the Y is plugged into the back and the power end of the Y is plugged into the front of the Wii U. This HDD has worked fine for Wii games for years. I think it was formatted as NTFS, but recently I wanted to run Gamecube games, so I reformatted it to FAT32 with 32K. Gamecube games also work fine now with this setup. The Wii disk is hidden using Ustealth.

    My SD card is is a 64 GB Samsung EVO micro-SD in its SD card adapter. This has also been used for years.

    Only recently have I tried to get virtual console / WiiWare games working. I don't have history with here with a prior WiiFlow or WiiFlow lite release for these games. Many of the same games work on another Wii (not Wii U). That Wii is running ABZ Masterpiece Pack with WiiFlow (not WiiFlow Lite). I haven't had the time yet to identify which one work on the real Wii but not on the Wii U vWii.
     
    RunningSnakes likes this.
  20. TeenTin

    TeenTin GBAtemp Maniac
    Member

    Joined:
    Jun 20, 2007
    Messages:
    1,242
    Country:
    Hong Kong
    May I ask : Is there anybody who has successfully load Wii games in SD with NAND Emulation set to Game save ?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - WiiFlow,