1. Tetsuo Shima

    Tetsuo Shima GBAtemp Advanced Maniac
    Member

    Joined:
    Oct 29, 2008
    Messages:
    1,564
    Country:
    Italy
    @biggzsizzle Well at that point, if you want to have both roms and covers on the USB, why don't you just install wiiflow on usb?
    That way you won't have to change every single ini. I've never tried to have wiiflow on one partition, and covers on another one, so I don't now if it will work, however you are missing : after usb1 in your posted ini.
    Full path is possible on the romdir, however if you mantain the same folder structure, you can also leave it as before and use rompartition=1 (which is usb)
     
    biggzsizzle likes this.
  2. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,069
    Country:
    United States
    wiiflow lite 5.4.7 official coming soon. but if you can't wait then all you have to do is figure out how to get the files and folders in the OUT folder via wiiflow lite on github.

    if you move everything to usb then all you should have to do is go to main settings>game partitions and set default plugin partition to usb. you may have to do a Reload Cahe.
     
  3. biggzsizzle

    biggzsizzle GBAtemp Regular
    Member

    Joined:
    Feb 13, 2008
    Messages:
    226
    Country:
    United States
    @fledge68 @Tetsuo Shima , I love you guys^_^:D,..I don't know why that didn't dawn on me,.. I really needed a nap, been looking at it for waaaaay too long lol

    So in essence, I don't need to worry with syntax at all... just create an apps/wiiflow; wiiflow; and other directories from plugin pack, on the root of the USB, then change paths in wiiflow,..right? And change or add
    Code:
    rompartition=1
    to each .ini file?
     
    Last edited by biggzsizzle, Oct 23, 2020
  4. ch5555

    ch5555 Newbie
    Newcomer

    Joined:
    Oct 22, 2020
    Messages:
    2
    Country:
    Germany
    omg, Thank you very much! I tried to compile by myself and never looked into the out folder before.
    Thank You again :)
     
  5. OfficialRammy

    OfficialRammy Advanced Member
    Newcomer

    Joined:
    Jul 23, 2020
    Messages:
    52
    Country:
    United Kingdom
    Just move your WiiFlow to your USB and change the partition in WiiFlow to USB. Done

    EDIT - All your comments just loaded, my bad LOL
     
    Last edited by OfficialRammy, Oct 24, 2020
    biggzsizzle likes this.
  6. AdamCatalyst

    AdamCatalyst Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    45
    Country:
    Canada
    5.4.7 Beta 8 has been 100% smooth sailing for me. I know nobody asked, but sometimes I just like to see my thoughts in writing.
     
    ca032769, OfficialRammy and fledge68 like this.
  7. OfficialRammy

    OfficialRammy Advanced Member
    Newcomer

    Joined:
    Jul 23, 2020
    Messages:
    52
    Country:
    United Kingdom
    Beta 8!? @fledge68 where is this secret forum where you're releasing these beta's? lol
     
  8. AdamCatalyst

    AdamCatalyst Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    45
    Country:
    Canada
    OfficialRammy likes this.
  9. OfficialRammy

    OfficialRammy Advanced Member
    Newcomer

    Joined:
    Jul 23, 2020
    Messages:
    52
    Country:
    United Kingdom
    Thank you @AdamCatalyst

    Does anybody know if It's possible to select certain plugins to show Database Titles? For example. I'd love for it to show the Database Titles for Wii but turn them off for Sega Genesis so I can see the Brackets. Is this possible?
     
  10. AdamCatalyst

    AdamCatalyst Member
    Newcomer

    Joined:
    May 26, 2020
    Messages:
    45
    Country:
    Canada
    @fledge68 Am I seeing this right, is 5.4.7 good to go?!? Super excited, had been stuck on either 5.2, or a version that often didn't work. 5.4.7 is beautiful, and it works for me 100% of the time.
     
    fledge68 likes this.
  11. HHscumJI

    HHscumJI Newbie
    Newcomer

    Joined:
    Oct 31, 2020
    Messages:
    3
    Country:
    United States
    how do I use wiimmfi with wiiflow lite
    please give an image
     
  12. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,069
    Country:
    United States
    v5.4.7 Released!

    https://github.com/Fledge68/WiiFlow_Lite/releases/tag/v5.4.7

    changes since 5.4.6:

    - fixed using plugin dol path via the apps folder that was broken in last release.

    - fixed displaying music titles when you only have one music file in wiiflow music folder.

    - fixed saving and loading enabled plugins upon exit and startup. This stops the "no plugins selected" message upon returning to wiiflow when you previously used the Select Plugin Menu.

    - fixed custom backgrounds when using the Select Plugin Menu.

    - fixed devolution for usb only users.

    - fixed plugin system to handle more than 128 plugins. upped to 255 plugins.

    - fixed to apply game settings when autoboot a non plugin game.

    - fixed wii game booting on vwii (an issue started in 5.4.0 release). could also help with normal wii.

    - added source menu setup via controller Home button while viewing source menu. Setup includes hide buttons, link buttons to plugins, and set roms path of plugins.

    - added wiiflow/covers/homebrew_small folder so when using homebrew smallbox mode you can use your own custom covers instead of the apps icon.png

    - added option to upsample/resample music audio to 48khz. code taken from wiixplorer thanks to dimok.

    - added 'Always show main icons' option page 14 of main settings. this prevents the main screen icons from hiding.

    - added proxy support for downloading with the option to use wii's config or settings via wiiflow_lite.ini.(blackb0x)

    - fixed download timeouts & updated wolfSSL.(blackb0x)

    - organized main settings pg 10 thru 14 better.

    - now when you have only the front cover image wiiflow will use that platform's custom blank cover image for the spine and back of the cover.

    - use RiiConnect24 geckocodes archive since geckocodes.org was shutdown.

    - language updates and general code cleanup
     
  13. HHscumJI

    HHscumJI Newbie
    Newcomer

    Joined:
    Oct 31, 2020
    Messages:
    3
    Country:
    United States
    please
     
  14. retrofan01

    retrofan01 Member
    Newcomer

    Joined:
    Jan 25, 2019
    Messages:
    17
    Country:
    United Kingdom
    5.4.7 is the first version that's worked for me (on vWii) since 5.2.0. Thanks Fledge68 and devs!
     
  15. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,069
    Country:
    United States
     
    biggzsizzle likes this.
  16. troipoison

    troipoison Member
    Newcomer

    Joined:
    Apr 25, 2009
    Messages:
    14
    Country:
    Canada
    Start with a thank you for the continued development of this @fledge68
    Setup: 2 partition USB HDD both FAT32 with wbfs files on second partition. Priiloader straight to Wiiflow Lite 5.4.7
    Games running fine, usb loading fine.
    I'm not sure if this is just me, but I've been having issues downloading covers. The .ini in 5.4.7 wants to look in Wii for Wii titles, gamecube, and channels respectively, but when I placed them in those folders and ran the cache converter in PC they didn't appear.
    For troubleshooting I grabbed a single game cover to see where it wanted to be placed from the Wii via WFL.
    When I connect the HDD back to pc my boxcovers folder is empty short of the newest cover.
    I will mention that 5.4.7 cover download for wiiware didn't just empty the boxcovers folder, but place the wiiware .app titles and the cover in that folder with no subfolders.
    Not looking for a fix necessarily, I will just set up the cache and cover folders on the PC so it reads happily on the Wii, but I thought I would mention it and see if others had this issue.
    Or maybe I missed something already addressed in this thread.
     
    Last edited by troipoison, Nov 2, 2020
  17. HHscumJI

    HHscumJI Newbie
    Newcomer

    Joined:
    Oct 31, 2020
    Messages:
    3
    Country:
    United States
    I'm having the same problem.
    Please fix it ASAP
     
  18. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,069
    Country:
    United States
    you problem is very confusing.

    The .ini in 5.4.7 wants to look in Wii for Wii titles, gamecube, and channels respectively, but when I placed them in those folders and ran the cache converter in PC they didn't appear.
    It sounds like you are using the wf internal plugins pack. Those plugins are confusing you. the only thing wiiflow uses for those plugins for is the MAGIC and DISPLAYNAME. the rest are bogus, fake entries.
    when you use these plugins wiiflow see's the magic number and says Oh you don't really want a plugin list, you want a wii games list or gamecube games list or so on.
    the main purpose of those internal plugins is so you can combine wii, gc, or channel sources with plugin sources either via a source button that has magic numbers separated by commas or by using the plugin select menu found via the Home Menu.
    the coverfolder is bogus. so when you download covers for wii, gamecube, and channels they go in dev:/wiiflow/boxcovers. no subfolder is used.
    cache converter in PC? are you using wiimpathy's pc app? why when wiiflow does it for you?

    I will mention that 5.4.7 cover download for wiiware didn't just empty the boxcovers folder, but place the wiiware .app titles and the cover in that folder with no subfolders.
    why would your boxcovers folder be empty?
    dev:/wiiflow/boxcovers?
    cover download doesn't download the wiiware app titles, it downloads covers. so why would your wiiware app titles be in the same folder as the covers? which by the way you just said was empty?
     
    alexander1970 likes this.
  19. troipoison

    troipoison Member
    Newcomer

    Joined:
    Apr 25, 2009
    Messages:
    14
    Country:
    Canada
    I should have explained more of my setup. Yes to plugins - WF internal plugins pack rev4 and the Rhapsodi-Shima theme. Now that you explained it's really just about the magic numbers and the other coverfolder entries are moot, I can get my head around this.

    Yes, the WFC_conv. If I get an issue, I use a different USB HDD and create a vanilla Wiiflow setup with the covers and emulators because it is faster. I only do this for troubleshooting so along the way I can see if any of my alterations are causing whatever dilemma I may run into. I don't run WFC_conv every time I grab a cover. I'm not a psycho. And if the forums don't have an answer I'm looking for I just assume it's a monday detail I messed up.

    Empty with the exception of the cover that was just downloaded and the .app files I mentioned. I'm trying to explain this as best I can, and left assumptions that when I said 'empty' it would be taken as 'empty save for' . My apologies. FAT32 is so goddam antiquated that my finger wants to point the blame on this. I will add, in my troubleshooting steps I thought I would see how Wiiflow handled downloading a cover that belonged in a folder: ie an SNES title. This worked fine.

    I have been setting this up and getting covers and making it all pretty and functional and tweaking and updating for quite some time. When I first downloaded covers and had them cached it was back on Wiiflow rev4 era. So most of my covers were already set and stable. It was recently I decided to add some GameCube titles to my system. This is when I started looking for new covers and it was on Wiiflow 5.4.6 that I grabbed GC covers. This was the first time I saw dev:/wiiflow/boxcovers empty with only the newly downloaded covers in the folder (everything else deleted). I just figured it was the Wii being an asshole so I didn't mention it. I went and grabbed covers manually as a workaround because I didn't want to bring up something I was certain was specific to me.

    I hope I've given enough detail that you might see the resolution simply. If other people really are experiencing any of these issues I guess it is worth bringing up.

    Again, I'm not complaining, I'm totally fine setting everything up on my computer and just plugging the HDD into Wiiflow and watching it look and run beautifully. I'm just addressing it because it might be something you need to look into. You do great work and I appreciate it!
     
    Last edited by troipoison, Nov 3, 2020
  20. MrSW

    MrSW GBAtemp Regular
    Member

    Joined:
    Sep 2, 2018
    Messages:
    137
    Country:
    Brunei
    I am experiencing a weird issue with 5.4.7. Everytime I enter/exit a plugin or a source tier via the source menu, the screen goes black for what it feels like a full second before the transition is made. This doesn't happen with 5.4.7 beta 6, so it has to be something added along the way what's causing this.
     
    biggzsizzle likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - WiiFlow,