1. xLAKITUx

    xLAKITUx GBAtemp Regular
    Member

    Joined:
    Aug 19, 2011
    Messages:
    117
    Country:
    United States
    Thanks! It’s been years since I’ve done anything with the HBC version - is there a preferred way to update to a newer version?

    And looking on the HBC site, it doesn't look like much changed that would affect me from 1.1.0 to 1.1.2 -- https://www.wiibrew.org/wiki/Homebrew_Channel#1.1.2

    1.1.1 has to do with the WiiU (I'm using an original Wii) and the changes in 1.1.2 aren't really applicable either.
     
    Last edited by xLAKITUx, Sep 21, 2020
  2. RagnaRock

    RagnaRock Member
    Newcomer

    Joined:
    Aug 28, 2020
    Messages:
    20
    Country:
    United Kingdom
    Hi, I'm having a problem with WiiFlow on vWii,
    Games that use to work just stop working after exiting them. (I've creatied a bigger description here https://gbatemp.net/threads/games-stop-working-using-wiiflow-without-changing-anything.574144/ )

    Trying to play games that used to work, but now it simply goes black when i try to load the games and i need to turn the power off in order to turn off the console pressing the on/off button for a long time doesn't do anything.

    I'm loading my games from a 32gb SD card, only have 4 games actually. And Im using the latest version of WiiFlow 5.4.6 (according to the metafile)

    The games are NTSC versions and the console is PAL, but I have played them in the past and did not change any configuration.

    *Edit*
    In dispair I changed the cIOS to 251 (base 58, instead of 250 base 57) and it worked.
    I dont get it... I tested it on 250 before

    *Edit 2*
    Something is odd, Ghost Squad stopped working again, this time I've set the video mode to NTSC and it started working again.
    For some reason out of nowhere configurations stop working, then I change one and it starts working again... lets see how long it will last...

    *Edit 3*
    Ghost Squad doesn't work anymore...

    As a way to try to give my full details here is my system check:

    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on vIOS58 (rev 6432).

    Region: PAL
    System Menu 4.3E (v610)

    Drive date: 06.28.2011
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x21
    Console ID: 612923357
    Console Type: vWii
    Shop Channel Country: United Kingdom (110)
    Boot2 v0
    Found 58 titles.
    Found 37 IOS on this console. 0 of them are stubs.

    vIOS9 (rev 1290): No Patches
    vIOS12 (rev 782): No Patches
    vIOS13 (rev 1288): No Patches
    vIOS14 (rev 1288): No Patches
    vIOS15 (rev 1288): No Patches
    vIOS17 (rev 1288): No Patches
    vIOS21 (rev 1295): No Patches
    vIOS22 (rev 1550): No Patches
    vIOS28 (rev 2063): No Patches
    vIOS31 (rev 3864): No Patches
    vIOS33 (rev 3864): No Patches
    vIOS34 (rev 3864): No Patches
    vIOS35 (rev 3864): No Patches
    vIOS36 (rev 3864): No Patches
    vIOS37 (rev 5919): No Patches
    vIOS38 (rev 4380): No Patches
    vIOS41 (rev 3863): No Patches
    vIOS43 (rev 3863): No Patches
    vIOS45 (rev 3863): No Patches
    vIOS46 (rev 3863): No Patches
    vIOS48 (rev 4380): No Patches
    vIOS53 (rev 5919): No Patches
    vIOS55 (rev 5919): No Patches
    vIOS56 (rev 5918): No Patches
    vIOS57 (rev 6175): No Patches
    vIOS58 (rev 6432): USB 2.0
    vIOS59 (rev 9249): No Patches
    vIOS62 (rev 6942): No Patches
    vIOS80 (rev 7200): No Patches
    vIOS249[56] (rev 21010, Info: d2x-v10beta52-vWii): NAND Access, USB 2.0
    vIOS250[57] (rev 21010, Info: d2x-v10beta52-vWii): NAND Access, USB 2.0
    vIOS251[58] (rev 21010, Info: d2x-v10beta52-vWii): NAND Access, USB 2.0
    vIOS252[56] (rev 21010, Info: d2x-v10beta53-alt-vWii): NAND Access, USB 2.0
    vIOS253[57] (rev 21010, Info: d2x-v10beta53-alt-vWii): NAND Access, USB 2.0
    vIOS255[58] (rev 21010, Info: d2x-v10beta53-alt-vWii): NAND Access, USB 2.0
    vIOS512 (rev 7): No Patches
    vIOS513 (rev 1): No Patches
    Report generated on 09/20/2020.

    Anyone that can bring some light to this issue, how come the games work and then stop working?
     
  3. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,022
    Country:
    United States
    wiiflow lite v5.4.7 beta 6 - http://www.mediafire.com/file/sl7wylrxzm4529x/wfl+5.4.7+beta+6.zip/file

    new changes:
    1. @blackb0x added support for those of you who use proxy settings for their wifi connection. on main settings page 14 you can choose to use the wii's system proxy settings or set them manually in wiiflow_lite.ini
    in wiiflow_lite.ini you will need to add (if not already there) the following.

    [PROXY]
    proxy_use_system=yes
    proxy_address=
    proxy_username=
    proxy_password=

    any questions about this please tag him in the message cause he know more about it than i do.

    2. he also updated wolfssl

    3. blackb0x also solved an issue with vwii users launching games with the latest versions of wiiflow lite. @xLAKITUx i know you are on wii but this may also help you with launching emunand games. updating HBC isn't necessary but it's always good to have the latest build. i do recommend using force cios ON and the cios either AUTO or 249 but other slots may work depending on the cios you have installed.

    4. fixed the Source Menu page button when hiding buttons. the count was off by one so sometimes the page button said there was another page when there really wasn't.

    5. fixed a minor issue when changing a plugins rom dir but then exiting the source menu via B button without selecting a source, it wouldn't reload the current coverflow but now it does.

    @RagnaRock a while back in 5.4.4 and 5.46 @blackb0x changed video settings for PAL games. maybe this is your problem. also his vwii fix might also apply to you.
     
  4. RagnaRock

    RagnaRock Member
    Newcomer

    Joined:
    Aug 28, 2020
    Messages:
    20
    Country:
    United Kingdom
    Making it Pal 60hz solved it for now. The thing is in the past changing it to NTSC also solved it... then after a while it stoped working. So Im no longer confident. but time will tell.

    One Question, why WiiFlow doesnt let us set the cIOS slot 255 ? I installed a cIOS there but now i cant use it :s
     
  5. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,022
    Country:
    United States
    i"m not even sure how you managed to install a cios in slot 255. I do know that slot 254 is used for the bootmii IOS when it's installed as a IOS. I guess everyone (passed wii HB devs) just figured to go from 200 to 253.
     
  6. RagnaRock

    RagnaRock Member
    Newcomer

    Joined:
    Aug 28, 2020
    Messages:
    20
    Country:
    United Kingdom
    Well... I just used the dx2 cIOS installer, and that option was available so I used it (I thought i could only use from 249 upwards at the time...) I wonder if that might be causing me issue, is there a way to reset it? (because i only see the option to override, not to delete)
     
  7. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,022
    Country:
    United States
    just leave it. it shouldn't cause an issue. but i thought the d2x cios installer had an option to uninstall. i could be wrong.
     
  8. xLAKITUx

    xLAKITUx GBAtemp Regular
    Member

    Joined:
    Aug 19, 2011
    Messages:
    117
    Country:
    United States
    Awesome. I'll put it on my to-do list to upgrade to the latest WFL version and change those settings.

    Follow-up question - I feel really noobish asking this, but here goes... What's the most efficient way to upgrade to the latest version of HBC?
     
  9. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,022
    Country:
    United States
    go here to download the hackmii installer - https://bootmii.org/download/

    the only thing you want/need is the boot.elf.
    since you already have HBC just create a folder named hbc installer in your apps folder. so dev/apps/hbc installer and put the boot.elf in there. leave it as an elf file.
    now launch your current HBC and choose hbc installer. follow the prompts. you shouldn't have to use bootmii to back up your nand and don't need dvdx if it asks, i don't think it does anymore.
     
    xLAKITUx likes this.
  10. blackb0x

    blackb0x GBAtemp Regular
    Member

    Joined:
    Apr 22, 2019
    Messages:
    135
    Country:
    United Kingdom
    Yea, but it's limited to patching PAL Wii games and it looks like @RagnaRock is using NTSC games.

    I'd suggest resetting all video settings to their defaults and checking that the SD card is FAT32 and has the cluster size set to 32KB. And should that still not work maybe it'd be worth trying a different SD card? I've seen similar issues in the past and changing the SD card or USB HDD normally fixes the issue.
     
    alexander1970 and Hakaisha like this.
  11. biggzsizzle

    biggzsizzle GBAtemp Regular
    Member

    Joined:
    Feb 13, 2008
    Messages:
    130
    Country:
    United States
    I need to know more of this "proxy setting",...Is this something useful for the WFC? or what??
    I try to follow this thread religiously but I guess I missed something along the way lol

    **SIDE NOTE** Had a friend ask me why couldn't WiiFlow access/pull/load games from a URL (filehost or otherwise)?? My only reply was, "Because, this is how it is!" now, it's bugging me, lol
     
    Last edited by biggzsizzle, Sep 22, 2020
  12. RagnaRock

    RagnaRock Member
    Newcomer

    Joined:
    Aug 28, 2020
    Messages:
    20
    Country:
    United Kingdom
    Is there any official page or wiki for wiiflow? there are so many configurations, but i don't know where to find the documentation for each bit.
     
  13. xLAKITUx

    xLAKITUx GBAtemp Regular
    Member

    Joined:
    Aug 19, 2011
    Messages:
    117
    Country:
    United States
    As always, thanks for the guidance.

    Updated to the latest WFL beta version, upgraded HBC to 1.1.2, and turned on Force Load CIOS on Startup (For now, I'm leaving CIOS: Auto)

    In my very limited testing, things look great. It may be placebo effect, but I could swear that my menu browsing is smoother and games launch faster. (Again - This could all be in my head, but it could be true!) Thanks for all your help. This box is an absolute beast. Maybe sometime soon I can stop tweaking settings and adding new games, and (crazy idea) play the Wii?
     
    biggzsizzle likes this.
  14. blackb0x

    blackb0x GBAtemp Regular
    Member

    Joined:
    Apr 22, 2019
    Messages:
    135
    Country:
    United Kingdom
    It's for people who can't download covers or cheats because they're on a restricted network.

    More info @ https://github.com/Fledge68/WiiFlow_Lite/issues/195
     
    biggzsizzle and alexander1970 like this.
  15. biggzsizzle

    biggzsizzle GBAtemp Regular
    Member

    Joined:
    Feb 13, 2008
    Messages:
    130
    Country:
    United States
    So this idea doesn't actually exist then, correct??
     
  16. fledge68

    OP fledge68 GBAtemp Addict
    Member

    Joined:
    Jan 30, 2012
    Messages:
    2,022
    Country:
    United States
    no it doesn't.
     
    biggzsizzle likes this.
  17. biggzsizzle

    biggzsizzle GBAtemp Regular
    Member

    Joined:
    Feb 13, 2008
    Messages:
    130
    Country:
    United States
    with the new beta, I'm getting ever other game, not returning to WiiFlow when exiting,...just a black screen and wiimotes stay connected
     
  18. DRLugawi

    DRLugawi Newbie
    Newcomer

    Joined:
    Sep 25, 2020
    Messages:
    1
    Country:
    Canada
    I have question. whats the image database do you use for the wii (and other) 3d modeled box art
     
  19. DRLugawi
    This message by DRLugawi has been removed from public view by Flame, Sep 25, 2020.
    Sep 25, 2020
  20. DRLugawi
    This message by DRLugawi has been removed from public view by Flame, Sep 25, 2020.
    Sep 25, 2020
  21. ca032769

    ca032769 GBAtemp Fan
    Member

    Joined:
    Jan 11, 2012
    Messages:
    457
    Country:
    United States
    Wii Backup Manager should scan what is on your drive or SD Card and automatically download them for you.

    Here's a link that should help: https://www.gametdb.com/Wii/Downloads
     
  22. bbq_bob

    bbq_bob Newbie
    Newcomer

    Joined:
    Sep 14, 2009
    Messages:
    8
    Country:
    United States
    Has anyone been able to get the latest WiiFlow Lite 5.4.7 beta 6 to play Wiiware games? When I try, the screen turns black and then Wiiflow starts again with the Wiiflow logo. I haven't been able to get a single game to work. Has anyone been successful?

    Are there other steps beyond using WiiFlow Lite to dump the NAND to a USB HDD and then using the Wiiflow Lite setting to load a WAD? I have all of the NAND options set to Full.

    I've also tried using ShowMiiWads in ShowMiiNands mode to add wiiware and virtual console games. What else should I check or do?

    Wii U
    Haxchi
    vwii running WiiFlow 5.4.7 beta6
    Gamecube, Wii, and NAND with Wiiware games on 500 GB WD USB drive formatted with FAT32 32K
    Gamecube and Wii games work fine
    Wiiflow has WiiFlow Plugins Pack
    d2x-v10beta52-vWii

    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline Double_A R2-D2199 and Nano
    ...runs on vIOS58 (rev 6432).

    Region: NTSC-U
    System Menu 4.3U (v609)

    Drive date: 07.12.2012
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x21
    Console ID: 615928460
    Console Type: vWii
    Shop Channel Country: United States (49)
    Boot2 v0
    Found 63 titles.
    Found 35 IOS on this console. 0 of them are stubs.

    vIOS9 (rev 1290): No Patches
    vIOS12 (rev 782): No Patches
    vIOS13 (rev 1288): No Patches
    vIOS14 (rev 1288): No Patches
    vIOS15 (rev 1288): No Patches
    vIOS17 (rev 1288): No Patches
    vIOS21 (rev 1295): No Patches
    vIOS22 (rev 1550): No Patches
    vIOS28 (rev 2063): No Patches
    vIOS31 (rev 3864): No Patches
    vIOS33 (rev 3864): No Patches
    vIOS34 (rev 3864): No Patches
    vIOS35 (rev 3864): No Patches
    vIOS36 (rev 3864): No Patches
    vIOS37 (rev 5919): No Patches
    vIOS38 (rev 4380): No Patches
    vIOS41 (rev 3863): No Patches
    vIOS43 (rev 3863): No Patches
    vIOS45 (rev 3863): No Patches
    vIOS46 (rev 3863): No Patches
    vIOS48 (rev 4380): No Patches
    vIOS53 (rev 5919): No Patches
    vIOS55 (rev 5919): No Patches
    vIOS56 (rev 5918): No Patches
    vIOS57 (rev 6175): No Patches
    vIOS58 (rev 6432): USB 2.0
    vIOS59 (rev 9249): No Patches
    vIOS62 (rev 6942): No Patches
    vIOS80 (rev 7200): No Patches
    vIOS236 (rev 65535): Trucha Bug ES Identify NAND Access
    vIOS249[56] (rev 21010 Info: d2x-v10beta52-vWii): Trucha Bug NAND Access
    vIOS250[57] (rev 21010 Info: d2x-v10beta52-vWii): Trucha Bug NAND Access
    vIOS251[58] (rev 21010 Info: d2x-v10beta52-vWii): Trucha Bug NAND Access
    vIOS512 (rev 7): No Patches
    vIOS513 (rev 1): No Patches
    Report generated on 09/17/2020.

    thanks for any help
     
  23. blackb0x

    blackb0x GBAtemp Regular
    Member

    Joined:
    Apr 22, 2019
    Messages:
    135
    Country:
    United Kingdom
  24. RunningSnakes

    RunningSnakes GBAtemp Fan
    Member

    Joined:
    Jun 21, 2018
    Messages:
    324
    Country:
    United States
    I can confirm all is working on my side using 5.4.7 beta 6 on Wii.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - WiiFlow,