1. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Yes the WW and VC games runs fine if i enable 'boot with neek2o'. It boots up with 'Dsi Exception Occurred' if i dont enable it. I prefer not to run every WW and VC wiith neek2o :(
     
  2. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    Neek2o doesnt use a cios but the other way does. Sounds to me like you need to post a syscheck. You might be using the wrong cios.
     
    KaiFun4Ever likes this.
  3. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Last edited: Nov 9, 2019
  4. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    looking at your syscheck. it's ok for the most part.
    You should get rid of all those d2x v9 cios. v9 had issues and that's why its not even included as a official release on the d2x github project.
    d2x base 57 in slot 250 is the recommended one to use now.

    next thing to try.
    open wiiflow_lite.ini with a text editor (notepad++)
    under [DEBUG] set write_sd_log=yes and save

    now run wiiflow and try to launch a game without neek2o.
    you should now have wiiflow.log file on the root of sd card.
    copy and paste it here for me to see.
     
    KaiFun4Ever and Hakaisha like this.
  5. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Ok here is my debug log. I did noticed my console dvd drive flashes once before popping out the error.

    Welcome to WiiFlow WFL 5.3.0 beta 8!
    This is the debug output.
    Real Wii
    AHBPROT disabled = yes
    IOS58 v6176
    patched isfs_permissions 1 times.
    patched es_setuid 1 times.
    patched es_identify 1 times.
    patched hash_check 0 times.
    patched new_hash_check 1 times.
    Init ISFS
    Found WiiFlow Save
    Loading IOS Settings from wiiflow save
    Reloading into IOS 250 from 58...
    Deinit ISFS
    AHBPROT disabled after IOS Reload: yes
    patched isfs_permissions 0 times.
    Init ISFS
    D2X IOS250[57] v10
    FAT Partition at sd: mounted.
    Changing USB port to port 0....
    * * * * * * * * * * * *
    * HDD Information
    * Sectors: 976717823
    * Size [Sector Size]: 465 GB [512]
    * * * * * * * * * * * *
    FAT Partition at usb1: mounted.
    Running sound thread
    Wiiflow boot.dol Location: sd:/apps/wiiflow
    Data Directory: sd:/wiiflow
    Wii Games Directory: %s:/wbfs
    Nintendont found
    GameCube Games Directory: %s:/games
    Loading cIOS map
    Found cIOS in slot 222
    Found cIOS in slot 223
    Found cIOS in slot 224
    Found cIOS in slot 225
    Found d2x base 37 in slot 244
    Found d2x base 38 in slot 245
    Found d2x base 53 in slot 246
    Found d2x base 55 in slot 247
    Found d2x base 57 in slot 248
    Found d2x base 56 in slot 249
    Found d2x base 57 in slot 250
    Found d2x base 58 in slot 251
    Setting Wii games partition to: 1
    emu nand path = sd:/nands/default
    saves nand path = sd:/nands/default
    Bootup completed!
    Creating Gamelist
    Adding wii list
    Games found: 11
    Displaying covers
    Creating Gamelist
    Adding emu nand list
    Invalid signature found, banner not valid
    Games found: 10
    Displaying covers
    Update Play log
    Launching game WGOE
    from emu nand
    Requested Game IOS: 35
    Dumping: /shared2/sys/SYSCONF (17kb)... done!
    Dumping: /title/00000001/00000002/data/setting.txt (1kb)... done!
    Dumping: /shared2/menu/FaceLib/RFL_DB.dat (762kb)... done!
    Game ID WGOE requested IOS 35.
    User selected 250
    Changed requested IOS to 250.
    Return to channel DWFA using d2x succeeded.
     
  6. Wiimpathy

    Wiimpathy GBAtemp Advanced Fan
    Member

    Joined:
    Mar 3, 2010
    Messages:
    786
    Country:
    France
    Ok, here's probably the most useless WiiFlow related tool :lol::

    WFC2PNG

    Source code

    It's a PC tool to convert WiiFlow cache file(wfc) back to a PNG.
    Now, you could ask why this stuff?
    First, some time ago, I realized I've lost some of the original boxcovers in png. Some of them were custom ones I've made. I only had the corresponding wfc files...

    So the good news is that it's now possible to restore the images. However, by default we all use compressed textures I guess. And it's a lossy format derived from DXT1 compression.

    The other reason was just curiosity. I wanted to know more about those textures and image processing in general. There may be mistakes or issues... The cmpr decoding algorithm was taken and adapted from various c# projects. I don't know who wrote it first but thanks!
     
    Last edited: Nov 10, 2019
  7. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    I see a couple of things.

    1. Why does Invalid signature found, banner not valid appear while wiiflow is creating the emu nand list? That message should only appear when you have selected a emu nand game and wiiflow is trying to get its banner. really odd that message is right there.

    2. it ends right after Return to channel DWFA using d2x succeeded. there should be messages about patching the IOS and getting the TMD and fake signing.

    Is there any possiblity in the game settings you have the option custom set to ON or YES? That would explain why i don't see those messages in #2 and would also explain why you get the DSI crash.

    set custom to NO or OFF.
    also you might need to change the 'boot apploader' option. by default its OFF but you could always try setting it to ON.
     
  8. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    I dont understand the banner part. U mean the banner that is displayed on top right corner when i select a game? If thats so, the game banner is displaying fine.

    Yup the debug log ended there. Im not sure what that last message is about.

    The custom setting is always off. I didnt mess with that as i dont know what it does. I tried running the game with boot apploader ON but still same DSI error. I tried messing with those 2 settings but nothing works :(
    IMG_20191111_104016.jpg
     
  9. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    ok so yes i was talking about the banner in upper right. it's weird that - Invalid signature found, banner not valid - shows up in the wiilog there. it shouldve been down next to playlog update.

    anyway, so I've come to 2 conclusions.
    1. Invalid signature found, banner not valid - makes me wonder if there is something wrong or invalid with your games wad when you installed it in your emu nand. yet neek2o runs it. maybe neek2o is region free or somehow ignores whatever makes it invalid.

    2. since we see no further gecko messages. I'm assuming when wiiflow enabled your emu nand it unmounted all devices including your SD card. it does mount them all again but maybe your sd card isn't getting mounted. and thus no more messages and the DSI crash since your emu nand is on SD. i've had a couple of other users with SD mounting issues. whereas in v5.2.0 release it works for them and yet in v5.3.0 beta's i have done nothing to change SD mounting.

    So what you can do is move your nands folder from SD to USB. run wiiflow and change emu nand partition to USB and then in emunand settings make sure you still have your nand (default) selected. go back to main screen and it should do reload cache and show your covers. then try to launch your game. make sure custom and apploader are off.
     
    KaiFun4Ever likes this.
  10. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Changing the emunand partition to usb1 in wiiflow menu settings doesnt take effect. I have to set it to 1 in wiiflow.ini. The game wads should be fine. Its USA region. I got it from mariocube. The only settings i changed in my neek2o is region free hack ON.

    So i tried running the game on usb1 without neek2o. Same DSI error. But now i noticed there is more info in the debug log for some reason. I dont see the invalid signature and banner message this time. Take a look. Im beginning to wonder if my Wii is faulty :( In the meantime i try mess around more a bit. Thanks.

    Welcome to WiiFlow WFL 5.3.0 beta 8!
    This is the debug output.
    Real Wii
    AHBPROT disabled = yes
    IOS58 v6176
    patched isfs_permissions 1 times.
    patched es_setuid 1 times.
    patched es_identify 1 times.
    patched hash_check 0 times.
    patched new_hash_check 1 times.
    Init ISFS
    Found WiiFlow Save
    Loading IOS Settings from wiiflow save
    Reloading into IOS 250 from 58...
    Deinit ISFS
    AHBPROT disabled after IOS Reload: yes
    patched isfs_permissions 0 times.
    Init ISFS
    D2X IOS250[57] v10
    FAT Partition at sd: mounted.
    Changing USB port to port 0....
    * * * * * * * * * * * *
    * HDD Information
    * Sectors: 976717823
    * Size [Sector Size]: 465 GB [512]
    * * * * * * * * * * * *
    FAT Partition at usb1: mounted.
    Running sound thread
    Wiiflow boot.dol Location: sd:/apps/wiiflow
    Data Directory: sd:/wiiflow
    Wii Games Directory: %s:/wbfs
    Nintendont found
    GameCube Games Directory: %s:/games
    Loading cIOS map
    Found cIOS in slot 222
    Found cIOS in slot 223
    Found cIOS in slot 224
    Found cIOS in slot 225
    Found d2x base 37 in slot 244
    Found d2x base 38 in slot 245
    Found d2x base 53 in slot 246
    Found d2x base 55 in slot 247
    Found d2x base 57 in slot 248
    Found d2x base 56 in slot 249
    Found d2x base 57 in slot 250
    Found d2x base 58 in slot 251
    Setting Wii games partition to: 1
    emu nand path = usb1:/nands/default
    saves nand path = usb1:/nands/default
    Bootup completed!
    Creating Gamelist
    Adding emu nand list
    Games found: 11
    Displaying covers
    Creating Gamelist
    Adding emu nand list
    Games found: 11
    Displaying covers
    Update Play log
    Launching game WGOE
    from emu nand
    Requested Game IOS: 35
    Dumping: /shared2/sys/SYSCONF (17kb)... done!
    Dumping: /title/00000001/00000002/data/setting.txt (1kb)... done!
    Dumping: /shared2/menu/FaceLib/RFL_DB.dat (762kb)... done!
    Game ID WGOE requested IOS 35.
    User selected 250
    Changed requested IOS to 250.
    Return to channel DWFA using d2x succeeded.
    FAT Partition at sd: unmounted.
    FAT Partition at usb1: unmounted.
    Device: USB 2.0 Mass Storage Device
    Enabling NAND Emulator... OK!
    FAT Partition at sd: mounted.
    Changing USB port to port 0....
    * * * * * * * * * * * *
    * HDD Information
    * Sectors: 976717823
    * Size [Sector Size]: 465 GB [512]
    * * * * * * * * * * * *
    FAT Partition at usb1: mounted.
    Cleanup Coverflow
    Stopping sound thread
    Stopped sound thread
    MEM1_freesize(): 9117680
    MEM2_freesize(): 40008320
    patched isfs_permissions 0 times.
    patched es_setuid 0 times.
    patched es_identify 0 times.
    patched hash_check 0 times.
    patched new_hash_check 0 times.
    Reading TMD for 00010001 57474f45...Success!
    Generating fake ticket...Success!
    Reading certs...Success!
    ES_Identify
    AHBPROT: 1, Key ID: 12
     
    Last edited: Nov 11, 2019
  11. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    great! we made it a lot further. although i'm confused as to why you couldn't switch to usb partition. but editing the ini worked.

    now I need you to show me all the settings you have for that game. easiest way is to take a snapshot of each page with Z button on nunchuck or gc controller and post the snapshots here.
     
  12. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Screenshots below. The only setting that i changed for that game is setting the ios to 250.
     

    Attached Files:

  13. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    more questions:

    1. what about in main settings? page 3 - default language and video mode? what are they set to?
    2. when you view your emu nand channels go to home menu and do reload cache please.
    3. when you launch the game after the wiiflow animated logo disappears do you see the quick little white progress bar at the bottom? and how far does it get?
    4. does turning apploader ON help?
     
  14. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Default video mode is 'Game'. Default game language is 'Default'. Do u need me to screenshot other wiiflow settings?

    I reloaded the cache. Tried with apploader ON still same error. Of all the testing i never saw the white progress bar. Its just wiiflow animated logo and then straight to DSI error.
     
  15. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    i'm assuming you can launch wii games?
     
  16. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Yes wii games work fine on usb hdd even other region games. Launching gamecube games with nintendont on sd card also no problem.
     
  17. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    i'm about to run out of ideas.

    but what do you have emu nand emulation set on? full or partial?
    also in emu nand settings set 'use real nand config and miis' to NO or OFF.

    also have you tried any other wiiware games? i seen one report that world of goo requires neek2o but other times it doesn't.

    if none of that works im at a loss.
     
    KaiFun4Ever likes this.
  18. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    Nand Emulation 'Full'. Select Saves Nand 'Default'. Saves Nand Emulation 'Off'. Use Real Nand Config & Miis both 'On'.

    Its fine. If else fails, i can rely on neek2o for WW & VC. The only other emunand game i tested is a VC game Super Mario 64. I will test more of those games later and report back here.

    I bought this used wii as a distraction. Having hard times lately. For some reason i spend more time setting it up and testing games than actually playing the games. Usually ended up having more games than time to play it. Well as long as i have the mood for it, at least this is something to keep me occupied :')
     
    Tetsuo Shima and fledge68 like this.
  19. KaiFun4Ever

    KaiFun4Ever Member
    Newcomer

    Joined:
    Oct 26, 2019
    Messages:
    33
    Country:
    Malaysia
    So... After various testing i gave up on running emunand games with cios. I have to boot with neek2o everytime for ww & vc as it runs fine.

    Tested a few more emunand games like Adventure Island, Burger Time WT, Contra Rebirth still with DSI error. Tested the games on real nand it runs fine. Reverted WFL to 5.2.0 same error. Created a fresh emunand via modmii doesnt help. Tried Hermes cios same error but it auto reboots. Tried running the games with usb loader gx completely black screen. Also i realized i cant even run native channels like Mii Channel on cios emunand.
     
  20. fledge68

    OP fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,745
    Country:
    United States
    contra rebirth is one of those games that requires neek2o.

    interesting that they didn't work in usb loader gx either.

    native channels on wiiflow require you to turn on the 'custom' setting. same for launching a forwarder on real nand via wiiflow - custom must be on.
     
    KaiFun4Ever likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - WiiFlow,