Weird things after I moved to another SD card

Discussion in '3DS - Flashcards & Custom Firmwares' started by Seepy, Mar 27, 2016.

  1. Seepy
    OP

    Seepy Member

    Newcomer
    24
    4
    Mar 24, 2016
    Hi GBATemp,

    So I've recently moved my custom firmware setup from a 16GB SD card to a 64GB MicroSD card + Adapter for my o3DS and I'm noticing some weird things on this new card.

    The method I tried to use initially was use EmuNAND Tool to make a copy of my existing emunand and inject that onto the new SD card with a formatted emunand on it. However each time I would format the emunand on the MicroSD card, the EmuNAND tool would say it can't find an emunand partition on the card. I used EmuNAND9 to create the partition.

    To circumvent this, I then used Decrypt9 to manually reinsert a copy of my emuNAND onto the new SD card. After this, I moved all the files across to the new SD card. Upon boot, I noticed I had lost CTRBoot Manager and I simply reinstalled it.

    The weird thing about the transfer is that it seems like it takes significantly longer to load into custom firmware. The other weird thing is that EmuNAND Tool does not recognise my SD card as having an EmuNAND partition. It makes me wonder whether or not this new SD card is setup as it should be and is operating correctly.

    I am afraid to move onto the next step of installing arm9loaderhax with this SD card due to the above concerns. Could someone please clarify whether or not this behavior is normal?

    EDIT: Could this be the reason?
    [​IMG]

    EDIT 2: It seems like the latest version of emunand9 formats the emunand differently to earlier iterations. emunand9 now allows partition managers to more accurately read the partition. The difference in partition organization explains why EmuNAND tool does not recognize the partition. Solved
     
    Last edited by Seepy, Mar 27, 2016
  2. GothicIII

    GothicIII GBAtemp Advanced Fan

    Member
    506
    137
    Jan 4, 2015
    Gambia, The