WAD Manager Error ret = -1

Discussion in 'Wii - Hacking' started by grcd, Mar 4, 2010.

Mar 4, 2010

WAD Manager Error ret = -1 by grcd at 9:34 PM (3,224 Views / 0 Likes) 8 replies

  1. grcd
    OP

    Newcomer grcd Member

    Joined:
    Sep 14, 2009
    Messages:
    18
    Country:
    United Kingdom
    I am not sure exactly when this problem occured first. I know that I sucesfully installed the latest CIOS, and this was pretty much the only major change I did to my Wii as far as I can tell. I realized the problem when I tried to install a forwarder WAD using WAD Manager. I received an error ret = -1 with no other specifics.

    I assumed it was a one-off, or a broken WAD. Surprisingly though, no other WAD installations work, even for WADs that have definately worked for me in the past.

    It is also seemingly hard to uninstall WADs, because I get the same error (though I have only tried uninstalling the 'corrupt' forwarder, and I don't want to uninstall any currently working WAD out of fear I may be losing functionality that I can't replace).

    Can anyone help me? I suspect CIOS here, but then again I don't understand why this happened.

    Any help for a solution? I have a full NAND dump, but I have a fear that it might have been taken just few minutes AFTER the installation of CIOS, and the other working back-up was taken several months ago so it would not be much help.
     
  2. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    Reinstall cIOS rev18 with IOS38 as a base and use WAD Manager 1.6
     
  3. azoreseuropa

    Member azoreseuropa GBAtemp Psycho!

    Joined:
    Nov 6, 2002
    Messages:
    4,497
    Location:
    I am deaf and live in the USA for now :D
    Country:
    Portugal
    Wait a minute.. there is wad manager 1.6 ? But it is a beta right now ??

    EDIT: Should I go with cIOS rev 18 ? Any problems ? I am using cIOS rev 14 for a long time.
     
  4. grcd
    OP

    Newcomer grcd Member

    Joined:
    Sep 14, 2009
    Messages:
    18
    Country:
    United Kingdom
    Thank you very much! I always know there is a solution to any problem [​IMG] This forum is just made of win!

    Perhaps this topic can help others who have a similar problem! Why and how did the new CIOS messed the use of the old WAD Manager? And what difference did choosing rev18 with IOS38? I had chosen another one at random, because this choice was not explained.
     
  5. chartube12

    Member chartube12 GBAtemp Addict

    Joined:
    Mar 3, 2010
    Messages:
    2,727
    Country:
    United States
    i went back to rev 17 to use wad manager.

    speaking of wad manager, it needs an update button! i been using 1.4, didnt know it was up to 1.6!
     
  6. azoreseuropa

    Member azoreseuropa GBAtemp Psycho!

    Joined:
    Nov 6, 2002
    Messages:
    4,497
    Location:
    I am deaf and live in the USA for now :D
    Country:
    Portugal
    Anybody ? [​IMG]
     
  7. grcd
    OP

    Newcomer grcd Member

    Joined:
    Sep 14, 2009
    Messages:
    18
    Country:
    United Kingdom
    No major problems so far, but indeed some things seem to be broken.. though it could just be me. Configurable USB Loader seems to fail to boot? I don't understand why, USB Loader GX still runs perfectly. But maybe this is because of something else...
     
  8. OJClock

    Member OJClock GBAtemp Regular

    Joined:
    Oct 4, 2008
    Messages:
    130
    Country:
    United States
    I was having the same issue, then when I use wadmanager 1.6, it gives me the ret = -1035 error [​IMG]
    this could probably be an issue because of cioscorp interference :S
    I'm going to try out uninstalling cios 18 tomorrow and i'll tell you how it goes
     
  9. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    cIOSCORP shouldn't have anything to do with it.
    Actually, shouldn't is an understatement. the right term is can't
     

Share This Page