Homebrew USB1 (Non-HDD Port) Not Working with Full EmuNAND and USBLoaderGX

Malarkeyzone

New Member
OP
Newbie
Joined
Jan 30, 2021
Messages
4
Trophies
0
Age
22
XP
33
Country
United States
Hi! New softmodder here. Trying to play Beatles Rock Band DLC tracks via emuNAND and USBLoaderGX, and I had to change the cIOS in GX’s settings from 249 to 250 in order for it to recognize the DLC. It works great with my Guitar Hero controller, but I need the other (non-HDD) USB port in order to use rock band instruments with their USB receivers. Any suggestions on how to re-enable that second port? (Wii is 4.3U, using d2x cIOS v10 beta 52 on 249/250).
 
  • Like
Reactions: Alexander1970

Alexander1970

XP not matters.
Member
Joined
Nov 8, 2018
Messages
14,854
Trophies
3
Age
52
Location
Austria
XP
675
Country
Austria
Hello.
Welcome to the Wii Zone.:yaywii:

Hi! New softmodder here. Trying to play Beatles Rock Band DLC tracks via emuNAND and USBLoaderGX, and I had to change the cIOS in GX’s settings from 249 to 250 in order for it to recognize the DLC. It works great with my Guitar Hero controller, but I need the other (non-HDD) USB port in order to use rock band instruments with their USB receivers. Any suggestions on how to re-enable that second port? (Wii is 4.3U, using d2x cIOS v10 beta 52 on 249/250).

Do you maybe have tried an USB Hub ?
My personal Experience with an "Hub" for Rockband Games is not so bad.:D
https://gbatemp.net/threads/getting-rock-band-to-work-on-softmodded-wii.580875/

Thank you.:)
 
  • Like
Reactions: jeannotte

Alexander1970

XP not matters.
Member
Joined
Nov 8, 2018
Messages
14,854
Trophies
3
Age
52
Location
Austria
XP
675
Country
Austria
Thank you.:)

Thanks for the advice! Unfortunately I tried a hub and it gave me problems recognizing even the HDD
The HDD was attached "untouched" in Port 0.
The USB Hub was plugged in Port 1.
You maybe read in the Thread/Link I have posted,the Test sysCheck/Setup.so you have maybe noticed,no bigger Changes was needed to use the Second Port.:)

As you see,that one I have tried was an cheap,chinese No Name Card Reader with USB Ports.:D
Maybe "good" Hubs has Issues...
I think it has also to do with the Equipment,I had the "Luck" to get an original Rockband.

Was worth a try,I am sorry you had no Luck with this....:(

Also if yo do not have an SNEEK/Neek2o Setup,you do not need "Full emuNAND" only Partial.:)
(I presume for Savegames on SD Card ? :unsure:)
 
  • Like
Reactions: jeannotte

Malarkeyzone

New Member
OP
Newbie
Joined
Jan 30, 2021
Messages
4
Trophies
0
Age
22
XP
33
Country
United States
Thank you.:)


The HDD was attached "untouched" in Port 0.
The USB Hub was plugged in Port 1.
You maybe read in the Thread/Link I have posted,the Test sysCheck/Setup.so you have maybe noticed,no bigger Changes was needed to use the Second Port.:)

As you see,that one I have tried was an cheap,chinese No Name Card Reader with USB Ports.:D
Maybe "good" Hubs has Issues...
I think it has also to do with the Equipment,I had the "Luck" to get an original Rockband.

Was worth a try,I am sorry you had no Luck with this....:(
I’ll try that! I’ll add that I had no problems playing with my default cIOS settings at 249, it just wouldn’t load the DLC files in but all the USB connections worked great. That’s the main diff between me an the people in these other threads, since I need working emunand to get those files. I’ll try with the instruments in the hub on the second port and lyk! Thanks again :)
 
  • Like
Reactions: Alexander1970

Alexander1970

XP not matters.
Member
Joined
Nov 8, 2018
Messages
14,854
Trophies
3
Age
52
Location
Austria
XP
675
Country
Austria
I’ll try that! I’ll add that I had no problems playing with my default cIOS settings at 249, it just wouldn’t load the DLC files in but all the USB connections worked great. That’s the main diff between me an the people in these other threads, since I need working emunand to get those files. I’ll try with the instruments in the hub on the second port and lyk! Thanks again :)

Ah,I see,thank you.
Maybe our rocking Friend @HarvHouHacker have an Idea for this.:)

Good Luck
Thank you.:)
 

HarveyHouston

The Christian Who Hacks Stuff
Member
Joined
Mar 24, 2019
Messages
1,233
Trophies
2
Location
The Point of Know Return
Website
gitlab.com
XP
928
Country
United States
(Doing my best Lurch impression) You rang?
Trying to play Beatles Rock Band DLC tracks via emuNAND and USBLoaderGX, and I had to change the cIOS in GX’s settings from 249 to 250 in order for it to recognize the DLC. It works great with my Guitar Hero controller, but I need the other (non-HDD) USB port in order to use rock band instruments with their USB receivers. Any suggestions on how to re-enable that second port? (Wii is 4.3U, using d2x cIOS v10 beta 52 on 249/250).
Did you make sure the base IOSes are correct? cIOS 249 should be based off of 56, and 250 off of 57. Additionally, you can also have cIOS 251 based off of 58, as well. See this guide on the Complete Softmod Guide.

Also, what @alexander1970 mentioned, you need to know where to plug in your USB hub and your USB drive. If one setup doesn't work, plug them in differently and try again.
 
Last edited by HarveyHouston,

Malarkeyzone

New Member
OP
Newbie
Joined
Jan 30, 2021
Messages
4
Trophies
0
Age
22
XP
33
Country
United States
(Doing my best Lurch impression) You rang?

Did you make sure the base IOSes are correct? cIOS 249 should be based off of 56, and 250 off of 57. Additionally, you can also have cIOS 251 based off of 58, as well.

Also, what @alexander1970 mentioned, you need to know where to plug in your USB hub and your USB drive. If one setup doesn't work, plug them in differently and try again.

Thank you! I tried basically every configuration with the hub to no avail. GX won’t recognize my drive without being plugged directly into the right port, and with the hub attached to the other one it still doesn’t help with the instruments. Both 249 and 250 are in those correct bases, should I install 251? Would that help?
 
  • Like
Reactions: Alexander1970

HarveyHouston

The Christian Who Hacks Stuff
Member
Joined
Mar 24, 2019
Messages
1,233
Trophies
2
Location
The Point of Know Return
Website
gitlab.com
XP
928
Country
United States
Thank you! I tried basically every configuration with the hub to no avail. GX won’t recognize my drive without being plugged directly into the right port, and with the hub attached to the other one it still doesn’t help with the instruments. Both 249 and 250 are in those correct bases, should I install 251? Would that help?
Odd, cIOS 249 should be all that you need. You could try 251; if it still doesn't work, you might want to ask in RBC Discord, or mention someone who has better knowledge about Wii IOSes.
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: https://i.imgur.com/IXlPrt6.jpeg